FEM MeshGmshFromShape

From FreeCAD Documentation
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎русский

FEM MeshGmshFromShape.svg FEM MeshGmshFromShape

Menu location
Mesh → FEM mesh from shape by Gmsh
Workbenches
FEM
Default shortcut
None
Introduced in version
-
See also
FEM tutorial

Description

For a finite elements analysis the geometry needs to be discretized into a FEM Mesh. This command uses the program Gmsh (which needs to be installed on the system) for calculating the mesh.

Gmsh is bundled with the FreeCAD installation binaries. Alternatively you can install it separately from FreeCAD and then use the menu Edit → Preferences → FEM → Gmsh to set the path to the gmsh.exe.

Usage

  1. Select the shape you want to analyze. For volume FEM this needs to be a solid or compsolid. A compsolid is necessary if your part is made from multiple materials. (A compsolid can be created with the BooleanFragments command.)
    • Press the FEM MeshGmshFromShape.svg FEM MeshGmshFromShape button.
    • Select the Mesh → FEM MeshGmshFromShape.svg FEM mesh from shape by Gmsh option from the menu.
  2. Optionally edit the minimal and maximal element size. (Autodetection works fine unless you apply complicated boundary conditions.)
  3. Click the Apply button and wait for the computation of the mesh to complete
  4. Close the task. You now should see a new FEMMeshGMSH object in your active analysis container.

After the mesh has been crated you can change its properties using the property editor. After you changed a property, you must reopen the Gmsh dialog again and click the Apply button. (You can leave the dialog open while changing properties.)

Properties

  • DataAlgorithm2D: The algorithm to create 2D meshes. The different algorithms are explained here. For Delaunay, see Delaunay triangulation.
  • DataAlgorithm3D: The algorithm to create 3D meshes. The different algorithms are explained here.
  • DataCharacteristic Length Max: The maximal size of the mesh elements. If set to 0.0, the size will be set automatically. This property can also be changed in the Gmsh dialog in the field Max element size.
  • DataCharacteristic Length Min: The minimal size of the mesh elements. If set to 0.0, the size will be set automatically. This property can also be changed in the Gmsh dialog in the field Min element size.
  • DataCoherence Mesh:
    • true (default); duplicate mesh nodes will be removed
    • false
  • DataElement Dimension: The dimension of the mesh elements. This property can also be changed in the Gmsh dialog in the field Mesh element dimension.
    • From Shape (default); the dimension will be determined from the dimension of the object that is meshed
    • 1D
    • 2D
    • 3D
  • DataElement Order: The mesh element order. This property can also be changed in the Gmsh dialog in the field Mesh order. introduced in version 0.20
    • 1st
    • 2nd (default)
  • DataGeometrical Tolerance: The geometrical tolerance for the mesh to match the object edges. The default 0.0 means that Gmsh's default of 1e-8 is used.
  • DataGroups Of Nodes: All nodes and not only the elements will be saved for each physical mesh group. Physical groups are collections of mesh entities (points, curves, surfaces and volumes). They and are identified by their dimension and by a tag. For example a mesh of the same object region is internally tagged the same. So all surfaces of this region will form one physical group.
  • DataHigh Order Optimize: If and how meshes with DataElement Order = 2nd are optimized. The optimization is done by a deformation of the element borders.
    introduced in version 0.20 Gmsh supports different optimization algorithms. Elastic is an algorithm in which the mesh elements are treated as a collection of deformable viscoelastic solids. 1st order meshes cannot be optimized because their element borders are linear an cannot be deformed.
  • DataMesh Size From Curvature introduced in version 0.20: The number of mesh elements per times the radius of the curvature. To get a finer mesh at small corners or holes, this value can be increased for better results

FEM Gmsh-MeshSizeFromCurvature.png

Effect of Mesh Size From Curvature'; left: set to 12, right: deactivated

  • DataOptimize Netgen: Whether the mesh will be optimized using the 3D mesh generator Netgen to improve the quality of tetrahedral elements. Note: since Netgen can only create tetrahedral elements, this option is ignored for meshes whose DataElement Dimension is not 3D.
  • DataRecombination Algorithm introduced in version 0.20: The algorithm used for DataRecombine 3D All and also for DataRecombine All. For more info, see section Element Recombination and for technical details see the Gmsh documentation.
  • DataRecombine 3D All introduced in version 0.20: Applies a recombination 3D-algorithm to all volumes. Tetrahedra will be recombined into prisms, hexahedra or pyramids if possible.
  • DataRecombine All: Applies a recombination algorithm to all surfaces. Triangles will be recombined into quadrangles when possible.
  • DataOptimize Std Optimizes the mesh to improve the quality of tetrahedral elements.
  • DataSecond Order Linear: Option if second order nodes (if DataElement Order set to 2nd) and/or mesh refinement points are created by linear interpolation.
    • true; linear interpolation is used
    • false (default); curvilinear interpolation is used

Notes

Nonpositive Jacobians

When you get a meshing erro about nonpositive Jacobians, you can try out the following strategies:

  • Set DataSecond Order Linear to true but keep DataElement Order at 2nd.
  • Set DataElement Order to 1st.
  • Use a smaller element size by reducing the DataCharacteristic Length Max.
  • If solver ccxtools is used and the run button is used (not the task panel) the nodes of non positive jacobian elements will be green.

Mesh Growth

At edges and small geometric entities the mesh has to be smaller than in areas without edges. So the mesh element size grows away from edges. The growing strategy of Gmsh is to grow between edges with different sizes. So the growing fails when an area has the same sized edges like for example this tube:

FEM Gmsh-MeshGrowth-failing.png

Failing mesh growing because the cylindrical area is surrounded be the same edges

To enable a sensible mesh growing, you must in this case add an edge to the area. In the example this would be a circle in the middle of the cylinder. The circle is added as part of a BooleanFragments compound (to form a CompSolid), see the project file of the example.

FEM Gmsh-MeshGrowth-success.png

Sensible mesh growing due to the additional edge in the middle of the cylindrical aread

Element Recombination

Elements can be recombined in two ways, on the surface of objects so that triangles will be recombined into quadrangles if possible and in the volume of objects so that tetrahedra will be recombined into prisms, hexahedra or pyramids if possible. Thinking about the geometry, it becomes clear that the recombination result depends strongly on the geometry of the body and that recombining a 3D body only at the surface will mostly lead to strange results.

To illustrate this, look at the image below. A cuboid body is meshed using the standard settings (tetrahedra, 2nd order mesh). This is the subimage at the upper left. The image at the upper right shows the result, when additionally the elements are recombined only at the surface of the body. The result is bad because the changed surface elements don't fit to the unchanged volume elements. So DataRecombine All alone usually only makes sense for 2D meshes.
When we use now also DataRecombine 3D All, the result is better, see the lower left subimage. However, the result doesn't show a great difference compared to the mesh without recombinations. Since our body is a cuboid, it is therefore sensible to use a recombination algorithm that tries to create cuboids as well. And this result is shown in the subimage at the lower right.

The Simple recombination algorithm will leave some triangles in the mesh in case the recombining leads to badly shaped quads. In such cases use a full-quad recombination algorithm, which will automatically perform a coarser mesh followed by the recombination, smoothing and subdividing. See forum topic

FEM Gmsh-Recombination.png

Effect of mesh element recombination. Upper left: standard mesh, Upper right: recombination only at the surface using the Simple algorithm, Lower left: recombination at the surface and in the volume using the Simple algorithm, Lower right: recombination at the surface and in the volume using the Simple full-quad algorithm