Tutorial pentru atelierul Desen 2D (Draft)

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft tutorial and the translation is 2% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎

Introducere

Acest îndrumător este menit să deprindă utilizatorul cu elementele de bază ale unui flux de operaţii bazat pe Panoul Ciornă (Draft), printre care se numără crearea de profile, folosirea planurilor active, crearea dimensiunilor de cotare, textelor şi notelor. Acest îndrumător foloseşte notarea (X, Y, Z) pentru desemnarea coordonatelor necesare pentru definirea diferitelor puncte într-un obiect.

This tutorial was originally written by Drei, and it was rewritten and illustrated by vocx.

This tutorial is meant to introduce the reader to the basic workflow of the Workbench Draft.svg Draft Workbench.

The reader will practice:

  • creation of lines, arcs, and polygons
  • the use of working planes
  • the creation of dimensions, text, and shapestrings
  • the creation of a technical drawing

This tutorial uses the notation (x, y, z) to denote the coordinates required to define points in an object. The default unit is millimeters mm.

00 Dr01 Draft Tutorial final.png

Final drawing including various Draft objects.


Cerinţe

  • FreeCAD versiunea 0.16 sau anterioară
  • Cititorul cunoaşte cum se folosesc tab-urile Date şi Vedere pentru a schimba proprietăţile unui element atunci când doreşte acest lucru.

1. Open FreeCAD, create a new empty document with File → Std New.svg New.

1.1. Switch to the Draft Workbench from the workbench selector, or the menu View → Workbench → Draft.
1.2. Make sure you understand how to use the property editor, particularly the Data and View tabs to change the properties.
1.3. Since the Draft objects are planar shapes, they are better viewed from the top. Use Std ViewTop.svg View top to set the 3D view.
1.4. Although it is not used in this tutorial, the Draft grid is helpful to position geometrical elements. Use Draft SelectPlane.svg SelectPlane to set both the working plane and the grid, and then show and hide the grid with Draft ToggleGrid.svg Toggle grid.

Cum se procedează

Este obligatoriu să vă asigurați că bara de instrumente Ciornă Ancorare (Draft Snap toolbar) va fi disponibilă pentru utilizare pe parcursul operaţiilor din acest îndrumător.

  1. Porniţi FreeCAD.
  2. Dacă nu ați deschis un nou document FreeCAD (cea mai mare parte a ferestrei FreeCAD se prezintă ca fiind gri), din meniul derulant, faceți clic pe Fișier, apoi pe Nou sau faceți clic pe instrumentul Creați un document nou Document-new.svg.
  3. Activați panoul Ciornă (Draft );
  4. Selectați meniul Editare;
  5. Faceți clic pe Preferințe;
  6. Mergeți la Ciornă (Draft ) și selectați tab-ul Grilă și ancorare (Grid and snapping);
  7. Verificați dacă bara de instrumente Arată bara Ciornă Ancorare (Show Draft Snap toolbar) este activă.

Rețineți că puteți modifica vizibilitatea Grilei din acest meniu, în cazul în care doriți să o dezactivați.

Folosirea planelor

Planele sunt folosite pentru a delimita efectul uneltelor din Ciornă la un anumit plan, evitând astfel problemele cu localizarea punctelor și curbelor în piesele complexe. Planele pot să se refere la axele sistemului de coordonate (XY, YZ, ...) sau pot să folosească o suprafață plană din document ca referință.

Most Draft objects are planar shapes so they are naturally based on a working plane. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.

  1. Selectați Draft SelectPlane.png Alegeţi planul de lucru. Acesta poate fi localizat în Bara de unelte Panou Ciornă sau în Meniul Ciornă din secţiunea Unelte pentru crearea de ciorne.
  2. Selectați planul XY.

Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.

Linii și Arce
  1. Selectați Draft Arc.png Arc.
  2. Setați centrul la (0, 0, 0).
  3. Setați raza la 30 mm.
  4. Unghiul de pornire este de 60,0°.
  5. Deschiderea este de 60,0°.

Repetați procedeul pentru trasarea unui al doilea arc cu o rază de 25 mm. Celelalte proprietăți rămân neschimbate.

  1. Selectaţi Draft Line.png Linie.
  2. Îndreptaţi-vă către capătul oricărui arc. Când cursorul Dvs. Snap Endpoint.png se va apropia de punctul de terminare, la apropierea de el, punctul va deveni alb.
  3. Selectaţi capătul celuilalt arc şi uniţi.
  4. Repetaţi operaţia în cealaltă parte a arcelor.

01 Dr01 Draft Arc profile.png

Closed profile created by two arcs and two lines.


Fusing or compounding

Acum avem mai multe curbe care descriu un profil, însă acesta nu este recunoscut ca o entitate de sine stătătoare. Se poate continua lucrul cu elementele nemodificate, totuşi în acest caz vom prefera să le unim într-un singur obiect.

  1. Selectaţi un arc şi o linie în timp ce apăsaţi tasta CTRL
  2. Daţi clic pe Draft Upgrade.png Actualizare

6b. If you wish to maintain the parametric nature of the objects you may wish to create a compound instead.

6.1. Switch to the Part Workbench.
6.2. With these objects selected, click on Part Compound.svg Part Compound.
Plane, dreptunghiuri şi cercuri
  1. Daţi clic pe Draft Rectangle.png Dreptunghi
  2. Setaţi coordonatele primului punct la (-100, -60, 0)
  3. Setaţi coordonatele celui de-al doilea punct la (140, 90, 0)

7. We will draw a rectangular frame.

7.1. Press Draft Rectangle.svg Rectangle.
7.2. Enter the values of the first point (-100, -60, 0), and press Enter.
7.3. Make sure the Relative option is unchecked, as we will use absolute units. You may press R in the keyboard to quickly toggle this option on and off.
7.4. Enter the values for the second point (140, 90, 0), and press Enter.

Rezultatul este un Plan. Aspectul lui pot fi modificat prin clic dreapta: dacă doriţi înlăturarea suprafeţei de umplere, schimbaţi Stil de desenare în Cadru cu linii (Wireframe).

  1. Selectaţi Draft Circle.png
  2. Setaţi coordonatele centrului la (0, 0, 0)
  3. Setaţi raza ca 15 mm
Polygons
  1. Selectaţi Draft Polygon.png Poligon
  2. Punctul central este localizat la (0, 0, 0).
  3. Setaţi raza la 50 mm.
  4. Selectaţi ca număr de laturi 6.

Again, you may change the DataMake Face and ViewDisplay Mode properties in the property editor if you want.

The rectangle, the circle, the polygon, and most other objects created with the Draft Workbench share many data and view properties because they are derived from the same base class, Part Part2DObject.

02 Dr01 Draft Rectangle circle polygon.png

Rectangle, circle and polygon added.


Matrici (tablouri)

Matricile sunt folosite pentru a replica un obiect de mai multe ori pe o direcție, după o axă de rotație sau de-a lungul unei căi.

  1. Selectaţi Cablul creat anterior
  2. Daţi clic pe Draft Array.png Matrici
  3. În tab-ul Date al objectului, schimbaţi tipul matricii din orto în polar
  4. Schimbaţi Numărul polar din 1 în 3

Arrays are used to replicate an object several times in an orthogonal direction (X, Y, Z), around a revolution axis, or along a path.

10. We will create a polar array.

10.1. Select the Wire object that was previously created with the Draft Upgrade.svg Upgrade tool, or the Compound created with the Part Compound.svg Part Compound tool.
10.2. Press Draft PolarArray.svg PolarArray.
10.3. Adjust the polar angle to 360°, and press OK.

Old workflow

10.2. Press Draft Array.svg Array.
10.3. Go to the tree view, select the Array object, and then go to the property editor, and change the DataArray Type from ortho to polar.
10.4. Change DataNumber Polar to 4, and DataAngle to 360°.

The array object shows copies of the object around the origin.

03 Dr01 Draft PolarArray.png

Polar array of the small profile centered around the origin.


Adăugaţi dimensiunile de cotare

Dimensiunile de cotare necesită o utilizare constantă a ancorării constrângerilor pentru a selecta corect punctele pe care doriți să le folosiţi la dimensionare. Pentru a schimba selectarea punctelor posibile, se va utiliza bara de instrumente Ancorare.

Linear dimensions work best when using the appropriate Draft Snap methods to select points and edges to measure. However, they can also be created by specifying absolute coordinates.

  1. Selectați Draft Dimension.png Dimension
  2. Selectați primul punct. Acesta poate să fie un element existent, fie specificat de coordonate. Pentru acest tutorial, primul punct va fi întotdeauna la (0, 0, 0)
  3. Selectați al doilea punct. Abordați punctul de mijloc al liniei de sus a poligonului. Un punct alb trebuie să apară lângă această pictogramă Snap Midpoint.png
  4. Mutați cursorul în locația dorită a dimensiunii și dați clic pe ea.
  5. Schimbați dimensiunea fontului în View tab la 6 mm

Repetați procesul pentru arcuri de cerc și cercuri.

13. Repeat the process for the circle located in the center. The first point of the measurement will still be the origin. To select the second point make sure Draft ToggleSnap.svg Toggle snap is active, and only Draft Angle.svg Angle as well. As you move the pointer to the top of the circle, the Draft Angle.svg Angle icon should appear; click to select this point. Then move the cursor to the right, and click to fix the dimension.

Remember to adjust the ViewFont Size, and other properties to see the dimension correctly.

04 Dr01 Draft Dimension.png

Dimensions that measure the vertical distance from the origin to the top of the circle, arcs, and polygon.


Adnotări şi text

Între cele două, există doar o diferență de nuanţă : textul oferă un profil ce poate fi utilizat pentru a efectua modelări 3D.

Annotations
  1. Selectaţi Draft Text.png Text
  2. Selectaţi punctul de referinţă în Vedere 3D. In acest caz, este punctul de mijloc al arcului de sus.
  3. Introduceţi textul şi apăsaţi tasta Enter. Repetaţi pentru fiecare linie de text pe care doriţi s-o introduceţi.
  4. Ca să terminaţi, apăsaţi tasta Enter de două ori.
Text
  1. Selectaţi Draft ShapeString.png ShapeString
  2. Selectaţi punctul de referinţă în Vederea 3D View. Acesta poate fi un punct existent sau dat de poziţia curentă a cursorului.
  3. Introduceţi textul şi apăsaţi tasta Enter.
  4. Setaţi mărimea literelor.
  5. Păstraţi urma (tracking) de 0 mm
  6. Selectaţi calea de acces către fişierul tipului de font pe care doriţi să-l folosiţi (dacă lăsaţi gol, se va folosi fontul implicit)

05 Dr01 Draft Text ShapeString.png

Text and ShapeString objects added.


To extrude letters and engrave them on to solids, see the Draft ShapeString tutorial.

Crearea planşelor

Pentru a realiza planşe, este necesară crearea unei pagini Desenare cu elementele pe care doriţi să le folosiţi. Vă rugăm să citiţi Îndrumător pentru Desenare pentru o descriere detaliată.

As it is now, the objects that we have created can be saved, exported to other formats like SVG or DXF, or printed.

If you wish, you may create a technical drawing to display these objects together with additional information like a frame.

Before doing anything, hide the Draft grid by pressing Draft ToggleGrid.svg Toggle grid.

16. Switch to the Workbench TechDraw.svg TechDraw Workbench.

16.1. Create a standard page by pressing TechDraw PageDefault.svg TechDraw PageDefault.
16.2. In the tree view select all objects created, except for the Page, and then press TechDraw ActiveView.svg TechDraw ActiveView. Press OK with the default options; it may take a few seconds to create the view in the page.
16.3. Selecting the Page object in the tree view will automatically display the Page in the main window. With the Page selected, go to the property editor, and change DataScale to 0.75.
16.4. Expand the Page object in the tree view to select the ActiveView object. With this view selected, go to the property editor, and change DataScale Type to Page.
16.5. Recompute the model by using Std Refresh.svg Refresh or pressing F5.
16.6. Hide the frames of the objects by pressing TechDraw ToggleFrame.svg TechDraw ToggleFrame.

Learn more about the TechDraw Workbench by reading the Basic TechDraw Tutorial.

06 Dr01 Draft TechDraw page.png

TechDraw page with a projection of the shapes created with the Draft Workbench.


TechDraw works best with objects that have a Part TopoShape. Since some objects from Draft, like Draft Texts and Draft Dimensions, don't have such "shapes", some operations of TechDraw don't work with these elements.

Tools like TechDraw ActiveView.svg TechDraw ActiveView, TechDraw DraftView.svg TechDraw DraftView, and TechDraw ArchView.svg TechDraw ArchView work by receiving an internal SVG image that is generated by internal Draft functions; therefore, TechDraw doesn't have much control about how these views are displayed. More integration of Draft and TechDraw is a work in progress.

Aici se termină şirul de operaţii elementare ce pot fi realizate cu panoul Ciornă (Draft).

The Draft Workbench in many ways is similar to the Sketcher Workbench, as both are intended to produce 2D shapes. The main difference is in the way each workbench handles coordinate systems, and how the objects are positioned. In Draft, objects are freely positioned in the global coordinates system, usually snapping their points to a grid, or to other objects. In Sketcher, a "sketch object" defines a local coordinate system which serves as the reference for all geometrical elements within that sketch. Moreover, the sketch relies on "constraints" to define the final position of its points.

  • The Sketcher Workbench is intended for 2D drawings that require precise relationships between its points. It does not rely on a grid, but on rules of positioning (constraints) to determine where the points and edges will be placed. The Sketcher Workbench is mostly used together with the PartDesign Workbench for the creation of solid bodies.

Template:Tutorials navi/ro