Tutorial di Draft

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft tutorial and the translation is 2% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎

Introduzione

Questo tutorial ha lo scopo di introdurre il lettore al flusso di lavoro di base dell'ambiente Draft, che prevede la creazione di profili, l'uso di piani di lavoro, e la creazione delle dimensioni, testo e annotazioni. Questo tutorial utilizza la notazione (X, Y, Z) per indicare le coordinate necessarie per definire i punti in un oggetto.

This tutorial was originally written by Drei, and it was rewritten and illustrated by vocx.

This tutorial is meant to introduce the reader to the basic workflow of the Workbench Draft.svg Draft Workbench.

The reader will practice:

  • creation of lines, arcs, and polygons
  • the use of working planes
  • the creation of dimensions, text, and shapestrings
  • the creation of a technical drawing

This tutorial uses the notation (x, y, z) to denote the coordinates required to define points in an object. The default unit is millimeters mm.

00 Dr01 Draft Tutorial final.png

Final drawing including various Draft objects.


Requisiti

  • FreeCAD versione 0.16 o superiore
  • Il lettore sappia come usare le schede Dati e Vista per modificare le proprietà di un elemento se lo desidera

1. Open FreeCAD, create a new empty document with File → Std New.svg New.

1.1. Switch to the Draft Workbench from the workbench selector, or the menu View → Workbench → Workbench Draft.svg Draft.
1.2. Make sure you understand how to use the property editor, particularly the Data and View tabs to change the properties.
1.3. Since the Draft objects are planar shapes, they are better viewed from the top. Use Std ViewTop.svg View top to set the 3D view.
1.4. Although it is not used in this tutorial, the Draft grid is helpful to position geometrical elements. Use Draft SelectPlane.svg SelectPlane to set both the working plane and the grid, and then show and hide the grid with Draft ToggleGrid.svg Toggle grid.

Procedura

Accertarsi che la barra degli strumenti Snap sia disponibile e possa essere utilizzata in questo tutorial.

  1. Avviare FreeCAD
  2. Se non c'è un nuovo documento di FreeCAD aperto (la maggior parte della finestra FreeCAD è grigia), dal menu a discesa fare clic su File -> Nuovo o fare clic sullo strumento Crea un nuovo documento Document-new.svg.
  3. Attivare l'ambiente Draft
  4. Selezionare il menu Modifica
  5. Cliccare su Preferenze
  6. Andare in Draft e selezionare la scheda Griglia e snap
  7. Verificare che Mostra la barra degli strumenti snap sia attiva

Notare che in questo menu è possibile modificare la visibilità della griglia, nel caso in cui si desidera disattivarla.

Usare i piani

I piani sono usati per limitare l'azione degli strumenti Draft ad un piano specifico, evitando problemi con la posizione dei punti e delle curve nei pezzi complessi. I piani possono fare riferimento agli assi del sistema di coordinate (XY, YZ, ...) oppure possono utilizzare come riferimento una superficie planare del documento.

Most Draft objects are planar shapes so they are naturally based on a working plane. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.

  1. Selezionare Draft SelectPlane.png Seleziona piano. Può essere situato all'interno della barra degli strumenti di Draft o nella sezione Utilità del menu Draft.
  2. Selezionare il piano XY

Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.

Linee e Archi

  1. Selezionare Draft Arc.png Arco.
  2. Impostare il centro a (0, 0, 0)
  3. Impostare il raggio a 30 mm
  4. Impostare starting angle a 60.0°
  5. Impostare l'ampiezza a 60.0°

Ripetere la stessa procedura per un secondo arco con raggio di 25 mm, e con le altre proprietà invariate.

  1. Selezionare Draft Line.png Linea.
  2. Avvicinare il cursore al Punto finale di un arco. Dovrebbe apparire un punto bianco, accanto a questa icona Snap Endpoint.png.
  3. Selezionare il punto finale dell'altro arco.
  4. Ripetere per l'altro lato degli archi.

01 Dr01 Draft Arc profile.png

Closed profile created by two arcs and two lines.


Fusing or compounding

Ora ci sono diverse curve che definiscono il profilo, ma esse non sono ancora riconosciute come una singola entità. È possibile continuare a lavorare con gli elementi separati, ma in questo caso verranno fusi in un unico oggetto.

  1. Selezionare un arco e tenendo premuto il tasto Ctrl selezionare i due segmenti di linea e l'altro arco.
  2. Con questi quattro oggetti selezionati, fare clic su Draft Upgrade.png Upgrade

6b. If you wish to maintain the parametric nature of the objects you can create a compound instead.

6b.1. Switch to the Part Workbench.
6b.2. With these objects selected, click on Part Compound.svg Part Compound.

Piani, Rettangoli e Cerchi

  1. Cliccare Draft Rectangle.png Rettangolo
  2. Impostare il primo punto a (-100, -60, 0). (Se dopo aver impostato questo punto Relativo appare attivato, deselezionarlo prima di impostare il secondo punto).
  3. Impostare il secondo punto a (140, 90, 0)

7. We will draw a rectangular frame.

7.1. Press Draft Rectangle.svg Rectangle.
7.2. Enter the values of the first point (-100, -60, 0), and press Enter.
7.3. Make sure the Relative option is unchecked, as we will use absolute units. You may press R in the keyboard to quickly toggle this option on and off.
7.4. Enter the values for the second point (140, 90, 0), and press Enter.

Il risultato è un Piano. Le sue proprietà possono essere modificate per rimuovere il Riempimento, cambiando la sua Visualizzazione in Wireframe.

  1. Selezionare Draft Circle.png
  2. Impostare il centro a (0, 0, 0)
  3. Impostare il raggio a 15 mm

Poligoni

  1. Selezionare Draft Polygon.png Poligono
  2. Il centro è posizionato a (0, 0, 0)
  3. Impostare il numero di lati a 6
  4. Impostare il raggio 50 mm

Again, you may change the DataMake Face and ViewDisplay Mode properties in the property editor if you want.

The rectangle, the circle, the polygon, and most other objects created with the Draft Workbench share many data and view properties because they are derived from the same base class, Part Part2DObject.

02 Dr01 Draft Rectangle circle polygon.png

Rectangle, circle and polygon added.


Schiere

Gli array sono utilizzati per replicare più volte un oggetto in una direzione, rispetto un asse di rotazione o lungo un percorso.

  1. Selezionare il Wire creato in precedenza
  2. Cliccare Draft Array.png Schiera
  3. Nella scheda Dati dell'oggetto, cambiare il tipo di schiera da ortho a polar
  4. Cambiare Number Polar da 1 a 3

Arrays are used to replicate an object several times in an orthogonal direction (X, Y, Z), around a revolution axis, or along a path.

10. We will create a polar array.

10.1. Select the Wire object that was previously created with the Draft Upgrade.svg Upgrade tool, or the Compound created with the Part Compound.svg Part Compound tool.
10.2. Press Draft PolarArray.svg PolarArray.
10.3. Adjust the polar angle to 360°.
10.4. Set the number of elements to 4.
10.5. Enter the values for the center of rotation (0, 0, 0), and press Enter.

Old workflow

10.2. Press Draft Array.svg Array.
10.3. Go to the tree view, select the Array object, and then go to the property editor, and change the DataArray Type from ortho to polar.
10.4. Change DataNumber Polar to 4, and DataAngle to 360°.

The array object shows copies of the object around the origin.

03 Dr01 Draft PolarArray.png

Polar array of the small profile centered around the origin.


Aggiungere le dimensioni

Le Dimensioni richiedono un uso costante di Snap per selezionare correttamente i punti che si vogliono quotare. La Barra degli strumenti Snap serve per cambiare i punti che è possibile selezionare.

Linear dimensions work best when using the appropriate Draft Snap methods to select points and edges to measure. However, they can also be created by specifying absolute coordinates.

  1. Selezionare Draft Dimension.png Dimensione
  2. Selezionare il primo punto. Questo può essere fatto cliccando su un elemento o specificando le coordinate di un punto esistente. In questo tutorial, il primo punto è sempre (0, 0, 0)
  3. Selezionare il secondo punto. Avvicinando il cursore al punto medio della linea superiore del poligono, dovrebbe apparire un punto bianco accanto questa icona Snap Midpoint.png
  4. Spostare il cursore fino alla posizione desiderata della dimensione e fare clic.
  5. Nella tabella Vista cambiare la dimensione del carattere in 6 mm

Ripetere il processo per gli archi ed i cerchi.

13. Repeat the process for the circle located in the center. The first point of the measurement will still be the origin. To select the second point make sure Draft ToggleSnap.svg Toggle snap is active, and only Draft Angle.svg Angle as well. As you move the pointer to the top of the circle, the Draft Angle.svg Angle icon should appear; click to select this point. Then move the cursor to the right, and click to fix the dimension.

Remember to adjust the ViewFont Size, and other properties to see the dimension correctly.

04 Dr01 Draft Dimension.png

Dimensions that measure the vertical distance from the origin to the top of the circle, arcs, and polygon.


Annotazioni e Testi

Sono due cose leggermente diverse: per eseguire delle operazioni 3D è possibile usare solo i testi come profilo.

Annotazioni

  1. Selezionare Draft Text.png Testo
  2. Selezionare il punto di riferimento nella Vista 3D. In questo caso, il punto medio dell'arco superiore.
  3. Inserire il testo e premere Invio. Ripetere l'operazione per tutte le righe di testo come si desidera inserire.
  4. Premere Invio

Testo

  1. Selezionare Draft ShapeString.png ShapeString
  2. Selezionare il punto di riferimento nella Vista 3D. Questo può essere un punto esistente o la posizione corrente del cursore.
  3. Inserire il testo e premere Invio
  4. Impostare la dimensione del carattere
  5. Lasciare tracking a 0 mm
  6. Selezionare il percorso per il file di font che si desidera utilizzare

05 Dr01 Draft Text ShapeString.png

Text and ShapeString objects added.


To extrude letters and engrave them on to solids, see the Draft ShapeString tutorial.

Creare le proiezioni

Per creare le proiezioni, è necessario creare un Disegno con gli elementi che si desidera utilizzare. Si prega di leggere il Tutorial di Drawing per avere una descrizione dettagliata.

As it is now, the objects that we have created can be saved, exported to other formats like SVG or DXF, or printed.

If you wish, you may create a technical drawing to display these objects together with additional information like a frame.

Before doing anything, hide the Draft grid by pressing Draft ToggleGrid.svg Toggle grid.

16. Switch to the Workbench TechDraw.svg TechDraw Workbench.

16.1. Create a standard page by pressing TechDraw PageDefault.svg TechDraw PageDefault.
16.2. In the tree view select all objects created, except for the Page, and then press TechDraw ActiveView.svg TechDraw ActiveView. Press OK with the default options; it may take a few seconds to create the view in the page.
16.3. Selecting the Page object in the tree view will automatically display the Page in the main window. With the Page selected, go to the property editor, and change DataScale to 0.75.
16.4. Expand the Page object in the tree view to select the ActiveView object. With this view selected, go to the property editor, and change DataScale Type to Page.
16.5. Recompute the model by using Std Refresh.svg Refresh or pressing F5.
16.6. Hide the frames of the objects by pressing TechDraw ToggleFrame.svg TechDraw ToggleFrame.

Learn more about the TechDraw Workbench by reading the Basic TechDraw Tutorial.

06 Dr01 Draft TechDraw page.png

TechDraw page with a projection of the shapes created with the Draft Workbench.


TechDraw works best with objects that have a Part TopoShape. Since some objects from Draft, like Draft Texts and Draft Dimensions, don't have such "shapes", some operations of TechDraw don't work with these elements.

Tools like TechDraw ActiveView.svg TechDraw ActiveView, TechDraw DraftView.svg TechDraw DraftView, and TechDraw ArchView.svg TechDraw ArchView work by receiving an internal SVG image that is generated by internal Draft functions; therefore, TechDraw doesn't have much control about how these views are displayed. More integration of Draft and TechDraw is a work in progress.

Il flusso di lavoro di base per l'ambiente Draft è concluso.

The Draft Workbench in many ways is similar to the Sketcher Workbench, as both are intended to produce 2D shapes. The main difference is in the way each workbench handles coordinate systems, and how the objects are positioned. In Draft, objects are freely positioned in the global coordinates system, usually snapping their points to a grid, or to other objects. In Sketcher, a "sketch object" defines a local coordinate system which serves as the reference for all geometrical elements within that sketch. Moreover, the sketch relies on "constraints" to define the final position of its points.

  • The Sketcher Workbench is intended for 2D drawings that require precise relationships between its points. It does not rely on a grid, but on rules of positioning (constraints) to determine where the points and edges will be placed. The Sketcher Workbench is mostly used together with the PartDesign Workbench for the creation of solid bodies.