Tutoriel Draft

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft tutorial and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎
Base ExampleCommandModel.png Tutoriel
Thème
Drafting
Niveau
Débutant
Temps d'exécution estimé
30 minutes
Auteur(s)
Drei et vocx
Version de FreeCAD
0.19
Fichier(s) exemple(s)
Draft tutorial updated


Introduction

Ce tutoriel a été écrit à l'origine par Drei et a été écrit et illustré par vocx.

Ce tutoriel est destiné à présenter au lecteur le flux de travail de base de l'Atelier Draft Workbench Draft.svg.

Le lecteur pratiquera:

  • création de lignes, d'arcs et de polygones
  • l'utilisation d'avions de travail
  • la création de dimensions, de texte et de formes à partir de texte
  • la création d'un dessin technique

Ce tutoriel utilise la notation (x, y, z) pour désigner les coordonnées nécessaires pour définir des points dans un objet. L'unité par défaut est le millimètre mm.

00 Dr01 Draft Tutorial final.png

Dessin final comprenant divers objets Draft.

Installation

1. Ouvrez FreeCAD, créez un nouveau document vide avec Fichier → Std New.svg Nouveau.

1.1. Basculez vers l'atelier Draft depuis le sélecteur d'atelier ou le menu Affichage → Atelier → Workbench Draft.svg Draft.
1.2. Assurez-vous de comprendre comment utiliser l'éditeur de propriétés, en particulier les onglets Données et Affichage pour modifier les propriétés. Lors de la modification des propriétés, vous devrez peut-être effectuer une action Std Refresh.svg Std Rafraîchir pour voir le résultat dans la vue 3D.
1.3. Comme les objets Draft sont des formes planes, ils sont mieux vus du dessus. Utilisez Std ViewTop.svg vue de dessus pour définir la Vue 3D.
1.4. Bien qu'elle ne soit pas utilisée dans ce tutoriel, la grille Draft est utile pour positionner des éléments géométriques. Utilisez Draft SelectPlane.svg Plan de travail pour définir à la fois le plan de travail et la grille, puis affichez et masquez la grille avec Draft ToggleGrid.svg Visibilité de la grille.

Verrouillage de la barre d'outils

2. L'Draft Accrochage est normalement activée lorsque vous basculez vers atelier Draft.

2.1. Pour vous assurer qu'il est toujours là, allez dans Draft Préférences, Edition → Préférences → Draft → onglet: Grille et accrochage.
2.2. Vérifiez que la barre d'outils Montrer la barre d'outils d'accrochage est active.

Vous pouvez aussi changer la visibilité et les propriétés de la grille Draft dans cette même fenêtre.

Plans de travail

La plupart des objets Draft sont des formes planes, ils sont donc naturellement basés sur un plan de travail. Un plan de travail peut être l'un des plans de coordonnées globaux principaux XY, XZ et YZ, ou il peut s'agir d'un plan qui leur est parallèle avec un décalage positif ou négatif, ou il peut s'agir d'un plan défini par la face d'un objet solide.

3. Appuyez sur Draft SelectPlane.svg SelectPlane ou allez dans le menu Utilities → Draft SelectPlane.svg Select plane pour ouvrir le plan de travail Panneau des tâches.

3.1. Appuyez sur Std ViewTop.svg Top (XY).

Avant d'appuyer sur le bouton, vous pouvez également modifier la valeur du décalage en millimètres, ainsi que l'espacement de la grille, les lignes principales et le rayon d'accrochage.

Lignes et arcs

4. Nous allons créer des arcs et des lignes.

4.1. Appuyez sur Draft Arc.svg Arc.
4.2. Définissez Center sur (0, 0, 0) et appuyez sur Validez.
4.3. Réglez Radius sur 30 mm et appuyez sur Validez.
4.4. Réglez Start angle sur 60.0° et appuyez sur Validez.
4.5. Réglez Aperture angle sur 60.0° et appuyez sur Validez.
4.6. Répétez la même procédure pour un deuxième arc avec un rayon de 25 mm, les autres propriétés sont les mêmes.

5. Nous allons maintenant créer un profil fermé en liant les arcs avec des lignes.

5.1. Appuyez sur Draft Line.svg Ligne.
5.2. Dans la Barre d'outils Accrochage, assurez-vous que Draft Snap Lock.svg Activer/désactiver l'accrochage est actif et que Draft Snap Endpoint.svg Terminaison également. Lorsque vous déplacez le pointeur sur l'arc et à proximité de l'un de ses extrémités, l'icône Draft Snap Endpoint.svg Terminaison doit apparaître. De plus, le point cible est mis en valeur par un grand point blanc. Cliquez pour sélectionner ce point.
5.3. Déplacez le pointeur vers l'extrémité la plus proche de l'autre arc pour lier les deux arcs ensemble.
5.4. Répétez le processus pour l'autre côté de l'arc pour fermer le profil.

01 Dr01 Draft Arc profile.png

Profil fermé créé par deux arcs et deux lignes.

Fusion ou composition

Nous avons maintenant plusieurs objets dans la Vue en arborescence qui forment un profil fermé. Cependant, ce profil est toujours composé d'objets déconnectés. Chacun d'eux peut être édité et déplacé indépendamment des autres. Il est possible de continuer à travailler avec les éléments de cette manière mais il est également possible de les fusionner en un seul objet.

6a. Notez que fusionner les objets en un seul objet créera un objet qui n'est plus paramétrique, de sorte que leurs propriétés ne peuvent plus être modifiées.

6a.1. Sélectionnez les quatre objets dans la Vue en arborescence ou en maintenant Ctrl et en les sélectionnant dans la Vue 3D.
6a.2. Une fois ces objets sélectionnés, cliquez sur Draft Upgrade.svg Mettre à niveau.
6a.3. Cela mettra à niveau les quatre objets en un seul Wire.

6b. Si vous souhaitez conserver la nature paramétrique des objets, vous pouvez créer un composé à la place.

6b.1. Basculez vers Workbench Part.svg atelier Part.
6b.2. Une fois ces objets sélectionnés, cliquez sur Part Compound.svg Part Composé.

Rectangles, cercles et polygones

7. Nous allons dessiner un cadre rectangulaire. (retournez vers l'Workbench Draft.svg atelier Draft.)

7.1. Appuyez sur Draft Rectangle.svg Rectangle.
7.2. Entrez les valeurs du premier point (-100, -60, 0) et appuyez sur Validez.
7.3. Assurez-vous que l'option Relative n'est pas cochée, car nous utiliserons des unités absolues. Vous pouvez appuyer sur R sur le clavier pour activer et désactiver rapidement cette option.
7.4. Entrez les valeurs du deuxième point (140, 90, 0) et appuyez sur Validez.

Un rectangle est créé. Allez dans l'Éditeur de propriétés pour modifier ses propriétés. Si vous ne voulez pas que le rectangle crée une face, définissez DonnéesMake Face sur false. Si vous voulez créer une face mais ne voyez que les fils de cet objet, conservez DonnéesMake Face sur true mais réglez VueDisplay Mode sur Wireframe.

8. Nous allons dessiner un cercle.

8.1. Appuyez sur Draft Circle.svg Cercle.
8.2. Entrez les valeurs du centre (0, 0, 0) et appuyez sur Validez.
8.3. Définissez le rayon sur 15 mm et appuyez sur Validez.

9. Nous allons dessiner un polygone régulier.

9.1. Appuyez sur Draft Polygon.svg Polygone.
9.2. Entrez les valeurs du centre (0, 0, 0) et appuyez sur Validez.
9.3. Définissez le nombre de côtés sur 6 et appuyez sur Validez.
9.4. Définissez le rayon sur 50 mm et appuyez sur Validez.

Encore une fois, vous pouvez modifier les propriétés DonnéesMake Face et VueDisplay Mode dans l'Éditeur de propriétés si vous le souhaitez.

Le rectangle, le cercle, le polygone et la plupart des autres objets créés avec l'atelier Draft partagent de nombreuses données et propriétés d'affichage car ils sont dérivés de la même classe de base, Part Part2DObject.

02 Dr01 Draft Rectangle circle polygon.png

Rectangle, cercle et polygone ajoutés.

Réseaux

Les réseaux sont utilisés pour répliquer un objet plusieurs fois dans une direction orthogonale (X, Y, Z) autour d'un axe de révolution ou le long d'une trajectoire.

10. Nous allons créer un réseau polaire.

10.1. Sélectionnez l'objet Wire qui a été précédemment créé avec l'outil Draft Upgrade.svg Mettre à niveau ou Compound créé avec l'outil Part Compound.svg Part Composé.
10.2. Appuyez sur Draft PolarArray.svg Réseau polaire.
10.3. Ajustez l'angle polaire sur 360°.
10.4. Définissez le nombre d'éléments sur 4.
10.5. Saisissez les valeurs du centre de rotation (0, 0, 0) et appuyez sur Validez.

Ancien processus de travail

10.2. Appuyez sur Draft Array.svg Réseau.
10.3. Accédez à la Vue en arborescence, sélectionnez l'objet Array, puis allez dans l'Éditeur de propriétés et changez DonnéesArray Type de ortho à polar.
10.4. Remplacez DonnéesNumber Polar par 4 et DonnéesAngle par 360°.

L'objet réseau montre des copies de l'objet autour de l'origine.

03 Dr01 Draft PolarArray.png

Réseau polaire du petit profil centré autour de l'origine.

Cotes

Les cotes linéaires fonctionnent mieux lorsque vous utilisez les méthodes d'Accrochage appropriées pour sélectionner les points et les arêtes à mesurer. Cependant, ils peuvent également être créés en spécifiant des coordonnées absolues.

11. Créez des dimensions pour les différents objets.

11.1. Appuyez sur Draft Dimension.svg Dimension.
11.2. Choisissez le premier point. Dans ce tutoriel, le premier point sera toujours l'origine (0, 0, 0).
11.3. Dans la Barre d'outils Accrochage, assurez-vous que Draft Snap Lock.svg Bascule l'accrochage est actif et que Draft Snap Midpoint.svg Milieu également. Lorsque vous déplacez le pointeur vers le bord supérieur du polygone, l'icône Draft Snap Midpoint.svg Milieu doit apparaître; cliquez pour sélectionner ce point.
11.4. Déplacez le curseur vers la droite pour spécifier l'emplacement de la dimension, puis cliquez pour définir la position finale, autour de (100, 20, 0). La cote affichera automatiquement la valeur de longueur mesurée entre les deux points.
11,5. Sélectionnez l'objet dimension dans la Vue en arborescence et dans l'Éditeur de propriétés remplacez VueFont Size par 6 mm, définissez VueExt Lines à 45 mm et VueShow Unit à false.

12. Répétez le processus pour les deux arcs du profil fermé. Le premier point de la mesure sera toujours l'origine et le second point utilisera le Draft Snap Midpoint.svg Milieu de l'arc.

13. Répétez le processus pour le cercle situé au centre. Le premier point de la mesure sera toujours l'origine. Pour sélectionner le deuxième point, assurez-vous que Draft Snap Lock.svg Bascule de l'accrochage est actif et que seul Draft Snap Angle.svg Angle également. Lorsque vous déplacez le pointeur vers le haut du cercle, l'icône Draft Snap Angle.svg Angle doit apparaître. Cliquez pour sélectionner ce point. Déplacez ensuite le curseur vers la droite et cliquez pour fixer la cote.

N'oubliez pas d'ajuster VueFont Size et d'autres propriétés pour voir correctement la dimension.

04 Dr01 Draft Dimension.png

Cotes qui mesurent la distance verticale entre l'origine et le haut du cercle, des arcs et du polygone.

Textes et Formes à partir de texte

14. Les objets texte sont de simples figures planes qui sont créées dans la Vue 3D mais qui n'ont pas de véritable "Forme" sous jacente. Cela signifie qu'ils ne peuvent pas être utilisés dans des opérations complexes avec des formes telles que des extrusions ou des opérations booléennes.

14.1. Appuyez sur Draft Text.svg Texte.
14.2. Sélectionnez le point de référence dans la Vue 3D. Dans la Barre d'outils d'accrochage, assurez-vous que Draft Snap Lock.svg Bascule l'accrochage est actif et que Draft Snap Midpoint.svg Milieu également. Déplacez le pointeur vers le bord supérieur de l'arc le plus élevé, de sorte que l'icône Draft Snap Midpoint.svg Milieu s'affiche. Cliquez pour sélectionner ce point.
14.3. Entrez le Text souhaité et appuyez une fois sur Validez pour commencer une nouvelle ligne; ajoutez plus de lignes de texte au besoin.
14.4. Lorsque vous êtes prêt à terminer l'édition, appuyez deux fois sur Validez.
14,5. Sélectionnez l'objet texte dans tree view, et dans l'Éditeur de propriétés remplacez VueFont Size par 6 mm et VueJustification à Center.

15. Les objets ShapeString sont des formes constituées de fils primitifs qui suivent les lignes indiquées par une certaine police. Cela signifie que ces objets ont une vraie "Forme" sous jacente et peuvent donc être utilisés dans des opérations complexes comme les extrusions et les opérations booléennes.

15.1. Appuyez sur Draft ShapeString.svg Forme à partir de texte.
15.2. Déplacez le pointeur vers l'emplacement souhaité dans la Vue 3D au-dessus du polygone régulier, et cliquez une fois. Cela corrigera le point de base du ShapeString. Les coordonnées peuvent également être entrées manuellement, par exemple, (-20, 65, 0).
15.3. Entrez la String (chaîne de caractère)souhaitée et choisissez la Height (hauteur) souhaitée.
15.4. S'il n'y a pas de fichier de police par défaut, vous devez cliquer sur les points de suspension ... pour ouvrir une boîte de dialogue pour choisir l'emplacement de la police dans le système.
15.5. Lorsqu'un fichier de police valide a été spécifié, vous pouvez cliquer sur OK ou appuyer sur Validez.

05 Dr01 Draft Text ShapeString.png

Objets Text et ShapeString ajoutés.

Pour extruder des lettres et les graver sur des solides, voir le Draft Tutoriel Forme à partir de texte.

Création de dessins techniques

Dans l'état actuel des choses, les objets que nous avons créés peuvent être sauvegardés, exportés vers d'autres formats SVG ou DXF ou imprimés.

Si vous le souhaitez, vous pouvez créer un dessin technique pour afficher ces objets avec des informations supplémentaires comme un cadre.

Avant de faire quoi que ce soit, masquez la grille Draft en appuyant sur Draft ToggleGrid.svg Bascule de la grille.

16. Basculez vers l' Workbench TechDraw.svg atelier TechDraw.

16.1. Créez une page standard en appuyant sur TechDraw PageDefault.svg TechDraw Page par défaut.
16.2. Dans la Vue en arborescence, sélectionnez tous les objets créés, à l'exception de la page, puis appuyez sur TechDraw ActiveView.svg TechDraw Vue active. Appuyez sur OK avec les options par défaut; la création de la vue dans la page peut prendre quelques secondes.
16.3. La sélection de l'objet Page dans la Vue en arborescence affichera automatiquement la page dans la fenêtre principale. Avec la page sélectionnée, allez dans l'Éditeur de propriétés et changez DonnéesScale en 0.75.
16.4. Développez l'objet Page dans la Vue en arborescence pour sélectionner l'objet ActiveView. Avec cette vue sélectionnée, allez dans property editor et changez DonnéesScale Type en Page.
16.5. Recalculez le modèle en utilisant Std Refresh.svg Rafraîchir ou en appuyant sur F5.
16.6. Cachez les cadres des objets en appuyant sur TechDraw ToggleFrame.svg TechDraw Bascule des cadres.

En savoir plus sur l'atelier TechDraw en lisant le TechDraw: Tutoriel d'introduction.

06 Dr01 Draft TechDraw page.png

Page TechDraw avec une projection des formes créées avec l'atelier Draft.

TechDraw fonctionne mieux avec les objets qui ont une Part TopoShape. Étant donné que certains objets de Draft, tels que Draft Textes et Draft Dimensions, n'ont pas de telles "formes", certaines opérations de TechDraw ne fonctionnent pas avec ces éléments.

Les outils tels que TechDraw ActiveView.svg TechDraw Vue active, TechDraw DraftView.svg TechDraw Vue Draft et TechDraw ArchView.svg TechDraw Vue architecturale fonctionnent en recevant une image SVG interne générée par les fonctions Draft internes; par conséquent, TechDraw n'a pas beaucoup de contrôle sur la façon dont ces vues sont affichées. Une plus grande intégration de Draft et TechDraw est un travail en cours.

Remarques finales

L'atelier Draft est à bien des égards similaire au atelier Sketcher, car tous deux sont destinés à produire des formes 2D. La principale différence réside dans la façon dont chaque atelier gère les systèmes de coordonnées et la façon dont les objets sont positionnés. Dans Draft, les objets sont librement positionnés dans le système de coordonnées global, en alignant généralement leurs points sur une grille ou sur d'autres objets. Dans Sketcher, un "objet sketch" définit un système de coordonnées local qui sert de référence pour tous les éléments géométriques de cette esquisse. De plus, l'esquisse s'appuie sur des «contraintes» pour définir la position finale de ses points.

  • L'atelier Sketcher est destiné aux dessins 2D qui nécessitent des relations précises entre ses points. Il ne s'appuie pas sur une grille mais sur des règles de positionnement (contraintes) pour déterminer où seront placés les points et les arêtes. L'atelier Sketcher est principalement utilisé avec l'atelier PartDesign pour la création de solides corps.