Entwurf Tutorium

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft tutorial and the translation is 92% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎

Base ExampleCommandModel.png Tutorial

Thema
Technisches Zeichnen
Niveau
Anfänger
Zeit zum Abschluss
30 Minuten
Autor
Drei und vocx
FreeCAD version
0.19
Beispieldatei(en)
Entwurf Tutorium aktualisiert


Einführung

Dieses Tutorium wurde ursprünglich von Drei geschrieben, und es wurde von vocx neu geschrieben und illustriert.

Dieses Tutorium soll den Leser in den grundlegenden Arbeitsablauf des Workbench Draft.svg Entwurf Arbeitsbereich einführen.

Der Leser wird üben:

  • Erstellung von Linien, Bögen und Polygonen
  • die Verwendung von Arbeitsebenen
  • die Erstellung von Bemaßungen, Text und Formzeichenketten
  • die Erstellung einer technischen Zeichnung

Dieses Tutorial verwendet die Schreibweise (x, y, z), um die zur Definition von Punkten in einem Objekt erforderlichen Koordinaten zu bezeichnen. Die Standardeinheit ist Millimeter mm.

00 Dr01 Draft Tutorial final.png

Endgültige Zeichnung mit verschiedenen Entwurfsobjekten.


Einrichtung

1. Öffne FreeCAD, erstelle ein neues leeres Dokument mit Datei → Std New.svg Neu.

1.1. Wechsle zum Arbeitsbereich Entwurf über die Arbeitsbereich Wähler oder das Menü Ansicht → Arbeitsbereich → Workbench Draft.svg Entwurf.
1.2. Stelle sicher, dass du verstehst, wie der Eigenschaftseditor, insbesondere die Daten und Ansichten Reiter zum Ändern der Eigenschaften zu verwenden sind.
1.3. Da es sich bei den Entwurfsobjekten um ebene Formen handelt, sind sie von oben besser zu sehen. Verwende Std ViewTop.svg Ansicht oben zum setzen der 3D Ansicht.
1.4. Obwohl es in diesem Tutorium nicht verwendet wird, ist das Entwurfsgitter hilfreich, um geometrische Elemente zu positionieren. Verwende Draft SelectPlane.svg WähleEbene, um sowohl die Arbeitsebene als auch das Gitter festzulegen, und dann das Gitter mit Draft ToggleGrid.svg Gitter umschalten anzuzeigen und auszublenden.

Fang Werkzeugleiste

2. Die Entwurf Fang Werkzeugleiste wird normalerweise aktiviert, wenn du zum Entwurf Arbeitsbereich wechselst.

2.1. Um sicherzustellen, dass sie immer vorhanden ist, gehe zu Entwurf Einstellungen, Bearbeiten → Einstellungen → Entwurf → Gitter und Fang Reiter.
2.2. Stelle sicher, dass die Werkzeugleiste Entwurfsfang anzeigen aktiv ist.

Du kannst auch die Sichtbarkeit und die Eigenschaften des Entwurfsgitters im gleichen Fenster ändern.

Arbeitsebenen

Die meisten Entwurfsobjekte sind planare Formen, so dass sie natürlich auf einer Arbeitsebene aufbauen. Eine Arbeitsebene kann eine der globalen Hauptkoordinatenebenen XY, XZ und YZ sein, oder es kann eine Ebene sein, die parallel zu diesen Ebenen mit einem positiven oder negativen Versatz verläuft, oder es kann eine Ebene sein, die durch die Fläche eines festen Objekts definiert ist.

3. Drücke Draft SelectPlane.svg Wähle Ebene, oder gehe zum Menü Hilfsmittel → Draft SelectPlane.svg Select plane, um die Arbeitsebene Aufgabenpaneel zu öffnen.

3.1. Drücke Std ViewTop.svg Oben (XY).

Vor dem drücken der Taste kannst du auch den Wert des Versatzes in Millimetern sowie den Rasterabstand, die Hauptlinien und den Fangradius ändern.

Linien und Bögen

4. Wir werden Bögen und Linien erstellen.

4.1. Drücke Draft Arc.svg Bogen.
4.2. Setze den Mittelpunkt auf (0, 0, 0), und drücke Enter.
4.3. Setze den Radius auf 30 mm, und drücke Enter.
4.4. Set the Anfangswinkel auf 60.0°, und drücke Enter.
4.5. Setze den Öffnungswinkel auf 60.0°, und drücke Enter.
4.6. Wiederhole das gleiche Verfahren für einen zweiten Bogen mit einem Radius von 25 mm, die anderen Eigenschaften sind die gleichen.

5. Wir werden nun ein geschlossenes Profil erzeugen, indem wir die Bögen mit Linien verbinden.

5.1. Drücke Draft Line.svg Linie.
5.2. Stelle in der Werkzeugleiste Fang sicher, dass Draft ToggleSnap.svg Fang umschalten aktiv ist, und nur Draft Endpoint.svg Endpunkt ebenfalls. Wenn du den Zeiger auf einen Endpunkt eines Bogens bewegst, sollte das Draft Endpoint.svg Symbol Endpunkt erscheinen. Klicke diesen Punkt zum auswählen .
5.3. Bewege den Zeiger auf den nächstgelegenen Endpunkt des anderen Bogens, um die beiden Bögen miteinander zu verbinden.
5.4. Wiederhole den Vorgang für die andere Seite des Bogens, um das Profil zu schließen.

01 Dr01 Draft Arc profile.png

Geschlossenes Profil, das durch zwei Bögen und zwei Linien erzeugt wird.


Verschmelzen oder Zusammensetzen

Wir haben jetzt mehrere Objekte in der Baumansicht, die ein geschlossenes Profil bilden. Dieses Profil besteht jedoch nach wie vor aus unverbundenen Objekten; jedes von ihnen kann unabhängig von den anderen bearbeitet und verschoben werden. Es ist möglich, mit den Elementen auf diese Weise weiter zu arbeiten, aber es ist auch möglich, sie zu einem einzigen Objekt zu verschmelzen.

6a. Beachte, dass das Verschmelzen der Objekte zu einem einzigen Objekt ein Objekt erzeugt, das nicht mehr parametrisch ist, so dass ihre Eigenschaften nicht weiter geändert werden können.

6a.1 Wähle alle vier Objekte in der Baumansicht oder durch Ctrl halten und greifen in der 3D Ansicht .

6a.2 Wenn diese Objekte ausgewählt sind, klicke auf Draft Upgrade.svg Aufwerten.

6a.3 Dadurch werden die vier Objekte zu einem einzigen Draht aufgewertet.

6b. Wenn du die parametrische Natur der Objekte beibehalten möchtest, kannst du stattdessen eine Verbindung erstellen.

6b.1. Wechsle zur Arbeitsbereich Part.
6b.2 Wenn diese Objekte ausgewählt sind, klicke auf Part Compound.svg Part Verbund.

Rechtecke, Kreise und Polygone

7. Wir werden einen rechteckigen Rahmen zeichnen.

7.1. Drücke Draft Rectangle.svg Rechteck.
7.2. Gib die Werte des ersten Punktes (-100, -60, 0) ein und drücke Enter.
7.3. Stelle sicher, dass die Relativ Option nicht angehakt ist, da wir absolute Einheiten verwenden werden. Du kannst R auf der Tastatur drücken, um diese Option schnell ein- und auszuschalten.
7.4. Gib die Werte für den zweiten Punkt (140, 90, 0) ein und drücke Enter.

Ein Rechteck wird erstellt. Gehe in den Eigenschaftseditor, um seine Eigenschaften zu ändern. Wenn das Rechteck keine Fläche erzeugen soll, setze DataErstelle Fläche auf false. Wenn du eine Fläche erstellen möchtest, aber nur die Drähte dieses Objekts siehst, lassen DataErstelle Fläche auf true, aber setze den ViewAnzeigemodus auf Wireframe.

8. Wir werden einen Kreis zeichnen.

8.1. Drücke Draft Circle.svg Kreis.
8.2. Gib die Werte des Zentrums (0, 0, 0) ein und drücke Enter.
8.3. Setze den Radius auf 15 mm und drücke Enter.

9. Wir werden ein regelmäßiges Polygon zeichnen.

9.1. Drücke Draft Polygon.svg Polygon.
9.2. Gib die Werte des Zentrums (0, 0, 0) ein, und drücke Enter.
9.3. Setze die Anzahl der Seiten auf 6, und drücke Enter.
9.4. Setze den Radius auf 50 mm, und drücke Enter.

Auch hier kannst du die Eigenschaften Make Face und Ansicht EigenschaftAnzeigemodus im Eingenschaftseditor ändern, wenn du möchtest.

Das Rechteck, der Kreis, das Polygon und die meisten anderen Objekte, die mit der Entwurf Arbeitsbereich erstellt werden, haben viele gemeinsame Daten- und Ansichtseigenschaften, da sie von derselben Basisklasse Part Teil2DObjekt abgeleitet sind.

02 Dr01 Draft Rectangle circle polygon.png

Rechteck, Kreis und Polygon hinzugefügt.


Anordnungen

Anordnungen werden verwendet, um ein Objekt mehrmals in einer orthogonalen Richtung (X, Y, Z), um eine Drehachse oder entlang eines Pfades zu vervielfältigen.

10. Wir werden eine polare Anordnung erstellen.

10.1. Wähle das Draht Objekt, das zuvor mit dem Draft Upgrade.svg Upgrade Werkzeug erstellt wurde, oder den Verbund erstellt mit dem Part Compound.svg Part Verbund Werkzeug.
10.2. Drücke Draft PolarArray.svg PolarAnordnung.
10.3. Stelle den Polarwinkel auf 360° ein.
10.4. Setze die Anzahl der Elemente auf 4.
10.5. Gib die Werte für das Drehzentrum (0, 0, 0) ein und drücke Enter.

Alter Arbeitsablauf

10.2. Drücke Draft Array.svg Anordnung.
10.3. Gehe zur Baumansicht, wähle das Anordnungs objekt, und gehe dann zum Eigenschaftseditor, und wechsle den Daten-EigenschaftAnordnungstyp von ortho auf polar.
10.4. Wechsle DataAnzahl Polar auf4, und DataWinkel auf 360°.

Das Anordnungsobjekt zeigt Kopien des Objekts um den Ursprung herum an.

03 Dr01 Draft PolarArray.png

Polaranordnung des kleinen Profils um den Ursprung zentriert.


Abmessungen

Lineare Bemaßungen funktionieren am besten, wenn die geeigneten Entwurf Fang Methoden zur Auswahl der zu messenden Punkte und Kanten verwendet werden. Sie können jedoch auch durch Angabe absoluter Koordinaten erstellt werden.

11. Erstelle Bemaßungen für die verschiedenen Objekte.

11.1. Drücke Draft Dimension.svg Bemaßung.
11.2. Nimm den ersten Punkt. In diesem Tutorial wird der erste Punkt immer der Ursprung sein. (0, 0, 0).
11.3. In der Fang Werkzeugleiste stelle sicher das Draft ToggleSnap.svg Umschalten Fang aktiv ist, und ebenso nur Draft Midpoint.svg Mittelpunkt. Sowie du den Zeiger auf die Oberkante des Polygons bewegst, sollte das Draft Midpoint.svg Mittelpunkt Symbol erscheinen; klicke, um diesen Punkt auszuwählen.
11.4. Bewege den Cursor nach rechts, um die Position der Abmessung anzugeben, und klicke dann, um die Endposition um (100, 20, 0) festzulegen. Die Bemaßung zeigt automatisch den zwischen den beiden Punkten gemessenen Längenwert an.
11.5. Wähle das Bemaßungsobjekt in der Baumansicht, und im Eigenschaftseditor, wechsle ViewSchriftgröße auf 6 mm, setze ViewExt Linien auf 45 mm, und ViewAnzeige Einheit auf false.

12. Wiederhole den Vorgang für die beiden Bögen des geschlossenen Profils. Der erste Punkt der Messung ist immer noch der Ursprung, und der zweite Punkt verwendet den Draft Midpoint.svg Mittelpunkt des Bogens.

13. Wiederhole den Vorgang für den Kreis in der Mitte. Der erste Punkt der Messung ist immer noch der Ursprung. Um den zweiten Punkt auszuwählen, stelle sicher, dass Draft ToggleSnap.svg Umschalten Fang aktiv ist, und ebenso nur Draft Angle.svg Winkel. Sobald du den Zeiger an den oberen Rand des Kreises bewegst, sollte das Draft Angle.svg Winkel Symbol erscheinen; klicke, um diesen Punkt auszuwählen. Bewege dann den Cursor nach rechts, und klicke, um die Bemaßung zu fixieren.

Denke daran, die ViewSchriftgröße und andere Eigenschaften anzupassen, damit die Bemaßung korrekt angezeigt wird.

04 Dr01 Draft Dimension.png

Bemaßungen, die den vertikalen Abstand vom Ursprung bis zur Oberkante des Kreises, der Bögen und des Polygons messen.


Texte und Formzeichenketten

14. Textobjekte sind einfache planare Figuren, die in der 3D Ansicht erstellt werden, aber keine tatsächliche "Form" darunter haben. Das bedeutet, dass sie nicht in komplexen Operationen mit Formen wie Extrusionen oder booleschen Operationen verwendet werden können.

14.1. Drücke Draft Text.svg Text.
14.2. Wähle den Referenzpunkt in der 3D Ansicht. In der Fang Werkzeugleiste stelle sicher das Draft ToggleSnap.svg Umschalten Fang aktiv ist, und ebenfalls nur Draft Midpoint.svg Mittelpunkt. Bewege den Mauszeiger auf die Oberkante des höchsten Bogens, so dass das Draft Midpoint.svg Mittelpunkt Symbol erscheint; klicke um diesen Punkt auszuwählen.
14.3. Gib den gewünschten Text ein und drücke einmal Enter, um eine neue Zeile zu beginnen; füge bei Bedarf weitere Textzeilen hinzu.
14.4. Wenn du mit der Ausgabe fertig bist, drücke zweimal Enter.
14.5. Wähle das Textobjekt in der Baumansicht aus, und ändere im Eigenschaftseditor ViewSchriftgröße in 6 mm und ViewAusrichtung in Center.

15. FormZeichenkettenobjekte sind Formen aus primitiven Drähten, die den durch eine bestimmte Schriftart angezeigten Linien folgen. Das bedeutet, dass diese Objekte eine echte "Form" darunter haben und daher in komplexen Operationen wie Extrusionen und booleschen Operationen verwendet werden können.

15.1. Drücke Draft ShapeString.svg FormZeichenkette.
15.2. Bewege den Zeiger an die gewünschte Stelle in der 3D Ansicht über dem regulären Polygon, und klicke einmal. Dadurch wird der Basispunkt für die FormZeichenkette festgelegt. Die Koordinaten können auch manuell eingegeben werden, zum Beispiel (-20, 65, 0).
15.3. Gib die gewünschte Zeichenkette ein und wähle die gewünschte Höhe.
15.4. Wenn es keine Standardschriftartdatei gibt, musst du auf die Ellipsen ... klicken, um ein Dialogfeld zur Auswahl des Speicherorts der Schriftart im System zu öffnen.
15.5. Wenn eine gültige Schriftartdatei angegeben wurde, kannst du fortfahren, auf OK zu klicken oder Enter zu drücken.

05 Dr01 Draft Text ShapeString.png

Text und FormZeichenkettenobjekte hinzugefügt.


Um Buchstaben zu extrudieren und auf Volumenkörper zu gravieren, siehe das Entwurf Formzeichenketten Tutorium.

Erstellen technischer Zeichnungen

So wie es jetzt ist, können die von uns erstellten Objekte gespeichert, in andere Formate wie SVG oder DXF exportiert oder gedruckt werden.

Wenn du möchtest, kannst du eine technische Zeichnung erstellen, um diese Objekte zusammen mit zusätzlichen Informationen wie einem Rahmen darzustellen.

Bevor irgendetwas getan wird, blende das Entwurfsgitter durch drücken Draft ToggleGrid.svg Umschalten Gitter aus.

16. 16. Wechsle zum Workbench TechDraw.svg TechDraw Arbeitsbereich.

16.1. Erstelle eine Standardseite durch Drücken von TechDraw PageDefault.svg TechDraw StandardSeite.
16.2. Wähle in der Baumansicht alle erstellten Objekte mit Ausnahme der Seite aus, und drücke dann TechDraw ActiveView.svg TechDraw ActiveView. Drücke OK mit den Standardoptionen; es kann einige Sekunden dauern, bis die Ansicht auf der Seite erstellt ist.
16.3. Wahl des Seitenobjekts in der Baumansicht wird die Seite automatisch im Hauptfenster anzeigen. Mit gewählter Seite gehe zum Eigenschaftseditor, und wechsle den DataMaßstab auf 0.75.
16.4. Erweitere das Seitenbobjekt in der Baumansicht um das AktiveAnsichtsobjekt zu wählen. Mit dieser gewählten Ansicht, gehe zum Eigenschaftseditor, und wechsle den DataMaßstabstyp auf Seite.
16.5. Berechne das Modell neu unter Verwendung von Std Refresh.svg Aktualisieren oder Drücken von F5.
16.6. Blende die Rahmen der Objekte durch drücken von TechDraw ToggleFrame.svg TechDraw UmschaltenRahmen aus.

Erfahre mehr über den TechDraw Arbeitsbereich durch Lesen des TechDraw Grundlagen Tutorium.

06 Dr01 Draft TechDraw page.png

TechDraw Seite mit einer Projektion der mit dem Entwurf Arbeitsbereich erstellten Formen.


TechDraw funktioniert am besten mit Objekten, die eine Part TopoForm. Da einige Objekte aus Entwurf, wie Entwurf Texte und Entwurf Bemaßungen, nicht über solche "Formen"verfügen, funktionieren einige Operationen von TechDraw nicht mit diesen Elementen.

Werkzeuge wie TechDraw ActiveView.svg TechDraw AktiveAnsicht, TechDraw DraftView.svg TechDraw EntwurfAnsicht, und TechDraw ArchView.svg TechDraw ArchitekturAnsicht arbeiten, indem sie ein internes SVG Bild erhalten, das von internen Entwurfsfunktionen erzeugt wird; daher hat TechDraw keine große Kontrolle darüber, wie diese Ansichten angezeigt werden. Die weitere Integration von Entwurf und TechDraw ist noch in Arbeit.

Schlussbemerkungen

Der Entwurf Arbeitsbereich ähnelt in vielerlei Hinsicht dem Entwurf Arbeitsbereich, da beide zur Erzeugung von 2D Formen gedacht sind. Der Hauptunterschied besteht in der Art und Weise, wie jeder Arbeitsbereich Koordinatensysteme handhabt und wie die Objekte positioniert werden. Im Entwurf werden die Objekte frei im globalen Koordinatensystem positioniert, wobei ihre Punkte normalerweise an einem Gitter oder an anderen Objekten gefangen werden. Im Skizzierer definiert ein "Skizzenobjekt" ein lokales Koordinatensystem, das als Referenz für alle geometrischen Elemente innerhalb dieser Skizze dient. Darüber hinaus stützt sich die Skizze auf "Beschränkungen", um die endgültige Position deiner Punkte zu definieren.

  • Der Skizzierer Arbeitsbereich ist für 2D Zeichnungen gedacht, die präzise Beziehungen zwischen ihren Punkten erfordern. Sie stützt sich nicht auf ein Gitter, sondern auf Positionierungsregeln (Beschränkungen), um zu bestimmen, wo die Punkte und Kanten platziert werden sollen. Der Skizzierer Arbeitsbereich wird meistens zusammen mit der PartDesign Arbeitsbereich für die Erstellung von Volumenkörpern Körper verwendet.

Template:Tutorials navi/de