Rysunek roboczy: Przyciąganie

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Snap and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Draft Snap.svg Rysunek roboczy: Przyciąganie

Lokalizacja w menu
Widok → Paski narzędzi → Rysunek roboczy przyciąganie
Środowisko pracy
Rysunek roboczy, Architektura
Domyślny skrót
brak
Wprowadzono w wersji
-
Zobacz także

Opis

Narzędzia Środowiska pracy Workbench Draft.svg Rysunek roboczy umożliwiają graficzne wybieranie punktów, odległości, promieni i kątów poprzez kliknięcie w oknie widoku 3D za pomocą kursora myszki, lub wpisując współrzędne w narzędziu panel zadań.

Innym sposobem wybierania punktów jest przyciąganie. Przyciąganie oznacza przyklejanie następnego punktu do istniejącego punktu lub elementu innego obiektu.

Przyciąganie jest dostępne przy użyciu większości narzędzi Środowisk pracy Draft i Arch i może być włączone i wyłączone globalnie przy użyciu przycisku Draft ToggleSnap.svg ToggleSnap, umieszczonego na pasku narzędzi podręcznych, który można uaktywnić za pomocą menu Widok → Paski narzędzi → Przyciągnij projekt.

Draft Snap example.jpg

Prostopadle do innej linii

Pasek narzędzi Rysunek roboczy: Przyciąganie

  • Draft ToggleSnap.svg Przełącz przyciąganie: przełącza globalnie przyciąganie obiektów na włączone lub wyłączone.
  • Snap Endpoint.svg Punkt końcowy: Przyciąga do punktów końcowych odcinków linii, łuku i splajnu.
  • Snap Midpoint.svg Punkt środkowy: Przyciąga do punktu środkowego linii i odcinków łuku.
  • Snap Center.svg Środek: Przyciąga do środkowego punktu łuków i okręgów.
  • Snap Angle.svg Kąt: Przyciąga do specjalnych punktów odniesienia kół i łuków, przy wielokrotnościach 30° i 45°.
  • Snap Intersection.svg Przecięcie: Przyciąga do przecięcia dwóch odcinków linii lub łuku. Najedź kursorem myszki na dwa pożądane obiekty, aby aktywować przyciąganie ich przecięcia.
  • Snap Perpendicular.svg Prostopadle: Na odcinkach linii i łuku, przyciąga prostopadle do ostatniego punktu.
  • Snap Extension.png Rozszerzenie: Przyciąga do umownej linii, która rozciąga się poza punkty końcowe segmentów linii. Aby uaktywnić przyciąganie rozszerzenia, należy najechać myszką na żądany obiekt.
  • Snap Parallel.svg Równolegle: Przyciąga do umownej linii równoległej do odcinka linii. Przesuń kursor myszy nad żądanym obiektem, aby aktywować jego przyciągnięcie równoległe.
  • Snap Special.svg Specjalne: Przyciąga na punktach specjalnych zdefiniowanych przez obiekt. dostępne w wersji 0.17
  • Snap Near.svg Najbliższy: Przyciąga do najbliższego punktu lub krawędzi najbliższego obiektu.
  • Snap Ortho.svg Ortho: Przyciąga na umownych liniach, które przecinają ostatni punkt i dochodzą pod kątem 0°, 45° i 90°.
  • Snap Grid.svg Siatka: Przyciąga na przecięciach linii siatki, jeśli siatka jest widoczna.
  • Snap WorkingPlane.svg Płaszczyzna robocza: Zawsze umieszcza przyciągany punkt na aktualnej płaszczyźnie roboczej, nawet jeśli przyciągany punkt znajduje się poza tą płaszczyzną roboczą.
  • Snap Dimensions.svg Wymiary: Prezentuje tymczasowe wymiary X i Y podczas przyciągania.
  • Draft ToggleGrid.svg Przełącz widoczność siatki: włącza lub wyłącza widoczność siatki.

Przyciąganie zaawansowane

  • Dodatkowe lokalizacje przyciągania można uzyskać poprzez połączenie dwóch metod przyciągania, takich jak Draft Ortho i Rysunek roboczy: Extension, które dadzą Ci punkt przyciągania na przecięciu ich umownych linii.
  • Inne lokalizacje przyciągania można uzyskać za pomocą Rysunek roboczy: wiązania, to znaczy trzymając wciśnięty klawisz Shift lub naciskając klawisz X, Y lub Z podczas rysowania.
  • Naciśnij klawisz Q podczas rysowania, aby wstawić punkt przyciągania w bieżącym miejscu kursora. Będziesz mógł wówczas użyć przyciągania prostopadłego do tych punktów trzymających i na przecięciu ich osi ortogonalnych. Jeżeli włączone jest przyciąganie Punkt środkowy, będziesz mógł również przyciągnąć w połowie odległości pomiędzy dwoma dowolnymi punktami przyciągania.

Ustawienia

  • Maksymalna odległość, przy której punkt jest uważany za punkt przyciągania, może być zmieniana w biegu przez naciśnięcie klawiszy [ (zwiększ) lub ] (zmniejsz). To ustawienie jest zapisywane: Narzędzia → Edycja parametrów... → BaseApp → Preferences → Mod → Draft → snapRange.
  • Wspomniane klawisze można dostosować do własnych potrzeb w Preferencjach środowiska pracy Rysunek roboczy: Edycja → Preferencje... → Draft → Ustawienia interfejsu użytkownika → Skróty poleceń.

Uwagi

  • Zaleca się aktywowanie tylko tych metod przyciągania, które są naprawdę potrzebne. Aktywowanie zbyt wielu z nich może spowolnić działanie.
  • Nie jest dobrym pomysłem aby mieć aktywne na stałe przyciąganie typu do najbliższego.