Tutorial Draft Forma da Testo

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft ShapeString tutorial and the translation is 2% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎italiano • ‎română • ‎русский

Introduzione

In questo tutorial vedremo come

  • inserire un testo con lo strumento Draft ShapeString.png Forma da testo (ShapeString)
  • estruderlo per creare un solido
  • posizionarlo nello spazio 3D usando il posizionamento e Draft Sposta con degli schizzi come elementi di supporto
  • inciderlo mediante l'applicazione di un taglio booleano

This tutorial was originally written by Roland Frank (†2017, r-frank), and it was rewritten and re-illustrated by vocx.

This tutorial describes a method to create 3D text and use it with solid objects in the Workbench Part.svg Part Workbench. We will discuss how to

To use ShapeStrings inside the Workbench PartDesign.svg PartDesign Workbench, the process is essentially the same as with the Part Workbench, but the ShapeString is placed inside the PartDesign Body to extrude it. Go to the end of this tutorial for more information.

08 T04 Part ShapesString Extrude final cut.png

Final model of the engraved text.


Si raccomanda di aver completato prima i tutorial di Sketcher.

Setup

1. Open FreeCAD, create a new empty document with File → Std New.svg New, and switch to the Part Workbench.

1.1. Press the Std ViewIsometric.svg View isometric button, or press 0 in the numerical pad of your keyboard, to change the view to isometric to visualize the 3D solids better.
1.2. Press the Std ViewFitAll.svg View fit all button whenever you add objects in order to pan and zoom the 3D view so that all elements are seen in the view.
1.3. Hold Ctrl while you click to select multiple items. If you selected something wrong or want to de-select everything, just click on empty space in the 3D view.

Creare la forma di base

  • Avviare FreeCAD e creare un nuovo documento
  • Passare all'ambiente Part
  • Inserire un cubo cliccando su Part Box.png
  • Assicurarsi che il cubo sia selezionato nella vista ad albero
  • Modificare la larghezza fino a 31 mm utilizzando la scheda dati nella finestra delle proprietà
  • Cliccare su View-axometric.svg per passare alla vista isometrica
  • Cliccare su View-zoom-all.svg per adattare la vista a tutto l'oggetto
  • Nella vista 3D selezionare il bordo superiore sulla faccia anteriore del cubo
  • Applicare uno smusso (a Edge6) di 5 mm cliccando su Part Chamfer.png
  • Assicurarsi che l'oggetto "Smusso" sia selezionato nella vista ad albero e premere <Spazio> per commutare la visibilità

TutorialDraftShapeString BasicShape.jpg

2. Insert a primitive cube by clicking on Part Box.svg Box.

2.1. Select Cube in the tree view.
2.2. Change the dimensions in the Data tab of the property editor.
2.3. Change Width to 31 mm.

3. Create a chamfer.

3.1. Select the upper edge (Edge6) on the front face of the Cube in the 3D view.
3.2. Press Part Chamfer.svg Chamfer.
3.3. In the Chamfer edges task panel go to Selection, choose Select edges. As Fillet type choose Constant length, then set Length to 5 mm.
3.4. Press OK. This will create a Chamfer object.
3.5. In the tree view, select Chamfer, in the View tab change the value of Line Width to 2.0.

01 T04 Part Cube base long.png

Base object created from a cube and a chamfer operation.


Inserire il testo con lo strumento ShapeString di Draft

  • Passare all'ambiente Draft
  • Assicurarsi che nella vista ad albero non sia selezionato nulla
  • Passare al piano di lavoro XY (dall'alto) cliccando su Draft SelectPlane.png Auto e sceglindo XY
  • Inserire il testo "FreeCAD" in questo modo
    • Cliccare su Draft ShapeString.png
    • Evidenziare il testo nel campo "Global X" e digitare "0" sulla tastiera, poi premere Return
    • Evidenziare il testo nel campo "Global Y"
    • Digitare "0" sulla tastiera, poi premere Return
    • Evidenziare il testo nel campo "Global Z"
    • Digitare "0" sulla tastiera, poi premere Return
    • Digitare "FreeCAD" nel campo della stringa (senza parentesi) e premere Return
    • Scegliere una altezza di 5mm
    • Scegliere un tracking di 0 mm
    • Ora fornire a FreeCAD il percorso al Font di testo "TTF" da usare (per esempio ARIAL-TTF)
    • Dopo aver premuto Return un'ultima volta, nella struttura ad albero viene creato l'oggetto Forma da testo di Draft

4. Switch to the Draft Workbench.

4.1. Make sure nothing is selected in the tree view.
4.2. Establish the working plane to XY (Top) by clicking on Draft SelectPlane.svg SelectPlane and pressing View-top.svg Top (XY).

5. Insert the text "FreeCAD".

5.1. Press on Draft ShapeString.svg ShapeString.
5.2. Change X to 0 mm.
5.3. Change Y to 0 mm.
5.4. Change Z to 0 mm.
5.5. Or press Reset point.
5.6. Change String to FreeCAD; change Height to 5 mm; change Tracking to 0 mm.
5.7. Make sure Font file points to a valid font, for example, /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf. Press the ellipsis ... to open the operating system's dialog to find a font.
5.8. Press OK. This will create a ShapeString object.
5.9. Recompute the document by pressing Std Refresh.svg Refresh.
5.10. In the tree view, select ShapeString, in the View tab change the value of Line Width to 2.0.
5.11. In the tree view, select Chamfer, in the View tab change the value of Visibility to false, or press Space in the keyboard. This will hide the object, so you can see the ShapeString better.
5.12. To see the ShapeString from above change the view by pressing View-top.svg Top (XY), or 2 in the keyboard.
5.13. To restore the view to isometric, press Std ViewIsometric.svg View isometric, or 0 in the keyboard.

02 T04 Part ShapeString.png

Text created as a ShapeString, that is, as a collection of edges in a plane.


Creare il testo 3D

  • Passare all'ambiente Part
  • Assicurarsi che nella struttura ad albero l'oggetto Shapestring sia selezionato
  • Usare lo strumento Estrusione di Part Part Extrude.png con i parametri:
    • estrusione Z=1 mm
    • assicurarsi di spuntare "Crea solido"
    • usare "OK" per terminare l'estrusione delle parti
  • Assicurarsi che l'oggetto "Estrusione" sia selezionato nella vista ad albero e premere <Spazio> per commutare la visibilità in visibile

TutorialDraftShapeString DraftShapestring.jpg

6. Switch back to the Part Workbench.

6.1. In the tree view, select ShapeString, then press Part Extrude.svg Extrude.
6.2. In the Extrude task panel go to Direction, choose Along normal; in Length, set Along to 1 mm; also tick the Create solid option.
6.3. Press OK. This will create an Extrude object.
6.4. In the tree view, select Extrude, in the View tab change the value of Line Width to 2.0.

03 T04 Part ShapeString Extrude.png

Text created as a ShapeString, and turned into a solid by extrusion.


Inserire lo schizzo per il posizionamento

  • Passare nell'ambiente Schizzo
  • Assicurarsi che l'oggetto "Smusso" sia selezionato nella vista ad albero e premere <Spazio> per commutare la visibilità in visibile
  • Scegliere la faccia inclinata creata dall'operazione smusso
  • Cliccare su Sketcher NewSketch.png per inserire un nuovo schizzo
  • Disegnare una linea (può essere orizzontale o verticale, la lunghezza non è importante ...)
  • Vincolare uno dei punti finali a +2,5 mm di distanza verticale e +2,5 mm di distanza orizzontale dall'origine
  • Chiudere lo schizzo

TutorialDraftShapeString Sketch.jpg

Now we will draw a simple sketch that will be used as auxiliary geometry to position the ShapeString extrusion.

7. In the tree view, select Extrude, and press Space in the keyboard to make it invisible.

8. Switch to the Sketcher Workbench.

9. In the tree view, select Chamfer, and press Space in the keyboard to make it visible.

9.1. Choose the sloped face created by the chamfer operation (Face3).
9.2. Click on Sketcher NewSketch.svg NewSketch. In the Sketch attachment dialog, select FlatFace, and press OK.
9.3. The view should adjust automatically so that the camera is parallel to the selected face.
9.4. Draw a horizontal line in a general position on top of the face. The length is not important; we are just interested in its position.
9.5. Constrain the left endpoint to be 2.5 mm away from the local X axis and from the local Y axis, using Sketcher ConstrainDistanceX.svg ConstrainDistanceX and Sketcher ConstrainDistanceY.svg ConstrainDistanceY.
9.6. Since the sketch is just an auxiliary object, we don't need to have it fully constrained. You can do this if you wish by assigning a fixed distance, say, 20 mm, again with Sketcher ConstrainDistanceX.svg ConstrainDistanceX.
9.7. Close the sketch.

04 T04 Part ShapeString support sketch.png

Line being created with the sketcher, with constraints.


05 T04 Part ShapeString support sketch 3D.png

Sketch line created on top of the solid face, to be used as reference guide for positioning the extruded text.


Posizionare il testo 3D nello spazio 3D

  • Assicurarsi che l'oggetto "Estrusione" sia selezionato nella vista ad albero e premere <Spazio> per commutare la visibilità in visibile
  • Assicurarsi che nella vista ad albero sia selezionato l'oggetto "Estrusione"
  • Applicare un posizionamento incrementale, asse di rotazione Z=90°
  • Applicare un posizionamento incrementale, asse di rotazione Y=45°
  • Passare nell'ambiente Draft
  • Passare alla modalità di vista Wireframe
  • Assicurarsi che sia attivo solo l'aggancio a un "Punto finale" Draft->Snap->Snap a un punto finale
  • Selezionare l'oggetto "Estrusione"
  • Cliccare su Draft Move.png
  • Nella vista 3D cliccare sul punto più alto dell'angolo sinistro dell'oggetto "Estrusione" (1) e quindi fare clic sul punto vincolato nello schizzo (2)

TutorialDraftShapeString Position.jpg

10. In the tree view, select Extrude, and press Space in the keyboard to make it visible.

11. In the tree view, select Extrude, in the Data tab of the property editor, click on the Placement value so the ellipsis button ... appears on the right.

11.1. Tick the option Apply incremental changes.
11.2. Change the Rotation to Rotation axis with angle; Axis to Z, and Angle to 90 deg, then click on Apply. This will apply a rotation around the Z-axis, and will reset the Angle field to zero.
11.3. Change the Rotation to Rotation axis with angle; Axis to Y, and Angle to 45 deg, then click on Apply. This will apply a rotation around the Y-axis, and will reset the Angle field to zero.
11.4. Click on OK to close the dialog.

12. Switch again to the Draft Workbench.

12.1. Switch to "Wireframe" draw style with View → Draw styleDrawStyleWireFrame.svg Wireframe, or press the DrawStyleWireFrame.svg Wireframe button in the view toolbar. This will allow you to see the objects behind other objects.
12.2. Make sure the Draft Snap "Snap to endpoint" method is active. This can be done from the menu Draft → Snapping → Draft ToggleSnap.svg Toggle On/Off, and then Snap Endpoint.svg Endpoint, or by pressing the Draft ToggleSnap.svg ToggleSnap and Snap Endpoint.svg Snap endpoint buttons in the Snap toolbar.

13. In the tree view, select Extrude.

13.1. Click on Draft Move.svg Move.
13.2. In the 3D view click on the upper left corner point of the Extrude object (1), and then click on the leftmost point in the line drawn with the sketcher (2).
13.3. If Snap Endpoint.svg Snap endpoint is active, as soon as you move the pointer close to a vertex, you should see that it attaches to it exactly.
Note: if you have problems snapping to vertices, make sure only the Snap Endpoint.svg Snap endpoint method is enabled. Having multiple snapping methods active at the same time may make it difficult to select the right feature.
13.4. The extruded text should now be inside the body of the Fillet object.

06 T04 Part ShapeString move.svg

The extruded ShapeString should be moved to the position of the sketched line that lies on the face of the base body.


07 T04 Part ShapesString Extrude in place.png

Extruded ShapeString positioned in the Fillet.


Creare il testo inciso

  • Passare all'ambiente Part
  • Passare alla modalità di vista "Come è"
  • Nella vista ad albero selezionare il testo 3D ("estrusione") e poi l'oggetto di base ("smusso")
  • Applicare un taglio booleano cliccando su Part Cut.png
  • Assicurarsi che nella vista ad albero sia selezionato l'oggetto "Sketch"
  • Premere <Spazio> per commutare la visibilità
  • Cliccare su View-axometric.svg per passare alla vista isometrica
  • Cliccare su View-zoom-all.svg per adattare la vista all'oggetto
  • Finito

TutorialDraftShapeString Complete.jpg

14. Switch back to the Part Workbench.

14.1. Switch to "As is" draw style with View → Draw styleDrawStyleAsIs.svg As is, or press the DrawStyleAsIs.svg As is button in the view toolbar. This will show all objects with the normal shading and color.
14.2. In the tree view, select Sketch, and press Space in the keyboard to make it invisible.

15. In the tree view select Chamfer first, and then Extrude.

15.1. Then press Part Cut.svg Cut. This will create a Cut object. This is the final object.
Note: the order in which you select the objects is important for the cut operation. The base object is selected first, and the subtracting object comes at the end.
15.2. In the tree view, select Cut, in the View tab change the value of Line Width to 2.0.

08 T04 Part ShapesString Extrude final cut.png

Final model of a filleted cube, with carved text created from a ShapeString, Extrude, and boolean Cut operations.


Engraving 3D text with the PartDesign Workbench

A similar process as described above can be done with the PartDesign Workbench.

  1. Create the Draft ShapeString.svg Draft ShapeString first.
  2. Create a PartDesign Body Tree.svg PartDesign Body, make it active, and add a base solid by adding primitives, or using a Sketch and extruding it with PartDesign Pad.svg PartDesign Pad.
  3. Move the ShapeString object into the active body.
  4. Attach the ShapeString object to one of the faces of the solid, or to a PartDesign Plane.svg PartDesign Plane, using Part Attachment.svg Part Attachment.
  5. Now create a PartDesign Pad.svg PartDesign Pad or a PartDesign Pocket.svg PartDesign Pocket from the ShapeString, in order to produce an additive or a subtractive feature of the base body, respectively.

See the forum thread, How to use ShapeStrings in PartDesign.

Note

  • Per creare un testo curvo è possibile utilizzare la macro Testo circolareFCCircularTextButtom.png
  • Per importare un testo da Inkscape vedere il tutorial Importare testo e geometria da Inkscape
  • L'estrusione della Forma stringa di testo può essere fatta anche con lo strumento Pad di PartDesign
  • Ricordare che l'oggetto DraftShapestring non può essere mappato su una faccia (quindi non è possibile nessun comando Tasca )