Taslak Şekil dizesi

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft ShapeString and the translation is 15% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
Arrow-left.svg Previous: Draft Facebinder.svg Facebinder
Next: Hatch Draft Hatch.svg Arrow-right.svg

Draft ShapeString.svg Şekil dizesi

Menü konumu
Taslak → Şekil dizesi
Tezgahlar
Taslak, Yapı
Varsayılan kısayol
S S
Versiyonda tanıtıldı
0.14
Ayrıca bkz
Metin, Parça çıkarma,
Macro Fonts Win10 PYMP Macro Fonts Win10 PYMP.png

Tanım

Şekil dizesi aracı, bir metin dizesini temsil eden bir bileşik şekil ekler. Metin yüksekliği, ara boşluk ve yazı tipi belirtilebilir. Ortaya çıkan şekil, 3D harfler oluşturmak için Parça çıkarma aracıyla kullanılabilir.

Kapalı bir şekil olmadan daha basit bir metin elemanı eklemek için Taslak Metin kullanın. Bir yönlendirici ve bir ok içeren bir metin etiketi oluşturmak için Taslak Etiket kullanın.

Draft ShapeString Example400.png

Şekil dizesini konumlandırmak için tek nokta gerekli

Nasıl Kullanılır

For Windows users: please read the Font file selection on Windows paragraph first.

  1. There are several ways to invoke the command:
    • Press the Draft ShapeString.svg Draft ShapeString button.
    • Select the Drafting → Draft ShapeString.svg Shape from text option from the menu.
  2. The ShapeString task panel opens.
  3. Click a point in the 3D view, or type coordinates.
  4. Optionally press the Reset Point button to reset the point to the origin.
  5. Enter a String.
  6. Specify the Height.
  7. To select a font do one of the following:
    • Enter a file path in the Font file input box.
    • Press the ... button and select a file.
  8. Press the OK button to finish the command.

Seçenekler

  • Koordinatları manuel olarak girmek için sayıları girin, ardından her bir X, Y ve Z bileşeni arasında Enter tuşuna basın. Noktayı eklemek istediğiniz değerlere sahipseniz Draft AddPoint.svg Nokta ekle düğmesine basabilirsiniz.
  • Geçerli komutu iptal etmek için Esc veya Close düğmesine basınız.

Notes

Sınırlamalar

  • Çok küçük metin yükseklikleri, ölçeklemede ayrıntı kaybı nedeniyle deforme karakter şekillerine neden olabilir.
  • Mevcut sürüm, soldan sağa yazma ile sınırlıdır.
  • Dairesel biçimde düzenlenmiş metin oluşturmak için FCCircularTextButtom.png Macro FCCircularText kullanın.

Font file selection on Windows

On Windows access to the default font folder is restricted. This affects the font file selection for ShapeStrings. There are three cases in FreeCAD where a font file for ShapeStrings can be specified: in the task panel of this command, when changing the VeriFont File property of a ShapeString, and when specifying the default font file in the Preferences Editor.

Pressing the ... button and then selecting a file from the default Windows font folder is not possible when using the native file dialog. There are a number of workarounds:

  • Make sure DontUseNativeFontDialog is set to true, which is the default value for this preference. This will only call a different, non-native, file dialog when pressing the ... in the task panel of this command. With this file dialog the default Windows font folder can be accessed.
  • Change DontUseNativeDialog to true. This instructs FreeCAD to always use the non-native file dialog.
  • Specify the font file in the input box. You can of course type the full path or copy-paste the path from the Windows File Explorer. But there is also another way to enter the path. If you enter C:\ a dropdown list will appear. Select Windows from that list and add \F. Select Fonts from the new dropdown list. Finally add \ and the first letter of the font file, and then select it from the dropdown list.
  • Create a custom folder for your font files.

See the Preferences paragraph below for the location of the mentioned preferences.

Kılavuzlar

Preferences

See also: Preferences Editor and Draft Preferences.

  • The default font file can be changed in the preferences: Edit → Preferences... → Draft → Texts and dimensions → Default ShapeString font file.
  • For Windows users:
    • Set Tools → Edit parameters... → BaseApp → Preferences → Dialog → DontUseNativeFontDialog to true to use the non-native file dialog when selecting a font file from the task panel of this command.
    • Set Tools → Edit parameters... → BaseApp → Preferences → Dialog → DontUseNativeDialog to true to always use the non-native file dialog.

Özellikler

See also: Property editor.

A Draft ShapeString object is derived from a Part Part2DObject and inherits all its properties. It also has the following additional properties:

Data

Draft

  • Veri Position: bileşik şeklin taban noktasının konumunu belirtir.
  • Veri Angle: şeklin taban çizgisinin dönüşünü belirtir.
  • Veri Axis: döndürme için kullanılacak ekseni belirtir.
  • Veri String: görüntülenecek metin dizesini belirtir; Taslak Metin aracından farklı olarak, Taslak Şekil dizesi yalnızca tek bir satır görüntüleyebilir.
  • Veri Size: harflerin genel yüksekliğini belirtir.
  • Veri Tracking: dizedeki karakterler arası ek boşluğu belirtir.
  • Veri Font File: dizeyi çizmek için kullanılan font dosyasının tam yolunu belirtir.

View

Draft

  • GörünümPattern (Enumeration): specifies the Draft Pattern with which to fill the faces of the text. This property only works if GörünümDisplay Mode is Flat Lines.
  • GörünümPattern Size (Float): specifies the size of the Draft Pattern.

Scripting

Betik

Ayrıca bkz.: Taslak API ve FreeCAD Betik esasları.

Şekil dizesi aracı, aşağıdaki işlevi kullanarak makrolar ve Python konsolundan kullanılabilir:

shapestring = make_shapestring(String, FontFile, Size=100, Tracking=0)
  • Belirtilen String ve desteklenen bir FontFile tam yolunu kullanarak bir ShapeString bileşik şekli oluşturur.
  • Size sonuçta elde edilen metnin milimetre cinsinden yüksekliğidir.
  • Tracking milimetre cinsinden karakterler arası ek boşluktır.

Şekil dizesi'in yerleşimi, Placement özniteliğinin üzerine yazarak veya Placement.Base ve Placement.Rotation özniteliklerinin üzerine yazılarak değiştirilebilir.

Örnek:

import FreeCAD as App
import Draft

doc = App.newDocument()

font1 = "/usr/share/fonts/truetype/msttcorefonts/Arial.ttf"
font2 = "/usr/share/fonts/truetype/dejavu/DejaVuSerif.ttf"
font3 = "/usr/share/fonts/truetype/freefont/FreeSerifItalic.ttf"

S1 = Draft.make_shapestring("This is a sample text", font1, 200)

S2 = Draft.make_shapestring("Inclined text", font2, 200, 10)

zaxis = App.Vector(0, 0, 1)
p2 = App.Vector(-1000, 500, 0)
place2 = App.Placement(p2, App.Rotation(zaxis, 45))
S2.Placement = place2

S3 = Draft.make_shapestring("Upside-down text", font3, 200, 10)
S3.Placement.Base = App.Vector(0, -1000, 0)
S3.Placement.Rotation = App.Rotation(zaxis, 180)

doc.recompute()