Planul de Lucru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft SelectPlane and the translation is 4% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
Arrow-left.svg Previous: Draft Shape2DView.svg Shape2DView
Next: SetStyle Draft SetStyle.svg Arrow-right.svg

Draft SelectPlane.svg Draft SelectPlane

poziția meniului
Draft → Utilities → Select Plane
Ateliere
Draft, Arch
scurtătură
W P
Prezentat în versiune
-
A se vedea, de asemenea,
Draft SetWorkingPlaneProxy

Description

Descriere

Modulul Draft dispune de un sistem de plan de lucru, care vă permite să specificați un plan personalizat în spațiul 3D pe care va apărea următoarea comandă Draft. Există mai multe metode pentru a defini planul de lucru:
  • De pe o fațetă selectată
  • De la 3 noduri selectate
  • Din vizualizarea curentă
  • De la o presetare: de sus, frontal sau lateral
  • Nici unul, caz în care planul de lucru este adaptat automat la vizualizarea curentă atunci când porniți o comandă sau la o față dacă începeți să desenați pe o față existentă.

WorkingPlane example.png

Shapes created on different working planes

Usage with pre-selection

  1. Do one of the following:
    • Select a single object. The following objects are supported:
    • Select one or more subelements. You can select:
      • A flat face.
      • Three vertices.
      • A circular edge.
      • Two straight edges that are co-planar but not co-linear.
      • A straight edge and a vertex that does not lie on the (extended) edge.
  2. There are several ways to invoke the command:
    • Press the Draft SelectPlane.svg Draft SelectPlane button in the Draft Tray. Depending on the current working plane this button can look different.
    • Select the Utilities → Draft SelectPlane.svg Select Plane option from the menu.
    • Use the keyboard shortcut: W then P.
  3. The working plane and the button in the Draft Tray are updated.

Usage with post-selection

  1. There are several ways to invoke the command:
    • Press the Draft SelectPlane.svg Draft SelectPlane button in the Draft Tray. Depending on the current working plane this button can look different.
    • Select the Utilities → Draft SelectPlane.svg Select Plane option from the menu.
    • Use the keyboard shortcut: W then P.
  2. The Working plane setup task panel opens. See Options for more information.
  3. Do one of the following:
    • Select a single object. See the previous paragraph for the supported objects.
    • Select one or more subelements. You can select:
      • A flat face.
      • Three vertices.
  4. Click anywhere in the 3D view to confirm the selection and finish the command.
  5. The working plane and the button in the Draft Tray are updated.

Usage with presets

  1. There are several ways to invoke the command:
    • Press the Draft SelectPlane.svg Draft SelectPlane button in the Draft Tray. Depending on the current working plane this button can look different.
    • Select the Utilities → Draft SelectPlane.svg Select Plane option from the menu.
    • Use the keyboard shortcut: W then P.
  2. The Working plane setup task panel opens. See Options for more information.
  3. Press any of the buttons to finish the command.
  4. The working plane and the button in the Draft Tray are updated.

Options

Opțiuni

  • Pentru a seta planul de lucru la geometria existentă: selectați o fațetă a unui obiect existent în vizualizarea 3D sau introduced in version 0.17, cu CTRL apăsat, 3 vârfuri pe orice obiect. Apoi apăsați tasta Draft SelectPlane.png SelectPlane
  • Apăsarea butonului VIEW va stabili planul de lucru drept planul de vizualizare, perpendicular pe axa camerei și trecând prin punctul de origine (0,0,0).
  • Apăsarea butonului AUTO va decupla orice plan de lucru curent. Următoarele operații 2D vor fi dependente de vizualizare.
  • De asemenea, puteți specifica o valoare de offset, care vă va stabili planul de lucru la o anumită distanță de planul pe care îl selectați.
  • Puteți să ascundeți și să arătați grila cu comanda rapidă G R

Notes

  • It can be useful to align the 3D view with the selected Draft working plane. For example after switching the working plane to Front you may want to switch to the Front view as well.
  • The grid can be toggled with the Draft ToggleGrid command.
  • By double-clicking Draft WorkingPlaneProxies in the Tree view you can quickly switch between working planes.

Preferences

See also: Preferences Editor and Draft Preferences.

  • The grid settings in the task panel as well as several other grid settings are available as preferences: Edit → Preferences... → Draft → Grid and snapping → Grid.
  • To use the grid the Edit → Preferences... → Draft → Grid and snapping → Grid → Use grid option must be selected. After changing this preference you must restart FreeCAD.
  • The Snapping radius can also be changed on-the-fly (see Draft Snap) or by changing: Tools → Edit parameters... → BaseApp → Preferences → Mod → Draft → snapRange.

Scripting

Script

Obiectul plan de lucru poate fi ușor creat și manipulat în scripturi și în macros. Puteți crea propriele dvs. planuri de lucru și le puteți folosi independent de planul curent de lucru curent.

De asemenea, puteți accesa planul curent de lucru al Draft-ului actual:

# This code only works if the Draft Workbench is active!

import FreeCAD as App
import FreeCADGui as Gui

workplane = App.DraftWorkingPlane

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()

workplane.alignToPointAndAxis(v1, v2, 17)
Gui.Snapper.toggleGrid()
Gui.Snapper.toggleGrid()

Exempluː

import WorkingPlane

my_plane = WorkingPlane.plane()

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()
my_plane.alignToPointAndAxis(v1, v2, 17)

projection = my_plane.projectPoint(App.Vector(10, 15, 2))
print(projection)


Arrow-left.svg Previous: Draft Shape2DView.svg Shape2DView
Next: SetStyle Draft SetStyle.svg Arrow-right.svg