Borrador SeleccinarPlano

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft SelectPlane and the translation is 12% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
Arrow-left.svg Anterior: Draft Stretch.svg Estirar
Siguiente: Acabar Línea Draft FinishLine.svg Arrow-right.svg

Draft SelectPlane.svg Borrador SeleccionarPlano

Ubicación en el Menú
Borrador -> Seleccionar Plano
Entornos de trabajo
Borrador, Arquitectura
Atajo de teclado por defecto
W P
Introducido en versión
-
Ver también
Borrador PlanoTrabajoProxy, Borrador AlternarRejilla

Descripción

El Workbench Draft.svg Ambiente de Trabajo Borrador cuenta con un sistema de planos de trabajo. Un plano en la Vista 3D indica dónde se construirá una forma de Borrador. Hay varios métodos para definir el plano de trabajo:

  • A partir de una cara seleccionada
  • De tres vértices seleccionados.
  • A partir de la vista actual
  • A partir de una vista predefinida: Planta, alzado o perfil
  • Ninguno, en cuyo caso el plano de trabajo se adapta automáticamente a la vista actual cuando se inicia un comando, o a una cara si comienzas dibujando sobre una cara existente.

WorkingPlane example.png

Se pueden establecer diferentes planos de trabajo en los que dibujar las formas

Usage with pre-selection

  1. Selecciona una cara de un objeto existente en la vista 3D, o mantén pulsado Ctrl y selecciona tres vértices de cualquier objeto. introducido en la versión 0.17
  2. Pulse el Draft SelectPlane.svg SeleccionarPlano, o haz clic con el botón derecho y selecciona Utilidades → Draft SelectPlane.svg SeleccionarPlano.

Usage with post-selection

  1. There are several ways to invoke the command:
    • Press the Draft SelectPlane.svg Draft SelectPlane button in the Draft Tray. Depending on the current working plane this button can look different.
    • Select the Utilities → Draft SelectPlane.svg Select Plane option from the menu.
    • Use the keyboard shortcut: W then P.
  2. The Working plane setup task panel opens. See Options for more information.
  3. Do one of the following:
    • Select a single object. See the previous paragraph for the supported objects.
    • Select one or more subelements. You can select:
      • A flat face.
      • Three vertices.
  4. Click anywhere in the 3D view to confirm the selection and finish the command.
  5. The working plane and the button in the Draft Tray are updated.

Usage with presets

  1. Pulse el Draft SelectPlane.svg SeleccinarPlano, o utilice BorradorUtilidadesDraft SelectPlane.svg SeleccinarPlano del menú superior, o el atajo de teclado W y luego P
  2. Seleccione el desplazamiento, el espaciado de la cuadrícula y las líneas principales
  3. Seleccione uno de los preajustes: View-top.svg XY (superior), View-front.svg XZ (frontal), View-right.svg YZ (lateral), View-isometric.svg View, o View-axonometric.svg Auto.

Opciones

  • Pulse el View-top.svg XY (top) para establecer el plano de trabajo en el plano XY. Para dibujar fácilmente en este plano, debes establecer la vista en la parte superior o inferior (la normal está en la dirección Z positiva o negativa). Pulsa 2 o 5 para cambiar rápidamente a estas vistas.
  • Pulse el View-front.svg XZ (frontal) para establecer el plano de trabajo en el plano XZ. Para dibujar fácilmente en este plano, debes fijar la vista en la parte delantera o trasera (la normal está en la dirección Y negativa o positiva). Pulsa 1 o 4 para cambiar rápidamente a estas vistas.
  • Pulse el View-right.svg YZ (lateral) para establecer el plano de trabajo en el plano YZ. Para dibujar fácilmente en este plano, debes fijar la vista en el lado izquierdo o derecho (la normal está en la dirección X positiva o negativa). Pulsa 3 o 6 para cambiar rápidamente a estas vistas.
  • Pulse el botón View-isometric.svg Vista para establecer el plano de trabajo en la vista 3D actual, perpendicular al eje de la cámara y pasando por el origen (0,0,0).
  • Pulse el botón View-axonometric.svg Auto para desajustar cualquier plano de trabajo actual, y establecer automáticamente un plano de trabajo cuando se utiliza una herramienta. Cuando se selecciona una herramienta de dibujo, la rejilla se actualiza automáticamente a la vista actual; entonces, si la vista se gira, y se selecciona otra herramienta, la rejilla se redibuja en la nueva vista. Esto equivale a pulsar View-isometric.svg Vista automáticamente antes de usar una herramienta.
  • Establecer el valor de "Desplazamiento" para fijar el plano de trabajo a una determinada distancia perpendicular del plano seleccionado.
  • Establezca el valor de "Espaciado de la rejilla" para definir el espacio entre cada línea de la rejilla.
  • Ajuste el valor "Grid size" para definir la extensión total del plano de la cuadrícula.
  • Ajuste el valor "Línea principal cada" para dibujar una línea ligeramente más gruesa en la cuadrícula en el valor establecido. Por ejemplo, si el espaciado de la cuadrícula es de 0,5 m, y hay una línea principal cada 20 líneas, habrá una línea ligeramente más gruesa cada 10 m.
  • Haga clic en la casilla "Centrar el plano en la vista" para dibujar el plano y la cuadrícula más cerca de la vista de la cámara en la vista 3D.
  • Pulse Esc o el botón Close para abortar el comando actual.
  • La rejilla muestra un borde adicional con el espacio de la línea principal indicado en la esquina inferior izquierda introduced in version 0.19. Esto se puede desactivar a través de Edición->Preferencias->Borrador->Rejilla y ajuste->Mostrar borde de la rejilla

Notes

  • It can be useful to align the 3D view with the selected Draft working plane. For example after switching the working plane to Front you may want to switch to the Front view as well.
  • The grid can be toggled with the Draft ToggleGrid command.
  • By double-clicking Draft WorkingPlaneProxies in the Tree view you can quickly switch between working planes.

Preferences

See also: Preferences Editor and Draft Preferences.

  • The grid settings in the task panel as well as several other grid settings are available as preferences: Edit → Preferences... → Draft → Grid and snapping → Grid.
  • To use the grid the Edit → Preferences... → Draft → Grid and snapping → Grid → Use grid option must be selected. After changing this preference you must restart FreeCAD.
  • The Snapping radius can also be changed on-the-fly (see Draft Snap) or by changing: Tools → Edit parameters... → BaseApp → Preferences → Mod → Draft → snapRange.

Scripting

Guión

Ver también: Fundamentos de Guión FreeCAD. Véase la WorkingPlane API.

Puede acceder al plano de trabajo actual del Borrador y aplicarle transformaciones:

# This code only works if the Draft Workbench is active!

import FreeCAD as App
import FreeCADGui as Gui

workplane = App.DraftWorkingPlane

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()

workplane.alignToPointAndAxis(v1, v2, 17)
Gui.Snapper.toggleGrid()
Gui.Snapper.toggleGrid()

Puede crear sus propios planos y utilizarlos independientemente del plano de trabajo actual. Esto es útil si necesita hacer cálculos o proyecciones en estos otros planos.

import WorkingPlane

my_plane = WorkingPlane.plane()

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()
my_plane.alignToPointAndAxis(v1, v2, 17)

projection = my_plane.projectPoint(App.Vector(10, 15, 2))
print(projection)


Arrow-left.svg Anterior: Draft Stretch.svg Estirar
Siguiente: Acabar Línea Draft FinishLine.svg Arrow-right.svg