Entwurf WähleEbene

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft SelectPlane and the translation is 12% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский

Draft SelectPlane.svg Entwirf WähleEbene

Menüeintrag
Entwurf → Hilfsprogramme → Wähle Ebene
Arbeitsbereich
Entwurf, Architektur
Standardtastenkürzel
W P
Eingeführt in Version
-
Siehe auch
Entwurf ArbeitsEbeneProxy,Entwurf GitterUmschalten

Beschreibung

Der Workbench Draft.svgEntwurf Arbeitsbereich verfügt über ein Bearbeitungsebenensystem. Eine Ebene in der 3D Ansicht zeigt an, wo eine Entwurfsform erstellt wird. Es gibt mehrere Möglichkeiten, die Bearbeitungsebene zu definieren:

  • Von einer ausgewählten Fläche.
  • Von drei ausgewählten Knoten.
  • Aus der gegenwärtigen Sicht.
  • Von einer Voreinstellung: oben, vorne oder seitlich.
  • Keine, in diesem Fall wird die Bearbeitungsebene beim Starten eines Befehls automatisch an die aktuelle Ansicht oder an eine Fläche angepasst, wenn Du mit dem Zeichnen auf einer vorhandenen Fläche beginnst.

WorkingPlane example.png

Unterschiedliche Arbeitsebenen können eingestellt werden, auf denen Formen gezeichnet werden können.

Usage with pre-selection

  1. Wähle eine Fläche eines vorhandenen Objekts in der 3D Ansicht aus, oder halte strg gedrückt und wähle drei Ecken eines Objekts. eingeführt in Version 0.17
  2. Drücke die Taste Draft SelectPlane.svg WähleEbene, oder klicke mit der rechten Maustaste und wähle Hilfsmittel→ Draft SelectPlane.svg. WähleEbene.

Usage with post-selection

  1. There are several ways to invoke the command:
    • Press the Draft SelectPlane.svg Draft SelectPlane button in the Draft Tray. Depending on the current working plane this button can look different.
    • Select the Utilities → Draft SelectPlane.svg Select Plane option from the menu.
    • Use the keyboard shortcut: W then P.
  2. The Working plane setup task panel opens. See Options for more information.
  3. Do one of the following:
    • Select a single object. See the previous paragraph for the supported objects.
    • Select one or more subelements. You can select:
      • A flat face.
      • Three vertices.
  4. Click anywhere in the 3D view to confirm the selection and finish the command.
  5. The working plane and the button in the Draft Tray are updated.

Usage with presets

  1. Drücke die Draft SelectPlane.svg WähleEbene, oder verwende EntwurfHilfsmittelDraft SelectPlane.svg WähleEbene aus dem oberen Menü, oder das Tastaturkürzel W und dann P
  2. Wähle den Versatz, den Rasterabstand und die Hauptlinien
  3. Wähle eine der Voreinstellungen: View-top.svg XY (oben), View-front.svg XZ (vorne), 16px YZ (Seite), View-isometric.svg Ansicht, oder View-axonometric.svg Auto.

Optionen

  • Drücke die View-top.svg XY (top) Taste um die Bearbeitungsebene in der XY Ebene festzulegen.

Um auf dieser Ebene leicht zeichnen zu können, solltest Du die Ansicht nach oben oder unten setzen (das Normal liegt in der positiven oder negativen Z Richtung). Drücke 2 oder 5, um schnell zu diesen Ansichten zu wechseln.

  • Drücke die View-front.svg XZ (front) Taste, um die Bearbeitungsebene in der XZ Ebene festzulegen. Um auf dieser Ebene leicht zeichnen zu können, solltest Du die Ansicht nach vorne oder hinten setzen (das Normal liegt in negativer oder positiver Y Richtung). Drücke 1 oder 4, um schnell zu diesen Ansichten zu wechseln.
  • Drücke die Taste {View-right.svg YZ (side) Taste, um die Bearbeitungsebene in der YZ Ebene einzustellen. Um auf dieser Ebene leicht zeichnen zu können, solltest Du die Ansicht auf die linke oder rechte Seite setzen. (das Normal liegt in positiver oder negativer X Richtung). Drücke 3} oder 6, um schnell zu diesen Ansichten zu wechseln.
  • Drücke die View-isometric.svg View Taste , um die Bearbeitungsebene auf die aktuelle 3D Ansicht, senkrecht zur Kameraachse und durch den Ursprung (0,0,0) verlaufend, zu setzen.
  • Drücke die View-axonometric.svg Auto Taste , um eine aktuelle Bearbeitungsebene aufzuheben und automatisch eine Bearbeitungsebene zu setzen, wenn ein Werkzeug verwendet wird. Wenn ein Zeichenwerkzeug ausgewählt ist, wird das Gitter automatisch auf die aktuelle Ansicht aktualisiert; wenn die Ansicht gedreht wird und ein anderes Werkzeug ausgewählt wird, wird das Gitter in der neuen Ansicht neu gezeichnet. Dies entspricht dem Drücken von View-isometric.svg View automatisch vor der Verwendung eines Werkzeugs.
  • Setze den Wert "Versatz", um die Bearbeitungsebene in einem bestimmten senkrechten Abstand von der von dir gewählten Ebene zu setzen.
  • Setze den Wert "Rasterabstand", um den Abstand zwischen den einzelnen Linien im Raster zu definieren.
  • Setze den Wert "Hauptlinie alle", um eine etwas dickere Linie im Raster bei setzen des Wertes zu zeichnen. Zum Beispiel, wenn der Rasterabstand beispielsweise 0,5 m beträgt und alle 20 Linien eine Hauptlinie vorhanden ist, wird alle 10 m eine etwas dickere Linie sein.
  • Klicke auf das Kontrollkästchen "Mittelebene auf Ansicht", um die Ebene und das Gitter in der 3D Ansicht näher an die Kameraansicht zu zeichnen.
  • Drücke Esc oder die Close Taste, um den aktuellen Befehl abzubrechen.

Notes

  • It can be useful to align the 3D view with the selected Draft working plane. For example after switching the working plane to Front you may want to switch to the Front view as well.
  • The grid can be toggled with the Draft ToggleGrid command.
  • By double-clicking Draft WorkingPlaneProxies in the Tree view you can quickly switch between working planes.

Preferences

See also: Preferences Editor and Draft Preferences.

  • The grid settings in the task panel as well as several other grid settings are available as preferences: Edit → Preferences... → Draft → Grid and snapping → Grid.
  • To use the grid the Edit → Preferences... → Draft → Grid and snapping → Grid → Use grid option must be selected. After changing this preference you must restart FreeCAD.
  • The Snapping radius can also be changed on-the-fly (see Draft Snap) or by changing: Tools → Edit parameters... → BaseApp → Preferences → Mod → Draft → snapRange.

Scripting

Skripten

Sie auch: Entwurf API und FreeCAD Grundlagen Skripten. Siehe die ArbeitsEbene API.

Du kannst auf die aktuelle Bearbeitungsebene Entwurf zugreifen und Transformationen darauf anwenden:

# This code only works if the Draft Workbench is active!

import FreeCAD as App
import FreeCADGui as Gui

workplane = App.DraftWorkingPlane

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()

workplane.alignToPointAndAxis(v1, v2, 17)
Gui.Snapper.toggleGrid()
Gui.Snapper.toggleGrid()

Du kannst deine eigenen Ebenen erstellen und sie unabhängig von der aktuellen Arbeitsebene verwenden. Dies ist nützlich, wenn du Berechnungen oder Projektionen in diesen anderen Ebenen durchführen musst.

import WorkingPlane

my_plane = WorkingPlane.plane()

v1 = App.Vector(0, 0, 0)
v2 = App.Vector(1, 1, 1).normalize()
my_plane.alignToPointAndAxis(v1, v2, 17)

projection = my_plane.projectPoint(App.Vector(10, 15, 2))
print(projection)