Draft Pattern/ru

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Pattern and the translation is 7% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎italiano • ‎polski • ‎čeština • ‎русский • ‎中文(中国大陆)‎
Arrow-left.svg Previous: Constrain

Description

Draft objects with a ДанныеMake Face property can display an SVG pattern instead of a solid face color.

DraftPatternSample.png

An ellipse and a polygon with an SVG pattern

Usage

  1. Make sure the objects are closed and planar, and do not self-intersect.
  2. To close a Draft Wire, a Draft BSpline, a Draft CubicBezCurve or a Draft BezCurve set its ДанныеClosed property to true.
  3. To close a Draft Circle or a Draft Ellipse set its ДанныеFirst Angle and ДанныеLast Angle properties to the same value.
  4. Select the objects.
  5. Switch to the View tab of the Property editor.
  6. The ВидDisplay Mode must be set to Flat Lines.
  7. Select a ВидPattern.
  8. Optionally change the ВидPattern Size. Note that a higher value results in a denser pattern.
  9. The pattern is not displayed when the objects are selected. Deselect them to check the result.
  10. Optionally reselect the objects to change the pattern properties.

Available patterns

Примечания

  • SVG patterns are stored in .SVG files. It is possible to use your own custom patterns. See Preferences.
  • The patterns themselves are not saved in the FreeCAD document. Objects whose ВидPattern cannot be found are displayed with a solid face color instead.

Preferences

See also: Preferences Editor and Draft Preferences.

  • To specify a directory with addition SVG patterns: Edit → Preferences... → Draft → Visual settings → Alternate SVG patterns location. Select a file in the directory and then remove the filename in the preferences input box, leaving only the path. After changing this preference you must restart FreeCAD.
  • The Edit → Preferences... → Draft → Visual settings → SVG pattern resolution preference is not used.
  • To change the ВидPattern Size used for new objects: Edit → Preferences... → Draft → Visual settings → SVG pattern default size.


Arrow-left.svg Previous: Constrain