Draft Module/cn

From FreeCAD Documentation
Jump to navigation Jump to search

草图模块用于将基本的二维制图功能添加到 FreeCAD 中,其尚处于开发实验阶段。它完全用 python 语言写成,同时也给你提供在完全用 python 语言甚至不接触源代码的情况下随意扩展 FreeCAD 功能的展示平台。

目前,草图模块并不能真正地用于生产工作,但是已经包含了一组可用的基本功能。尽情尝试,并且将你的反馈意见通过讨论页面发送给我们。

The draft interface with the buttons toolbar and the function toolbar

草图工作台位于工作台列表中。当打开草图工作台后,将出现两个工具栏:包含标准草图命令(随后将详细介绍)的标准工具栏和一个特别的命令栏,此命令栏不包含工具用于显示不同功能的控制信息。利用命令栏也可以改变诸如当前线条颜色和线宽等一般的属性。作为旁注,如果在 FreeCAD 的一般首选项中选择 "cleanlooks" 样式,命令栏(甚至整个 QT 界面)将会看起来更加漂亮。

学习指南

深层次的学习可以阅读草图用法手册(尚处研发整理阶段),快速而基本的了解与使用可以阅读下面的快速自学手册。

快速自学手册

目前并不是所有的草图绘制命令都可以很好的在三维环境中使用,所以在绘图之前最好先处于正投影的二维视图方位。具体就是,首先打开或新建一份新文档,然后按下 O 键(或者通过菜单栏视图 -> 正投影视图)转换到正投影模式。然后按下 2 键(或者菜单栏视图 -> 标准视图 -> 顶视图)使位于顶视图方位。现在就可以开始绘图了。也可以通过菜单栏的“编辑 -> 首选项”来将 freecad 配置为正投影模式。

所有的草图绘制命令都具有相似的用法:绘图工具会提示你在屏幕上选择点或者输入数值坐标,修改工具会提示你先选择一个工作对象以防止没有对象被选中。几乎所有的命令工具中,按下 CTRL 键可以拾取(snap)已存点。按下 SHIFT 键将仅限制在水平、垂直、或者相对于某条已存线段的方向运动。对于一些工具,按下 ALT 键可以给出更多的选项,比如新建一个新对象的副本而不是将原有对象上进行操作。ESC 键将取消激活的命令。

注释
在一些桌面系统中(例如 Gnome、Kde),ALT 键已经被默认绑定为窗口移动的快捷键。
你应该在桌面的首选项中修改此快捷键。

一些命令也可以在非水平面工作,此时,绘图时要确保 Z 坐标轴没有被锁定,而且你要位于适当的视图位置。下面你将学习到所有可用工具的完整用法描述。

导入与导出

这些功能用于打开、导入、导出其它的文件格式。打开命令将打开一个含有文件内容的新文档。导入命令将某文件的内容添加到当前的文档中。导出命令所选对象保存至文件,如果没有对象被选择,则导出整个对象。注意由于草图模块是用于二维对象的,所以导入对象仅仅为二维对象。而且,尽管 DXF 和 OCA 格式支持在三维空间中对象的定义(对象不必是平坦的),但它们并不导入像网格、三维表面等具有体积的对象,而导入直线、圆、或者平坦的形状。目前所支持的文件格式有:


This template is now obsolete and is directly include in the original page

===绘制对象===

下面是用于创建对象的工具。

  • Draft Line.png 两点成线:用两个点绘制一条直线段
  • Draft Wire.png 折线 (多点成线):绘制一条折线段
  • Draft Circle.png :指定圆心与半径绘制圆
  • Draft Arc.png 圆弧:指定中心、半径、起始与终止角度绘制圆弧
  • Draft Rectangle.png 矩形:通过两个对角顶点绘制矩形
  • Draft Polygon.png 多边形:通过中心与半径绘制正多边形
  • Draft BSpline.png B 样条曲线:通过一系列点绘制一条 B 样条曲线
  • Draft Text.png 文本:绘制多行文本标注
  • Draft Dimension.png 尺寸:绘制尺寸标注

修改对象

下面是一组可用于修改既有对象的工具。它们可处理被选中的对象,如果未有对象被选中,那么 FreeCAD 便会要求你选中欲修改的对象。

  • Draft Move.png 平移:将一个对象或一组对象从一个位置移动到另一个位置
  • Draft Rotate.png 旋转:将一个对象或一组对象围绕旋转轴从一个角度旋转到另一个角度
  • Draft Offset.png 偏置:将对象的各段按照给定的距离进行移动(译注:移动过程中仍保持各段的连接性,例如一个半径为 1 的圆,如果设定偏移距离为 1,那么结果是半径为 2 的圆,并且与偏移前的圆同心)
  • Draft Upgrade.png 升级:提升對象的維度
  • Draft Downgrade.png 降级:降低對象的維度
  • Draft Trimex.png 裁剪/延展: 裁剪或延伸一个对象
  • Draft Scale.png 缩放:围绕一个基准点缩放被选中的对象
  • Draft Edit.png 编辑:编译一个被选中的对象
  • Draft PutOnSheet.png 制图:将所选中的对象写入图纸
  • Draft Shape2DView.png 生成二维视图:由三维对象的二维投影生成制图对象

常见操作

  • 拾取(Snapping): 允许在已存对象的特定位置放置新点
  • 限制: 允许与已知点水平或垂直的新点
  • 手动坐标: 允许手动输入坐标值而不是在屏幕上取点来确定
  • 复制: 所有的修改工具都可以直接修改选中的对象,或者另创建一份选中对象的副本再在进行修改。使用此工具时按下 ALT 键将创建一份副本
  • 创建模式: 允许将几何零件从其它零件中分离出来,以便于打开或关闭
  • 工作平面: 所有的草图绘制命令都可在三维空间中任何平面上使用。当前的工作平面可以简单的设置好
  • 所有新创建的对象都采用当前草图颜色和线宽
  • 草图模块也有它的首选项 屏幕

API

参见草图 API 页面可以了解到在脚本和宏中可以使用的草图功能的更加完整的描述。

其他语言版本: Flag-cn.jpg Flag-es.jpg Flag-fr.jpg Flag-pl.jpg Flag-ru.jpg