底图坐标

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Coordinates and the translation is 42% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

描述

描述

底图工作台工具中,您可以通过指针单击3D视图来拾取图形中的点、距离、半径与角度。

但是,当这些参数需要特别精准时,可能就要在工具对话框中输入精确值。

此时可能会涉及两个有关的界面:任务视图(taskview)与命令工具栏。菜单中默认选择的界面为:编辑(Edit) → 偏好设定(Preferences) → Draft → 常规设置(General settings) → 底图界面模式(Draft interface mode)

任务视图面板

任务视图面板是一种随具体所用工具而改变内容的智能窗口,且需要用户对其进行输入。例如,当使用底图圆形工具时,此面板将请求用户输入中心点,以及半径值。此二参数可通过在3D视图中选择点或以输入数值的方式来加以描述。

当您看到任务视图上的输入栏时,就可以为之输入数值;再者,您也将在此看到鼠标指针移动过程中相关数值的改变。

  • 按下TabEnter键可将光标依次移至X、Y、Z字段;当光标位于Z字段时,再按下Enter键即输入完成,并记录下当前设置的这个点。

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates Taskview.png

此第一张屏幕截图为绘制圆形工具的任务视图,当前正在输入圆形的中心点坐标


Draft Coordinates Taskview 2.png

此第二张屏幕截图为绘制圆形工具的任务视图,当前正在输入圆形的半径


命令工具栏

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

在命令工具栏中输入底图坐标


The Draft command toolbar is an intelligent toolbar that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the command toolbar will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the command toolbar, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.
  • Press R to switch between absolute and relative coordinates.
  • Press P to switch between original mode and copy mode.
  • Press L to lock or unlock the Z coordinate. This is now deprecated: the L key now toggles the fill mode of closed shapes.

锁定Z坐标

Draft Coordinates.jpg

在命令工具栏中输入底图坐标 (截图为老版FreeCAD)


It can be hard to align objects when working in 3D space. For this reason, you can lock the Z coordinate so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can change this; just unlock it, change the Z value, and lock it again. If the Z coordinate is locked, you won't be able to draw in non-horizontal planes.

Most Draft tools work in the working plane defined by Draft SelectPlane. Therefore, it is usually not necessary to lock the Z coordinate, just establish the correct working plane.

Set the number of decimals

By default, FreeCAD shows two decimal places in quantities. To change the number of decimal places shown change the preferences:

  • Go to Edit → Preferences → General → Units, and set "Number of decimals" to the desired value.
  • Then press Apply and OK.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.

PreferencesDecimals 01 en.png

Parameter editor to change the decimal places shown by a numerical value