Taslak Koordinat

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Tüm Taslak araçlarında, 3D nokta konumları, mesafeler, yarıçaplar, açılar veya başka bir sayısal veri istendiğinde, bu değerleri grafiksel olarak, ekran üzerinde farenizi seçerek veya doğrudan rakamları klavyeden girerek seçebilirsiniz. İlk yöntem genellikle daha sezgiseldir, ancak mutlak hassasiyetle çalıştığınızda, genellikle kesin bir sayı girmeniz ve girdiğiniz koordinatın tam olduğundan emin olmanız gerekir. Bu nedenle, Taslak modülünün komut çubuğu her zaman sayı girişini kabul edebilir:

The Workbench Draft.svg Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview (recommended) and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel (AKA Task panel) is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle.svg Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates.jpg

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


Taslak komut çubuğu, "akıllı" bir araç çubuğudur; bu, içeriğinin, kullanılan araca ve kullanıcıdan istenen girişe göre değiştiği anlamına gelir. Örneğin bir daire çizdiğinizde, komut çubuğu art arda daire merkezini ve ardından yarıçapı ister. Bu iki değer, ekranda bir nokta seçilerek veya sayı girilerek gösterilebilir.

Komut çubuğunda sayı girişi alanlarını gördüğünüzde, bunlara sayı girebilirsiniz. Bu sayıların fare imlecinizin hareketlerini yansıttığını göreceksiniz. Koordinatları ayarlamak için, TAB X, Y ve Z alanlarını kullanabilirsiniz. Z alanında ENTER tuşuna basmak, noktayı kaydeder. Yeni X, Y ve Z koordinatlarının girişini tekrarlamak bir çizgi için ikinci noktayı ve / veya bir kablo için sonraki noktaları ayarlayacaktır.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Bazen, 3D alanda çalışırken nesneleri hizalamak zor olabilir. Z koordinatını kilitleyebilirsiniz, böylece çizdiğiniz her şeyin aynı yatay düzlemde olacağından emin olabilirsiniz. FreeCAD'i açtığınızda, Z koordinatı varsayılan olarak 0.00'da kilitlenir, ancak kolayca değiştirebilirsiniz, kilidi açabilir, Z değerini değiştirebilir ve tekrar kilitleyebilirsiniz. Z koordinatı kilitliyse yatay olmayan düzlemlerde çizim yapamazsınız.

Taslak komutlarının çoğu şimdi 3D olarak çalışıyor, sadece Z koordinatının kilidini açın ve görünümü uygun açıya getirin; bundan sonra çizeceğiniz şey o görünüme hizalanır.

Set the number of decimals

Varsayılan olarak, FreeCAD iki ondalık basamakla çalışır, ondalık basamak sayısını değiştirmek için yapmanız gerekenler:

  • Araçlar → Parametreleri düzenle ...→ BaseApp → Seçenekler → Birimler menüsünde Ondalıklar adlı yeni bir tamsayı öğesi ekle
  • Pencereye sağ tıklayın ve Yeni tamsayı öğesi' → oluştur Ondalıklar 'seçip istediğiniz ondalık basamak sayısını girin.
  • Ardından değişikliklerinizi onaylamak için Diske kaydet tuşuna tıklayın.
  • Kapat ve değişikliklerini aktif hale getirmek için FreeCAD'e dön.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 en.png