Координаты чертежа

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Coordinates and the translation is 46% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Описание

The Workbench Draft.svg Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview (recommended) and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Task panel

The Task panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle.svg Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates Taskview.png

Обзор задач, первый экран для инструмента Circle, ввод координат центра

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius

Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar

Командная панель инструментов Draft является "интеллектуальной", её содержимое изменяется в соответствии с используемым инструментом и требуемым вводом от пользователя. Например, при создании окружности, командная панель инструментов последовательно запрашивает цент окружности, а затем радиус. Значения могут быть указаны выбором точек на экране или вводом чисел.

Когда вы видите поля ввода, появляющиеся на панели инструментов команды, вы можете вводить в них числа; кроме того, вы увидите, что эти числа отражают движение указателя.

  • Нажмите Tab или Enter, чтобы перейти к полям X, Y и Z; нажатие Enter в поле Z запишет точку.
  • Нажмите R для переключения между абсолютными и относительными координатами.
  • Нажмите P для переключения между режимом оригинала и режимом копирования.
  • Нажмите L, чтобы заблокировать или разблокировать координату Z. Это устарело: клавиша L теперь переключает режим заливки замкнутых фигур.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)

Выровнять объекты при работе в трёхмерном пространстве может быть сложно. Поэтому можно заблокировать Z-координату, так что всё создаваемое будет расположено в той же горизонтальной плоскости. По умолчанию при запуске FreeCAD Z-координата заблокирована в 0.00, но Вы можете изменить это. Просто разблокируйте Z-координату, введите Z-значение и заблокируйте её обратно. Если Z-координата заблокирована, то черчение возможно только в горизонтальной плоскости.

Большинство инструментов черчения работают в рабочей плоскости, определенной параметром Draft_SelectPlane. Поэтому обычно не требуется фиксировать координату Z, просто установите правильную рабочую плоскость.

Set the number of decimals

По умолчанию FreeCAD работает с числами с двумя знаками после запятой. Для изменения количества знаков после запятой:

  • Перейдите в Правка → Настройки → Основные → Единицы измерения и установите "Количество десятичных знаков" на желаемое значение.
  • Затем нажмите Применить и OK.

Другой способ - использовать редактор параметров:

  • Перейдите в Инструменты → Редкатор параметров → BaseApp → Preferences → Units и измените значение "Decimals" на желаемое.
  • Если "Decimals" не существует, вы можете его создать; щелкните правой кнопкой мыши в окне и выберите Новый целочисленный параметр → Введите название →, введите "Decimals" и продолжите, введя желаемое число.
  • Нажмите кнопку Сохранить на диск.
  • Закройте окно и вернитесь к FreeCAD для активации изменения.

PreferencesDecimals 01 en.png

Редактор параметров для изменения десятичных знаков, отображаемых числовым значением