Draft: Wartości odniesienia

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Draft Coordinates and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Opis

Narzędzia Środowiska pracy Workbench Draft.svg Draft umożliwiają graficzne wybieranie punktów, odległości, promieni i kątów poprzez wskazanie kursorem myszki i kliknięcie w widoku 3D.

Jeśli jednak te parametry muszą być precyzyjne, w oknie dialogowym narzędzia można wprowadzić dokładne wartości.

Dostępne są dwa interfejsy: Widok zadań (zalecane) i Pasek narzędzi poleceń. Domyślny interfejs jest wybierany w menu Edycja → Preferencje → Draft → Ustawienia ogólne → Tryb pracy interfejsu.

Panel Widok zadań

Panel Widok Zadań (lub Panel zadań) jest inteligentnym oknem, które zmienia swoją zawartość w zależności od używanego narzędzia i danych wejściowych wymaganych od użytkownika. Na przykład przy użyciu Draft Circle.svg Draft: Okrąg, panel poprosi Cię o wprowadzenie danych punktu centralnego, a następnie o wartość promienia. Te dwa parametry mogą być wskazane przez wybranie punktu w widoku 3D lub przez wprowadzenie liczb.

Za każdym razem, gdy zobaczysz pola wejściowe pojawiające się w Widoku zadań, możesz wprowadzić w nich liczby; ponadto zobaczysz, że liczby te odzwierciedlają ruch kursora.

  • Naciśnij klawisz Tab lub Enter, aby przejść do pól X, Y i Z; naciśnięcie Enter, w polu Z spowoduje zapisanie punktu.

W zależności od użytego narzędzia Draft, mogą być dostępne inne opcje.

  • Naciśnij klawisz R, aby przełączać między współrzędnymi bezwzględnymi i względnymi.
  • Naciśnij klawisz T, aby przełączyć się między trybem normalnym a trybem kontynuacji.
  • Naciśnij klawisz L, aby przełączyć się między trybem szkieletowym a trybem wypełnionym.
  • Naciśnij klawisz P, aby przełączyć się między trybem oryginału a trybem kopiowania.

Draft Coordinates Taskview.png

Widok zadań, pierwszy ekran narzędzia Okrąg, wprowadzanie współrzędnych środka


Draft Coordinates Taskview 2.png

Widok zadań, drugi ekran dla narzędzia Okrąg, wprowadzenie promienia


Pasek narzędzi poleceń

(listopad 2018) Od wersji FreeCAD 0.17, Pasek narzędzi poleceń Draft nie jest już preferowanym trybem interfejsu Draft. Teraz preferowany jest tryb Widok zadań. Poniższe informacje mogą nie być już dokładne lub nie działać zgodnie z opisem.


Draft Coordinates Toolbar.png

Wstępne współrzędne wprowadzone na pasku narzędzi poleceń.


Panel Widok Zadań jest inteligentnym oknem, które zmienia swoją zawartość w zależności od używanego narzędzia i danych wejściowych wymaganych od użytkownika. Na przykład przy użyciu Draft Circle.svg Draft: Okrąg, panel poprosi Cię o wprowadzenie danych punktu centralnego, a następnie o wartość promienia. Te dwa parametry mogą być wskazane przez wybranie punktu w widoku 3D lub przez wprowadzenie liczb.

Za każdym razem, gdy zobaczysz pola wprowadzania pojawiające się na pasku narzędzi poleceń, możesz wprowadzić w nich liczby. Co więcej, zobaczysz, że liczby te odzwierciedlają ruch kursora.

  • Naciśnij klawisz Tab lub Enter, aby przejść do pól X, Y i Z. Naciśnięcie Enter, w polu Z spowoduje zapisanie punktu.
  • Naciśnij klawisz R, aby przełączać między współrzędnymi bezwzględnymi i względnymi.
  • Naciśnij klawisz P, aby przełączyć się między trybem oryginału a trybem kopiowania.
  • Naciśnij klawisz L, aby przełączyć się między trybem szkieletowym a trybem wypełnionym.

Blokowanie współrzędnej Z

Draft Coordinates.jpg

Wstępne współrzędne wprowadzone na pasku narzędzi poleceń (starsza wersja FreeCAD)


Wyrównanie obiektów podczas pracy w przestrzeni 3D może być trudne. Z tego powodu możesz zablokować współrzędne Z, aby mieć pewność, że wszystko co narysujesz będzie leżało w tej samej płaszczyźnie poziomej. Kiedy uruchomisz FreeCAD, współrzędna Z jest domyślnie zablokowana na 0.00, ale możesz to zmienić. Wystarczy ją odblokować, zmienić wartość Z i zablokować ponownie. Jeśli współrzędna Z jest zablokowana, nie będziesz mógł rysować na płaszczyznach nie poziomych.

Większość narzędzi Draft działa na płaszczyźnie roboczej zdefiniowanej przez Draft: Wybór płaszczyzny. Dlatego zazwyczaj nie jest konieczne blokowanie współrzędnych Z, tylko ustalenie właściwej płaszczyzny roboczej.

Ustawienie liczby miejsc po przecinku

Domyślnie FreeCAD pokazuje dwa miejsca po przecinku w liczbach. Aby zmienić ilość wyświetlanych miejsc po przecinku, należy dostosować preferencje:

  • Przejdź do Edycja → Preferencje → Ogólne → Jednostki i ustaw opcję Liczba cyfr po przecinku na żądaną wartość.
  • Następnie naciśnij przycisk Zastosuj i OK.

Innym sposobem jest użycie edytora parametrów:

  • Przejdź do menu Narzędzia → Edycja parametrów → BaseApp → Preferences → Units, i zmień wartość "Decimals" na żądaną liczbę.
  • Jeśli wartość „Dziesiętne” nie istnieje, możesz ją utworzyć. W tym celu kliknij prawym przyciskiem myszy w oknie i wybierz Nowy obiekt liczby całkowitej → Wprowadź nazwę, wpisz Decimals i przejdź do wpisania żądanej liczby.
  • Następnie kliknij w przycisk Zapisz na dysku i Zamknij.
  • Uruchom ponownie FreeCAD, aby aktywować zmiany.

PreferencesDecimals 01 en.png

Edytor parametrów do zmiany miejsc dziesiętnych pokazanych przez wartość liczbową