Компиляция в Windows

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Compile on Windows and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский

На этой странице шаг за шагом объясняется "как скомпилировать FreeCAD 0.19 или новее в Windows"". Для других платформ см.Compiling.

Требования

Для компиляции FreeCAD в Windows требуется несколько инструментов и библиотек.

Требования

  • Компилятор. FreeCAD тестируется с помощью Visual Studio (MSVC)—другие компиляторы могут работать, но инструкции по использованию здесь не включены. Более подробная информация в #Compiler, находится ниже.
  • Git (Для Git также доступны графические интерфейсы, см. Следующий раздел.)
  • CMake версия 3.11.x или более новая.
    "Подсказка:" Выбор опции Add CMake to the system PATH for all users при установке CMake сделает CMake доступным из командной строки Windows, что может быть полезно.
  • LibPack (так называемый FreeCADLibs). Это единый пакет, содержащий все библиотеки, необходимые для компиляции FreeCAD в Windows. Загрузите версию LibPack, соответствующую версии FreeCAD, которую вы хотите скомпилировать. Чтобы скомпилировать FreeCAD 0.19 или последнюю версию разработки 0.20, загрузите LibPack для 0.19/0.20 (только 64-разрядная версия). Извлеките пакет LibPack в удобное место. (Если ваш компьютер не распознает расширение .7z, вам следует установить программу 7-zip.)
    "Примечание": Настоятельно рекомендуется компилировать FreeCAD с версией компилятора, для которой предназначен LibPack. Например, вы можете столкнуться с проблемами при компиляции FreeCAD 0.19 с использованием MSVC 15, поскольку LibPack для 0.19 предназначен для сборки с MSVC 17.

Опционные программы

  • Графический интерфейс для Git. Существует несколько доступных интерфейсов, см. this list. Основное преимущество интерфейса заключается в том, что вам не нужно изучать команды Git, чтобы получить исходный код FreeCAD или отправлять исправления в репозиторий FreeCAD на GitHub.

Ниже мы опишем обработку исходного кода с использованием интерфейса TortoiseGit. Этот интерфейс интегрируется непосредственно в проводник файлов Windows и имеет большое сообщество пользователей, которые могут получить помощь в случае возникновения проблем.

  • NSIS используется для создания установщика Windows FreeCAD.

Исходный код

Теперь вы можете получить исходный код FreeCAD:

Использование интерфейса

При использовании TortoiseGit Интерфейс Git:

  1. Создайте новую папку, в которую будет загружен исходный код.
  2. Щелкните правой кнопкой мыши на этой папке в проводнике файлов Windows и выберите "'Git Clone" в контекстном меню.
  3. Появится диалоговое окно. В нем введите URL-адрес репозитория FreeCAD Git

https://github.com/FreeCAD/FreeCAD.git

и нажмите "ОК".

Последний исходный код будет загружен из репозитория FreeCAD Git, и Git будет отслеживать папку.

Использование командной строки

Чтобы создать локальную ветвь отслеживания и загрузить исходный код, откройте терминал (command prompt) и перейдите в каталог, в котором вы хотите получить исходный код, затем введите:

git clone https://github.com/FreeCAD/FreeCAD.git

Компилятор

По умолчанию (recommended) используется компилятор MS Visual Studio (MSVC). Хотя, возможно, можно использовать другие компиляторы, например gcc через Cygwin или MinGW, это не тестируется и не рассматривается здесь.

Вы можете получить бесплатную версию MSVC (для индивидуального использования), загрузив Community edition of MS Visual Studio.

Для тех, кто хочет избежать установки огромного MSVC только для того, чтобы иметь компилятор, см. CompileOnWindows - Reducing Disk Footprint.

"Примечание:" Несмотря на то, что "Community" выпуск MSVC является бесплатным, для использования среды IDE в течение более чем 30-дневного пробного периода необходимо создать учетную запись Майкрософт. Если вы будете компилировать только с помощью командной строки, вам не понадобится среда разработки и, следовательно, учетная запись Microsoft.

В качестве бесплатной и альтернативной среды разработки с открытым исходным кодом вы можете использовать KDevelop. Вы можете использовать KDevelop для изменения и написания кода на C++, но для компиляции необходимо использовать командную строку.

Дополнительная конфигурация системного пути

При необходимости вы можете включить пути к некоторым папкам в переменную системного ПУТИ. Это полезно, если вы хотите получить доступ к программам в этих папках из командной строки/powershell или если вы хотите, чтобы компилятор или CMake находили специальные программы. Кроме того, добавление папок в ПУТЬ может потребоваться, если вы не использовали соответствующие параметры при установке программы.

  • Вы можете включить папку вашего LibPack в переменную системного ПУТИ. Это полезно, если вы планируете создавать несколько конфигураций/версий FreeCAD.
  • Если вы не использовали опцию добавления CMake в ПУТЬ при его установке, добавьте папку его установки

"C:\Program Files\CMake\bin" по ПУТИ.

  • Если вы не использовали опцию добавления TortoiseGit в ПУТЬ при его установке, добавьте папку его установки

C:\Program Files\TortoiseGit\bin по ПУТИ.

Чтобы добавить пути к папкам в переменную PATH:

  1. В меню "Start" Windows щелкните правой кнопкой мыши на "Computer" и выберите "Properties".
  2. В появившемся диалоговом окне нажмите "Advanced system settings".
  3. Откроется другое диалоговое окно. Нажмите там на вкладке "Advanced" в разделе "Environment Variables".
  4. Снова откроется другое диалоговое окно. Затем выберите переменную "Path" и нажмите "Edit".
  5. И снова откроется другое диалоговое окно. Нажмите там на "New" и добавьте в путь к папке Git или LibPack.
  6. Наконец, нажмите "ОК" и закройте все диалоговые окна, также нажав "ОК".

Конфигурация

Как только у вас будут все необходимые инструменты, библиотеки и исходный код FreeCAD, вы будете готовы приступить к процессу настройки и компиляции. Этот процесс будет проходить в пять этапов:

  1. Запустите CMake один раз, чтобы проверить вашу систему и начать процесс настройки (это сообщит о том, что она не удалась).
  2. Настройте необходимые параметры CMake, чтобы установить расположение пакета LibPack и включить Qt5.
  3. Повторно запустите CMake, чтобы завершить настройку (на этот раз она должна завершиться успешно).
  4. Используйте CMake для создания системы сборки Visual Studio.
  5. Используйте Visual Studio для создания FreeCAD.

CMake

Во-первых, настройте среду сборки с помощью CMake:

  1. Откройте графический интерфейс CMake
  2. Укажите исходную папку FreeCAD.
  3. Укажите папку сборки (не используйте исходную папку-CMake создаст эту папку, если она не существует).
  4. Нажмите кнопку "Configure".
  5. В появившемся диалоговом окне укажите генератор, который вы хотите использовать: в большинстве случаев вы будете использовать значения по умолчанию в этом диалоговом окне. Для стандартной MS Visual Studio используйте "Visual Studio xx 2yyy", где xx-версия компилятора, а 2yyy-год его выпуска. Рекомендуется использовать опцию по умолчанию "Use default native compilers".

Примечание: Важно указать правильный вариант разрядности. Если у вас есть 64-разрядный вариант LibPack, вы также должны использовать компилятор x64.

Это приведет к началу настройки и "завершится ошибкой" из-за отсутствия настроек. Это нормально, вы еще не указали местоположение пакета LibPack. Однако могут возникнуть и другие сбои, которые потребуют некоторых дальнейших действий с вашей стороны.

Если произойдет сбой с сообщением о том, что Visual Studio не найдена, поддержка CMake в MSVC еще не установлена. Для этого:

  1. Откройте среду разработки MSVC
  2. Используйте меню Tools → Get Tools и Features
  3. На вкладке "Workloads" включите "Desktop development with C++".
  4. На правой стороне теперь вы должны видеть, что будет установлен компонент "Visual C++ tools for CMake".
  5. Установите его.

Если он завершится ошибкой с сообщением о неверной версии Python или отсутствующем Python, то:

  1. Используйте поле "Search:" в CMake для поиска строки "Python".
  2. Если вы видите там путь, подобный "C:/Program Files/Python38/python.exe", CMake распознал Python, который уже установлен на вашем компьютере, но эта версия несовместима с LibPack. Поскольку LibPack включает совместимую версию Python, измените следующие параметры Python в CMake в соответствии с его путями (при условии, что LibPack находится в папке "D:\FreeCAD-build\FreeCADLibs_12.5.2_x64_VC17"):

CMake Python settings.png

Если нет ошибки в Visual Studio или Python, все в порядке, но CMake еще не знает всех необходимых настроек. Поэтому сейчас:

  1. Найдите в CMake переменную "FREECAD_LIBPACK_DIR" и укажите местоположение папки LibPack, которую вы загрузили ранее.
  2. Только если сборка FreeCAD 0.19, найдите переменную "'BUILD_QT5" и включите эту опцию.
  3. Нажмите "Configure" еще раз.

Теперь ошибок быть не должно. Если вы по-прежнему сталкиваетесь с ошибками, которые не можете диагностировать, посетите Install/Compile forum на веб-сайте форума FreeCAD. Если CMake прошел правильно, нажмите на кнопку "Generate". После этого вы можете закрыть CMake и начать компиляцию FreeCAD с помощью Visual Studio. Однако для первой компиляции держите его открытым на случай, если вам захочется или потребуется изменить некоторые параметры процесса сборки.

"Примечание:" При компиляции FreeCAD 0.19 переменная CMake "BUILD_ENABLE_CXX_STD" будет установлена в "C++14", в то время как она будет установлена для FreeCAD 0.20 в "C++17". Это связано с тем, что для FreeCAD 0.20 требуется, по крайней мере, стандартная версия языка C++ 17. Поэтому, когда вы в последний раз компилировали FreeCAD 0.19, необходимо повторно запустить CMake для FreeCAD 0.20, чтобы изменить стандарт языка C++.

Параметры процесса сборки

Система сборки CMake дает вам контроль над некоторыми аспектами процесса сборки. В частности, вы можете включать и выключать некоторые функции или модули с помощью переменных CMake.

Вот описание некоторых из этих переменных:

Variable name Description Default
BUILD_XXX Создайте FreeCAD с компонентом XXX. Если вы не хотите/не нуждаетесь в компиляции, например, рабочего стола "OpenSCAD", отключите переменную "BUILD_OPENSCAD". Тогда у FreeCAD не будет этого верстака.

""Примечание: "" Некоторые компоненты требуются для других компонентов. Если вы, например, снимите флажок "BUILD_ROBOT", CMake сообщит вам, что компонент "Путь" не может быть правильно скомпилирован. Поэтому проверьте вывод CMake после изменения параметра BUILD_XXX!

depends
BUILD_ENABLE_CXX_STD Версия стандарта языка C++. "C++14" является максимально возможным для FreeCAD 0.19, в то время как для FreeCAC 0.20 требуется как минимум "C++17". См. Также примечание в разделе Building with Visual Studio 15 (2017) and 16 (2019) depends
CMAKE_INSTALL_PREFIX Выходная папка при создании целевой "INSTALL" см. также раздел Running and installing FreeCAD Windows' default program installation folder
FREECAD_COPY_DEPEND_DIRS_TO_BUILD Копии библиотек, необходимых для выполнения FreeCAD.exe в папку сборки. См. также раздел Running and installing FreeCAD.
"Примечание:" параметры FREECAD_COPY_XXX отображаются только в том случае, если библиотеки еще не были скопированы. Поэтому при переходе на другую версию LibPack важно удалить все папки в папке сборки, кроме папки LibPack. В CMake удалите кэш и начните так, как будто вы компилируете в первый раз, и вы получите параметры FREECAD_COPY_XXX options.
OFF
FREECAD_COPY_PLUGINS_BIN_TO_BUILD Copies Qt's plugin files needed to execute the FreeCAD.exe to the build folder. См. также раздел Running and installing FreeCAD. OFF
FREECAD_LIBPACK_USE Switch the usage of the FreeCAD LibPack on or off ON
FREECAD_LIBPACK_DIR Directory where the LibPack is FreeCAD's source code folder
FREECAD_RELEASE_PDB Create debug libraries also for release builds ON

Сборка FreeCAD

В зависимости от вашего компилятора процесс создания FreeCAD будет немного отличаться. В следующих разделах описаны известные вам рабочие процессы. Если вы создаете с помощью Qt Creator, перейдите к Building with Qt Creator, в противном случае продолжайте напрямую:

Сборка в Visual Studio 15 (2017) и 16 (2019)

Сборка релиза

  1. Запустите среду разработки Visual Studio. Это можно сделать либо нажатием кнопки "Open Project" в графическом интерфейсе CMake, либо двойным щелчком по файлу "FreeCAD.sln", который вы найдете в папке сборки.
  2. На панели инструментов среды разработки MSVC убедитесь, что вы используете для первой компиляции "Release".
  3. Есть окно под названием "Solution Explorer". В нем перечислены все возможные цели компиляции. Чтобы начать полную компиляцию, щелкните правой кнопкой мыши на целевом объекте "ALL_BUILD", а затем выберите "Build".

Теперь это займет довольно много времени.

Чтобы скомпилировать готовый к использованию FreeCAD, скомпилируйте целевую "INSTALL", см. раздел Running and installing FreeCAD.

Если вы не получили никаких ошибок, значит все готов. "Поздравляю!" Теперь вы можете выйти из MSVC или оставить его открытым.

"Примечание:" Для FreeCAD 0.20 требуется, по крайней мере, стандартная версия языка C++ 17, но сторонний компонент "flann" из LibPack еще не готов для этого. Поэтому вы получите ошибки компиляции для целевого "обратного проектирования". Чтобы исправить это, щелкните правой кнопкой мыши на этом целевом объекте в обозревателе решений MSVC и выберите в контекстном меню последнюю запись "Properties". В появившемся диалоговом окне измените "C++ Language Standard" на "ISO C++14". Наконец, снова создайте цель "ALL_BUILD".

Отладочная сборка

Для отладочной сборки необходимо использовать Python, который входит в пакет LibPack. Чтобы гарантировать это:

  1. Поиск в графическом интерфейсе CMake "Python"
  2. Если вы видите там путь, подобный "C:/Program Files/Python38/python.exe", CMake распознал Python, установленный на вашем компьютере, а не тот, который входит в LibPack. В этом случае адаптируйте эти различные настройки Python в CMake к этому (при условии, что LibPack находится в папке "D:\FreeCAD-build\FreeCADLibs_12.5.2_x64_VC17"):

CMake Python settings.png

Теперь

  1. Запустите среду разработки Visual Studio. Это можно сделать либо нажатием кнопки "Open Project" в графическом интерфейсе CMake, либо двойным щелчком по файлу "FreeCAD.sln", который вы найдете в папке сборки.
  2. На панели инструментов среды разработки MSVC убедитесь, что вы используете для первой компиляции "Debug".
  3. Есть окно под названием "Solution Explorer". В нем перечислены все возможные цели компиляции. Чтобы начать полную компиляцию, щелкните правой кнопкой мыши на целевом объекте "ALL_BUILD", а затем выберите "Build" в контекстном меню.

Теперь это займет довольно много времени. Если ошибок компиляции не было, вы можете запустить отладочную сборку:

  1. Щелкните правой кнопкой мыши на целевой "FreeCADMain", а затем выберите "Set as Startup Project" в контекстном меню.
  2. Наконец, нажмите на панели инструментов на кнопку с зеленым треугольником под названием "Local Windows Debugger".

Это запустит отладочную сборку FreeCAD, и вы сможете использовать среду разработки MSVC для ее отладки.

Видеоресурс

Учебник по английскому языку, который начинается с настройки в графическом интерфейсе CMake и продолжается командой "Build" в Visual Studio 16 2019, доступен без списка на YouTube по адресу Tutorial: Build FreeCAD from source on Windows 10.

Сборка с помощью Qt Creator (устарело)

Инсталяция и настройка Qt Creator

  • Загрузите и установите Qt Creator
  • Tools → Options → Text Editor → Behavior tab:
    • File Encodings → Default Encodings:
    • Установите значение: "'ISO-8859-1 /...csISOLatin1"' (Некоторые символы создают ошибки/предупреждения с помощью Qt Creator, если оставить значение UTF-8. Это, кажется, все исправляет.)
  • Tools → Options → Build & Run:
    • CMake tab
      • Заполните поле Исполняемый файл путем к cmake.exe
    • Kits tab
      • Name: MSVC 2008
      • Compiler: Microsoft Visual C++ Compiler 9.0 (x86)
      • Debugger: Auto detected...
      • Версия Qt: Отсутствует
    • General tab
      • Снимите флажок: Всегда создавайте проект перед его развертыванием
      • Снимите флажок: Всегда развертывайте проект перед его запуском

Импорт проекта и здания

  • File → Open File or Project
  • Открыть "'CMakeLists.txt"' который находится на верхнем уровне источника
  • Это запустит CMake
  • Выберите каталог сборки и нажмите кнопку Далее
  • Установите для генератора значение "NMake Generator (MSVC 2008)"'
  • Нажмите кнопку Запустить CMake. Следуйте инструкциям, приведенным выше, чтобы настроить CMake по своему вкусу.

Теперь FreeCAD можно построить

  • Build → Build All
  • Это займет много времени...

После завершения его можно запустить: В левом нижнем углу есть 2 зеленых треугольника. Один из них-отладка. Другой "run". Выбери, что тебе больше нравится.

Сборка из командной строки

Шаги по компиляции из командной строки зависят от компилятора. Для MSVC 2017 следующие шаги:

  1. В меню "Пуск" Windows перейдите в Visual Studio 2017 → Visual Studio Tools и выберите ""Командная строка разработчика для VS 2017""
  2. Перейдите в папку сборки.
  3. Выполните команду
msbuild ALL_BUILD.vcxproj /p:Configuration=Release

или

msbuild INSTALL.vcxproj /p:Configuration=Release

Эти шаги также могут быть автоматизированы. Вот, например, решение для MSVC 2017:

  1. Скачать скрипт compile-FC.txt.
  2. Переименуйте его в "compile-FC.bat".
  3. В проводнике файлов Windows Shift+Right-click на папке сборки и используйте из контекстного меню "Command prompt here".
  4. Выполните команду
compile-FC install

Вместо вызова compile-FC с опцией install вы также можете использовать debug или release.:

debug   - компиляция FreeCAD в конфигурации отладки

release - компиляция FreeCAD в конфигурации выпуска

install    - скомпилируйте FreeCAD в конфигурации выпуска и создайте установку установки

Запуск и установка FreeCAD

Существует 2 метода для запуска скомпилированного FreeCAD:

"Метод 1": Вы выполняете FreeCAD.exe которые вы найдете в своей папке сборки во вложенной папке "bin"

"Метод 2": Вы создаете целевую "УСТАНОВКУ"

Метод 2 является более простым, поскольку он автоматически гарантирует, что все библиотеки, необходимые для запуска FreeCAD.exe находятся в нужной папке. В FreeCAD.exe и библиотеки будут выведены в папку, указанную вами в переменной CMake "CMAKE_INSTALL_PREFIX".

Для метода 1 вам нужно поместить библиотеки в папку "bin" вашей папки сборки (где FreeCAD.exe есть). Это можно легко сделать:

  1. Откройте графический интерфейс CMake.
  2. Найдите там параметр переменной "FREECAD_COPY_DEPEND_DIRS_TO_BUILD" и проверьте его. Если такой опции нет, библиотеки уже были скопированы, см. description of the options.
  3. Найдите там параметр переменной "FREECAD_COPY_LIBPACK_BIN_TO_BUILD" и проверьте его.
  4. Найдите там параметр переменной "FREECAD_COPY_PLUGINS_BIN_TO_BUILD" и проверьте его.
  5. Нажмите на кнопку "Configure". В конце настройки CMake автоматически скопирует необходимые библиотеки из папки LibPack.

Обновление сборки

FreeCAD очень активно развивается. Поэтому его исходный код меняется почти ежедневно. Добавляются новые функции и исправляются ошибки. Чтобы извлечь выгоду из этих изменений исходного кода, вы должны перестроить свой FreeCAD. Это делается в два этапа:

  1. Обновление исходного кода
  2. Перекомпиляция

Обновление исходного кода

Использование интерфейса

При использовании Git frontend TortoiseGit:

  1. Щелкните правой кнопкой мыши папку с исходным кодом FreeCAD в проводнике файлов Windows и выберите в контекстном меню ""Pull"".
  2. Появится диалоговое окно. Выберите там, какую ветвь разработки вы хотите получить. "master" - это основная ветвь. Поэтому используйте это, если вы не хотите скомпилировать специальную новую функцию из ветви, которая еще не была объединена в "master". (Для получения дополнительной информации о ветвях Git см. Git development process.)

Наконец, нажмите "ОК".

Использование командной строки

Откройте терминал (командная строка) и переключитесь там в свой исходный каталог. Затем введите:

git pull https://github.com/FreeCAD/FreeCAD.git master

где "master" - название основной ветви разработки. Если вы хотите получить код из другой ветви, используйте ее имя вместо "master".

Сборник

  1. Откройте среду разработки MSVC, дважды щелкнув файл "FreeCAD.sln" или файл "ALL_BUILD.vcxproj" в папке сборки.
  2. Перейдите к шагу 2 из раздела Building with Visual Studio 15 2017.

Инструменты

Для того, чтобы включиться к разработке FreeCAD, вы должны скомпилировать и установить следующие инструменты:

Плагин Qt designer

FreeCAD использует Qt в качестве инструментария для его пользовательского интерфейса. Все диалоговые окна настраиваются в UI-файлах, которые можно редактировать с помощью программы Qt Designer, который является частью любой установки Qt, а также включен в пакет LibPack. FreeCAD имеет свой собственный набор виджетов Qt для предоставления специальных функций, таких как добавление единицы измерения в поля ввода и настройка свойств настроек.

Установка

Чтобы Qt Designer знал о виджетах FreeCAD, вы должны

  1. Скачать this ZIP файл. (Скомпилирован с использованием Qt 5.12, см. below.)
  2. Извлеките DLL-файл в ZIP-файле и скопируйте его
  • Если вы используете LibPack: в папку
    "~\FreeCADLibs_12.5.2_x64_VC17\bin\designer"
    , так как там будет только папка "bin", и вы должны сначала создать подпапку "конструктор".
  • Если у вас полная установка Qt: вы можете выбрать между folder
    "C:\Qt\5.15.2\msvc2019_64\plugins\designer"
    or
    "C:\Qt\5.15.2\msvc2019_64\bin\designer" (сначала вы должны создать подпапку "конструктор".)
    (адаптируйте пути к вашей установке!).

(Повторно)Запустите Qt Designer и проверьте его меню Help → Plugins. Если плагин "' FreeCAD_widgets.dll"' указана как загружаемая, теперь вы можете создавать и изменять файлы .ui FreeCAD. Если нет, вы должны compile создать библиотеку DLL самостоятельно.


Если вы предпочитаете использовать Qt Creator вместо Qt Designer библиотека DLL должна быть помещена в эту папку:
"C:\Qt\Qt5.15.2\Tools\QtCreator\bin\plugins\designer"
(Повторно)Запустите Qt Creator, переключитесь в режим "Design", а затем проверьте меню Tools → Form Editor → About Qt Designer Plugins. Если плагин "' FreeCAD_widgets.dll"' указана как загружаемая, теперь вы можете создавать и изменять файлы .ui FreeCAD. Если нет, вы должны compile создать библиотеку DLL самостоятельно.

Сборник

DLL не может быть загружена как плагин, если она была скомпилирована с использованием другой версии Qt, чем тот, на котором основан ваш Qt Designer/Qt Creator. В этом случае вы должны скомпилировать DLL самостоятельно. Это делается следующим образом:

  1. Перейдите в исходную папку FreeCAD
    "~\src\Tools\plugins\widget"
  2. Откройте командную строку MSVC x64 с помощью меню "Пуск" Windows и перейдите в нее в указанную выше папку. Важно, чтобы это была x64-версия командной строки MSVC!
  3. Выполните эту команду
    qmake -t vclib plugin.pro
    
    Если qmake не удалось найти, используйте полный путь к нему, например, для пакета LibPack он должен быть таким (адаптируйте пути к вашей установке):
    "D:\FreeCAD-build\FreeCADLibs_12.5.2_x64_VC17\bin\qmake -t vclib plugin.pro"
    for a full Qt это
    "C:\Qt\5.15.2\msvc2019_64\bin\qmake -t vclib plugin.pro"
    (адаптируйте пути к вашей установке!)
  4. Вызов "qmake" создал файл "FreeCAD_widgets.vcxproj" в папке "~\src\Tools\plugins\widget". Дважды щелкните по нему, и откроется среда разработки MSVC.
  5. На панели инструментов среды разработки MSVC убедитесь, что вы используете целевой объект компиляции "Release".
  6. Есть окно под названием "Solution Explorer". Щелкните правой кнопкой мыши на "FreeCAD_widgets", а затем выберите "Build".
  7. В результате у вас теперь должны быть "'FreeCAD_widgets.dll"' в папке "~\src\Tools\plugins\widget\release", которую вы можете установить в качестве плагина, как описано выше.

Поставщик миниатюр

FreeCAD имеет функцию предварительного просмотра миниатюр для файлов *.FCStd. Это означает, что в проводнике файлов Windows *.FCStd файлы отображаются со снимком экрана модели, которую он содержит. Чтобы предоставить эту функцию, FreeCAD должен иметь файл "'FCStdThumbnail.dll"" где установлено в Windows.

Установка

Библиотека DLL устанавливается таким образом:

  1. Скачать this ZIP file и извлеките его.
  2. Откройте командную строку Windows с правами администратора (эти права являются обязательным требованием).
  3. Перейдите в папку, в которой находится библиотека DLL.
  4. Выполните эту команду
    regsvr32 FCStdThumbnail.dll
    

Поэтому проверьте, работает ли это, убедитесь, что в FreeCAD включена опция настроек "Save thumbnail into project file when saving document"" и сохраните модель. Затем просмотрите в проводнике Windows папку сохраненной модели, используя представление символов. Теперь вы должны увидеть снимок экрана модели в представлении папок.

Сборник

Для компиляции FCStdThumbnail.dll

  1. Перейдите в исходную папку FreeCAD
    "~\src\Tools\thumbs\ThumbnailProvider"
  2. Откройте графический интерфейс CMake
  3. Укажите там в качестве исходной папки ту, в которой вы находитесь в данный момент.
  4. Используйте ту же папку, что и папка сборки.
  5. Нажмите "Configure".
  6. В появившемся диалоговом окне укажите генератор в соответствии с тем, который вы хотите использовать. Для стандартной MS Visual Studio используйте "Visual Studio xx 2yyy", где xx-версия компилятора, а 2yyy-год его выпуска. Рекомендуется использовать опцию по умолчанию "Использовать собственные компиляторы по умолчанию".
    "Примечание:" Важно указать правильный вариант бита. Если у вас 64-битный вариант LibPack, вы также должны использовать компилятор x64.
  7. Нажмите на кнопку "Generate".
  8. Теперь у вас должен быть файл "ALL_BUILD.vcxproj" в папке "~\src\Tools\thumbs\ThumbnailProvider". Дважды щелкните по нему, и откроется среда разработки MSVC.
  9. На панели инструментов среды разработки MSVC убедитесь, что вы используете целевой объект компиляции "Release".
  10. Есть окно под названием "Solution Explorer". Щелкните правой кнопкой мыши на "ALL_BUILD", а затем выберите "Build".
  11. В результате у вас теперь должно быть "'FCStdThumbnail.dll"' в папке "~\src\Tools\thumbs\ThumbnailProvider\release", который вы можете установить, как описано выше.


Компиляция OpenCascade

Стандартный пакет Libpack поставляется с версией OpenCascade, подходящей для общего использования. Однако при некоторых обстоятельствах вы можете захотеть скомпилировать с альтернативной версией OpenCascade, такой как один из их официальных релизов или исправленная ветвь. Обратите внимание, что нет никакой гарантии, что FreeCAD будет работать со всеми версиями OpenCascade, и использование версии, отличной от Libpack, предназначено только для продвинутых пользователей. Обратите также внимание, что если вы используете библиотеку Netgen, она использует OpenCascade для некоторых своих функций и должна быть скомпилирована с той же версией OpenCascade, которую вы используете при компиляции FreeCAD.

Процесс создания пользовательской версии OpenCascade аналогичен процессу для FreeCAD, и вы можете использовать уже загруженный пакет FreeCAD Libpack для предоставления необходимых ему сторонних зависимостей (Freetype и Tcl/Tk).

Сначала получите исходный код OpenCascade либо непосредственно со страницы выпуска по адресу OpenCASCADE.org, через git, или путем клонирования чужой вилки, например вилка "blobfish" поддерживается участником форума FreeCAD tanderson69.

Затем используйте CMake для настройки системы сборки аналогично созданию FreeCAD. Примечательными вариантами CMake для OpenCascade являются:

  • 3RDPARTY_DIR - Место расположения ваших сторонних библиотек, обычно заданное в каталоге FreeCAD Libpack
  • INSTALL_DIR - Где устанавливают готовые библиотеки. Рекомендуется использовать изолированный каталог в вашей системе, а не устанавливать его глобально или перезаписывать версию Libpack.

Наконец, откройте проект в Visual Studio и создайте ALL_BUILD, а затем УСТАНОВИТЕ целевые объекты.

Как только вы сгенерируете соответствующие библиотеки DLL для OpenCascade (их много), вам нужно будет перестроить FreeCAD. Откройте CMake и настройте каталоги исходного кода и сборки сборки FreeCAD, как указано выше. Как правило, рекомендуется использовать новый каталог сборки для этой альтернативной версии OpenCascade, чтобы было легко переключиться на старую версию FreeCAD, если что-то пойдет не так, и настроить каталог установки, чтобы вы могли убедиться, что установлены правильные библиотеки. В дополнение к переменным CMake, описанным выше, установите переменную OpenCASCADE_DIR в расположение папки cmake, содержащей информацию о сборке OpenCascade. Например: CMAKE_INSTALL_PREFIX C:/Users/JaneDoe/Work/FreeCAD_occt751-install/ OpenCASCADE_DIR C:/Users/JaneDoe/Work/opencascade-7.5.1-install/cmake/


После того, как вы использовали CMake для создания файлов сборки для FreeCAD, откройте его в Visual Studio, создайте его, а затем запустите сборку в целевом объекте УСТАНОВКИ.

Ссылки на литературу

Смотрите также