Compilare in Windows

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Compile on Windows and the translation is 84% complete.
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
Arrow-left.svg Smistamento dei bug Pagina precedente:
Pagina successiva: Compilazione in Linux Arrow-right.svg

Questo articolo spiega passo dopo passo come compilare FreeCAD 0.18 o superiore su Windows. Per altre piattaforme vedere la pagina Compilazione.

Prerequisiti

Innanzitutto è necessario installare le seguenti librerie e programmi richiesti:

Programmi richiesti

  • Git Ci sono una serie di alternative come GitCola, Tortoise Git, e altri.
  • CMake versione 3.11.x - 3.17.x. Nota: Di solito non si può prendere l'ultima versione di CMake. Pertanto, utilizzare solo una versione di CMake nell'intervallo specificato in questa pagina!

Si consiglia di utilizzare l'opzione Aggiungi CMake al PERCORSO di sistema per tutti gli utenti durante l'installazione di CMake. Quindi in seguito puoi accedere facilmente a CMake anche dalla riga di comando/powershell.

  • LibPack (chiamato anche FreeCADLibs). Questo è un insieme di librerie necessarie per compilare FreeCAD su Windows. A seconda della versione di FreeCAD che vuoi compilare, devi scaricare il LibPack corrispondente. Ad esempio per compilare FreeCAD 0.18, scarica la versione a 32 bit o 64 bit di LibPack for 0.18, per compilare l'ultima versione di sviluppo 0.19, scaricare il LibPack for 0.19 (esiste solo una versione a 64 bit).

Basta scaricare LibPack, decomprimerai e configurerai in seguito.

Nota: Si consiglia di utilizzare la stessa versione del compilatore MS Visual Studio (MSVC) per cui è progettato LibPack. Questo assicura che la compilazione e l'esecuzione del FreeCAD.exe compilato abbiano esito positivo. Quindi, ad esempio, dovresti essere in grado di compilare FreeCAD 0.18 usando LibPack per 0.19 e MSVC 15 ma potresti avere problemi a compilare FreeCAD 0.18 usando LibPack per 0.18 e MSVC 15 perché LibPack per 0.18 è progettato per essere costruito con MSVC 12.

Programmi opzionali

  • Python 3.x. Un'installazione separata di Python non è obbligatoria poiché LibPack contiene Python. Tuttavia, per poter testare successivamente la tua build di FreeCAD è utile avere un'installazione Python autonoma. Si consiglia di utilizzare non l'ultima versione, ma la versione precedente (ad esempio non Python 3.8 ma 3.7).
  • Un frontend GUI per Git. Ci sono diversi frontend disponibili, vedi this list. Il vantaggio principale di un frontend è che non devi imparare i comandi Git per ottenere il codice sorgente di FreeCAD o per inviare patch al repository GitHub di FreeCAD.

Di seguito descriviamo la gestione del codice sorgente usando il frontend TortoiseGit. Questo frontend si integra direttamente con Esplora file di Windows e dispone di una grande comunità di utenti per ricevere assistenza in caso di problemi.

  • NSIS Questo è il programma per generare il programma di installazione di Windows di FreeCAD. (Informazioni: per FreeCAD 0.17 e precedenti il programma WiX è stato utilizzato per creare il programma di installazione.)

Codice sorgente

Ora puoi ottenere il codice sorgente di FreeCAD:

Utilizzo di un frontend

Quando si utilizza il Git frontend TortoiseGit:

  1. Crea una nuova cartella in cui dovrebbe essere il codice sorgente.
  2. Fare clic con il tasto destro su questa cartella in Esplora file di Windows e selezionare nel menu contestuale Git Clone.
  3. Apparirà una finestra di dialogo. Usa lì come URL per il repository di FreeCAD

https://github.com/FreeCAD/FreeCAD.git

e clicca OK.

Ora il codice sorgente viene scaricato e la sua cartella diventa una cartella tracciata da Git.

Usando la riga di comando

Per creare un ramo locale e scaricare il codice sorgente è necessario aprire un terminale (prompt dei comandi) e portarsi nella directory in cui si desidera creare il sorgente, quindi digitare:

git clone https://github.com/FreeCAD/FreeCAD.git

Compilatore

Il compilatore predefinito (consigliato) è MS Visual Studio (MSVC). Sebbene possa essere possibile utilizzare altri compilatori utilizzando Cygwin o MinGW gcc, non è stato testato o portato finora.

Puoi ottenere una versione gratuita di MSVC (per l'utilizzo di OpenSource) scaricando l'edizione "Community" di MS Visual Studio. Per fare ciò, utilizzare questo URL

https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=xx

dove xx è il numero di versione. Quindi per ottenere MSVC 15 (chiamato anche MSVC 2017), utilizzare questo URL:

https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=15

Per chi vuole evitare l'installazione completa dell'ingombrante MSVC al solo scopo di avere un compilatore può vedere Compilare in Windows - Occupare meno spazio.

Nota: Nonostante l'edizione Community di MSVC sia gratuita, è necessario creare un account Microsoft dall'IDE MSVC che è possibile utilizzare l'IDE per più di 30 giorni. Se compilerai solo usando la riga di comando, non hai bisogno dell'IDE e quindi non hai un account Microsoft.

Come IDE alternativo gratuito e OpenSource puoi usare KDevelop. Puoi usare KDevelop per modificare e scrivere codice C ++ ma devi usare la riga di comando per compilare.

Optional System Path Configuration

programmi in queste cartelle dalla riga di comando / powershell o se si desidera trovare programmi speciali da parte del compilatore o di CMake. Oltre a ciò, potrebbe essere necessario aggiungere cartelle al PERCORSO se non si sono utilizzate le opzioni corrispondenti durante l'installazione del programma.

  • Puoi includere la cartella del tuo LibPack nella variabile PATH del tuo sistema. Ciò è utile se prevedi di creare più configurazioni / versioni di FreeCAD.
  • Se non hai utilizzato l'opzione per aggiungere CMake al PERCORSO durante l'installazione, aggiungi la sua cartella di installazione

C:\Program Files\CMake\bin to the PATH.

  • Se non hai utilizzato l'opzione per aggiungere TortoiseGit al PERCORSO durante l'installazione, aggiungi la sua cartella di installazione

C:\Program Files\TortoiseGit\bin to the PATH.

Per aggiungere percorsi di cartelle alla variabile PATH:

  1. Nel menu Start di Windows, fai clic con il pulsante destro del mouse su "Computer" e scegli "Proprietà".
  2. Nella finestra di dialogo visualizzata, fai clic su "Impostazioni di sistema avanzate".
  3. Si aprirà un'altra finestra di dialogo. Fare clic lì nella scheda Avanzate in Variabili d'ambiente.
  4. Ancora una volta si aprirà un'altra finestra di dialogo. Seleziona quindi la variabile Percorso e fai clic su Modifica.
  5. E di nuovo si aprirà un'altra finestra di dialogo. Fai clic su Nuovo e aggiungi al percorso la cartella di Git o LibPack.
  6. Infine premi OK e chiudi tutte le finestre di dialogo premendo anche OK.

Configurazione

LibPack

All'inizio devi impostare una cartella di build:

  1. Crea una nuova cartella in cui dovrebbe essere compilato FreeCAD. Si consiglia vivamente di non inserire questa cartella nella cartella del codice sorgente di FreeCAD.
  2. Crea lì una nuova sottocartella per il LibPack. Nota: Il nome di questa sottocartella deve essere uguale al nome del file LibPack. Se ad es. il LibPack ha il nome file FreeCADLibs_12.1.4_x64_VC15.7z, devi nominare la sottocartella FreeCADLibs_12.1.4_x64_VC15.
  3. Estrai il LibPack in questa sottocartella.

CMake

Ora devi configurare l'ambiente di compilazione usando CMake:

  1. Apri la GUI di CMake
  2. Specificare lì la cartella di origine di FreeCAD
  3. Specifica la cartella di creazione che hai appena creato nel passaggio precedente.
  4. Fai clic su Configura
  5. Nella finestra di dialogo visualizzata specificare il generatore in base a quello che si desidera utilizzare. Per MS Visual Studio standard usa Visual Studio xx 2yyy dove xx è la versione del compilatore e 2yyy l'anno della sua uscita. Si consiglia di utilizzare l'opzione predefinita Usa compilatori nativi predefiniti.

Nota: È importante specificare la variante di bit corretta. Se hai la variante a 64 bit di LibPack devi usare anche il compilatore x64.

Questo avvierà la configurazione e fallirà a causa delle impostazioni mancanti.

Se non riesce con il messaggio che Visual Studio non è stato trovato, il supporto CMake in MSVC non è ancora installato. Per farlo:

  1. Apri l'IDE MSVC
  2. Utilizza il menu Strumenti → Ottieni strumenti e funzionalità
  3. Nella scheda Carichi di lavoro abilita Sviluppo desktop con C++
  4. Sul lato destro ora dovresti vedere che il componente Strumenti Visual C++ per CMake sarà installato.
  5. Installalo.

If it fails with a message about the wrong Python version or missing Python, then:

  1. Search in the CMake GUI for "Python"
  2. If you see there a path like C:/Program Files/Python38/python.exe, CMake recognized the Python that is already installed on your PC. Since the Python installation is important for different programs on your PC you should keep it as it is and adapt only the 4 different Python settings in CMake to these paths (assuming the LibPack is in the folder D:\FreeCAD-build\FreeCADLibs_12.3.2_x64_VC15):

CMake Python settings.png

Se non si verificano errori in Visual Studio o Python, va tutto bene, ma CMake non conosce ancora tutte le impostazioni necessarie. Pertanto ora:

  1. Assicurati che l'opzione di ricerca Avanzate sia selezionata.
  2. Cerca in CMake la variabile FREECAD_LIBPACK_DIR e specifica la posizione corretta nella cartella LibPack.
  3. Cerca la variabile BUILD_QT5 e abilita questa opzione.
  4. Fai di nuovo clic su Configura

Ora non dovrebbero esserci errori. In tal caso, fai clic su Genera. Al termine, è possibile chiudere CMake e continuare ad avviare la compilazione di FreeCAD. Tuttavia, per la prima compilazione tienilo aperto per il caso che desideri o devi modificare alcune opzioni per il processo di compilazione:

Opzioni per il processo di compilazione

Il sistema di generazione CMake offre la flessibilità necessaria per il processo di creazione. Ciò significa che è possibile attivare e disattivare alcune funzionalità o moduli tramite le variabili CMake.

Ecco una descrizione di alcune di queste variabili:

Link table
Nome variabile Descrizione Predefinito
BUILD_XXX Crea FreeCAD con il componente XXX. Se non si desidera / è necessario compilare ad es. il workbench OpenSCAD, disabilita la variabile BUILD_OPENSCAD. FreeCAD non avrà quindi questo banco di lavoro.

Nota: Alcuni componenti sono richiesti per altri componenti. Se ad esempio deselezioni BUILD_ROBOT CMake ti informerà che il componente Percorso non può essere compilato correttamente. Quindi controlla l'output di CMake dopo aver modificato un'opzione BUILD_XXX! || dipende

CMAKE_INSTALL_PREFIX La cartella di output durante la creazione della destinazione INSTALL, vedere anche la sezione Esecuzione e installazione di FreeCAD Windows' Cartella di installazione del programma predefinita di Windows
FREECAD_COPY_DEPEND_DIRS_TO_BUILD Copia le librerie dipendenti necessarie per eseguire FreeCAD.exe nella cartella build. Vedi anche la sezione Esecuzione e installazione di FreeCAD.
Nota: le opzioni FREECAD_COPY_XXX compaiono solo se le librerie non sono ancora state copiate. Quindi, quando si passa a un'altra versione di LibPack, è importante eliminare tutte le cartelle nella cartella di compilazione, ad eccezione della cartella LibPack. In CMake eliminare la cache e iniziare come se si compilasse per la prima volta e si otterranno le opzioni FREECAD_COPY_XXX.
OFF
FREECAD_COPY_LIBPACK_BIN_TO_BUILD Copia i binari di LibPack necessari per eseguire FreeCAD.exe nella cartella build. Vedere anche la sezione Esecuzione e installazione di FreeCAD. OFF
FREECAD_COPY_PLUGINS_BIN_TO_BUILD Copia i file del plugin di Qt necessari per eseguire FreeCAD.exe nella cartella build. Vedere anche la sezione Esecuzione e installazione di FreeCAD. OFF
FREECAD_LIBPACK_USE Cambia l'utilizzo di FreeCAD LibPack on o off ON
FREECAD_LIBPACK_DIR Directory in cui si trova il LibPack Cartella del codice sorgente di FreeCAD
FREECAD_RELEASE_PDB Crea librerie di debug anche per build di rilascio ON

Costruzione di FreeCAD

A seconda del compilatore, il processo per la creazione di FreeCAD sarà leggermente diverso. Nelle sezioni seguenti sono descritti i flussi di lavoro noti. Se stai costruendo con Qt Creator, passa a Building with Qt Creator, altrimenti procedi direttamente:

Compilare con Visual Studio 15 2017, e Visual Studio 16 2019

  1. Avvia l'IDE di Visual Studio. Questo può essere fatto premendo il pulsante Apri progetto nella GUI di CMake o facendo doppio clic sul file FreeCAD.sln che trovi nella cartella di compilazione.
  2. Nella barra degli strumenti dell'IDE MSVC assicurati di utilizzare per la prima compilation Release.
  3. C'è una finestra chiamata Solution Explorer. Essa elenca tutti i possibili target di compilazione.

Per iniziare una compilation completa, fai clic con il tasto destro del mouse sul target ALL_BUILD e quindi scegli Build. Questo richiederà ora molto tempo.

Per compilare un FreeCAD pronto all'uso, compila la destinazione INSTALLA , vedi sezione Running and installing FreeCAD.

Se non ricevi errori, hai finito. Congratulazioni! Puoi uscire da MSVC o tenerlo aperto.

Video Resource

An English language tutorial that begins with configuration in CMake Gui and continues to the `Build` command in Visual Studio 16 2019 is available unlisted on YouTube at Tutorial: Build FreeCAD from source on Windows 10.

Costruire con Visual Studio 12 2013

Assicurati di specificare Visual Studio 12 x64 (o il C-Compiler alternativo che stai utilizzando) come generatore in CMake prima di continuare.

  • Avviare Visual Studio 12 2013 facendo clic sull'icona del desktop creata durante l'installazione.
  • Apri il progetto da:

File → Open → Project/Solution

  • Aprire FreeCAD_Trunk.sln dalla cartella di creazione creata da CMake
  • Passa al menu a discesa Configurazione soluzioni in alto a Rilascia X64

Questo potrebbe richiedere del tempo a seconda del sistema

  • Build → Build Solution
  • Ci vorrà molto tempo ...

Se non ricevi errori, hai finito. Uscire da Visual Studio e avviare FreeCAD facendo doppio clic sull'icona di FreeCAD nella cartella bin della directory di build.

Costruire con Qt Creator (obsoleto)

Installazione e configurazione di Qt Creator

  • Scarica e installa Qt Creator
  • Strumenti → Opzioni → Editor di testo → scheda Comportamento:
    • Codifica dei file → Codifiche predefinite:
    • Impostato su: ISO-8859-1 /...csISOLatin1 (Alcuni caratteri creano errori / avvertimenti con Qt Creator se lasciato impostato su UTF-8. Questo sembra risolverlo.)
  • Strumenti → Opzioni → Crea ed esegui:
    • Scheda CMake
      • Riempi la casella Eseguibile con il percorso di cmake.exe
    • Scheda Kit
      • Nome: MSVC 2008
      • Compilatore: Microsoft Visual C++ Compiler 9.0 (x86)
      • Debugger: rilevato automaticamente ...
      • Versione Qt: Nessuna
    • Scheda Generale
      • Deselezionare: crea sempre un progetto prima di distribuirlo
      • Deselezionare: distribuire sempre il progetto prima di eseguirlo

Importa progetto e crea

  • File → Apri file o progetto
  • Apri CMakeLists.txt che si trova nel livello più alto della fonte
  • Questo avvierà CMake
  • Scegli la cartella di costruzione e fai clic su Avanti
  • Imposta generatore su NMake Generator (MSVC 2008)
  • Clicca Esegui CMake. Segui le istruzioni illustrate sopra per configurare CMake a tuo piacimento.

Ora è possibile creare FreeCAD

  • Build → Build All
  • Ci vorrà molto tempo ...

Una volta completato, può essere eseguito: Ci sono 2 triangoli verdi in basso a sinistra. Uno è il debug. L'altro è eseguito. Scegli quello che vuoi.

Configurazione della riga di comando

I passaggi su come compilare dalla riga di comando dipendono dal compilatore. Per MSVC 2017 i passaggi sono:

  1. Nel menu Start di Windows vai a Visual Studio 2017 → Visual Studio Tools e scegli Prompt dei comandi per sviluppatori per VS 2017
  2. Passa alla tua cartella di build.
  3. Eseguire il comando
msbuild ALL_BUILD.vcxproj /p:Configuration=Release

o

msbuild INSTALL.vcxproj /p:Configuration=Release

Questi passaggi possono anche essere automatizzati. Ecco ad esempio una soluzione per MSVC 2017:

  1. Scarica lo script compile-FC.txt.
  2. Rinominalo in compile-FC.bat
  3. In Esplora file Shift di Winddows + Fare clic con il tasto destro del mouse sulla cartella di creazione e utilizzare dal menu di scelta rapida "Prompt dei comandi qui".
  4. Eseguire il comando
compile-FC install

Invece di chiamare compile-FC con l'opzione installa puoi anche usare debug o release:

debug   - compila FreeCAD nella configurazione di debug

release - compilare FreeCAD nella configurazione della versione

install    - compilare FreeCAD nella configurazione di rilascio e creare un'installazione di installazione

Esecuzione e installazione di FreeCAD

Esistono 2 metodi per eseguire FreeCAD compilato:

Metodo 1: Esegui FreeCAD.exe che trovi nella cartella di compilazione nella sottocartella bin

Metodo 2: costruisci il target INSTALL

Il metodo 2 è quello più semplice perché assicura automaticamente che tutte le librerie necessarie per eseguire FreeCAD.exe siano nella cartella corretta. FreeCAD.exe e le librerie verranno emessi nella cartella specificata nella variabile CMakeCMAKE_INSTALL_PREFIX.

Per il Metodo 1 devi mettere le librerie nella cartella bin della tua cartella di build (dove si trova FreeCAD.exe). Questo può essere fatto facilmente:

  1. Apri la GUI di CMake.
  2. Cerca lì l'opzione variabile FREECAD_COPY_DEPEND_DIRS_TO_BUILD e controllala. Se non esiste tale opzione, le librerie sono già state copiate, vedere la descrizione delle opzioni
  3. Cerca lì l'opzione variabile FREECAD_COPY_LIBPACK_BIN_TO_BUILD e controllala.
  4. Cerca lì l'opzione variabile "FREECAD_COPY_PLUGINS_BIN_TO_BUILD" e controllala.
  5. Fare clic su Configura. Al termine della configurazione CMake copierà automaticamente le librerie necessarie dalla cartella LibPack.

Per FreeCAD 0.19 esiste attualmente un solo problema che richiede un'azione manuale:

  1. Scarica il file qwindowsvistastyle.zip dal forum di FreeCAD.
  2. Crea una nuova sottocartella denominata stili nella cartella bin (dove si trova FreeCAD.exe).
  3. Estrai il file ZIP in questa cartella.

Questo aggiunge lo stile necessario per rendere FreeCAD simile a un normale programma Win 10. Altrimenti sembra in Windows 98.

Aggiornamento della build

FreeCAD è sviluppato molto attivamente. Pertanto il suo codice sorgente cambia quasi quotidianamente. Nuove funzionalità vengono aggiunte e i bug corretti. Per beneficiare di queste modifiche al codice sorgente, è necessario ricostruire FreeCAD. Questo avviene in due fasi:

  1. Aggiornamento del codice sorgente
  2. Ricompilazione

Aggiornamento del codice sorgente

Usando un frontend

Quando si utilizza il Git frontend TortoiseGit:

  1. Fare clic con il tasto destro del mouse sulla cartella del codice sorgente di FreeCAD in Esplora file di Windows e selezionare nel menu di scelta rapida 'Pull' .
  2. Apparirà una finestra di dialogo. Seleziona lì quale ramo di sviluppo vuoi ottenere. master è il ramo principale. Pertanto utilizzare questo a meno che non si desideri compilare una nuova funzionalità speciale da un ramo che non è stato ancora unito a "master". (Per ulteriori informazioni sui rami Git, vedere Git development process.)

Finalmente clicca OK.

Utilizzando la riga di comando

Apri un terminale (prompt dei comandi) e passa alla directory di origine. Quindi digitare:

git pull https://github.com/FreeCAD/FreeCAD.git master

dove master è il nome del ramo di sviluppo principale. Se vuoi ottenere il codice da un altro ramo, usa il suo nome invece di master.

Ricompilazione

  1. Apri l'IDE MSVC facendo doppio clic sul file FreeCAD.sln o sul file ALL_BUILD.vcxproj nella cartella di compilazione.
  2. Continua con il passaggio 2 dalla sezioneBuilding with Visual Studio 15 2017.

Tools

In order to join the FreeCAD development you should compile and install the following tools:

Qt Designer plugin

FreeCAD uses Qt as toolkit for its user interface. All dialogs are setup in UI-files that can be edited using the program Qt Designer that is part of any Qt installation and also included in the LibPack. FreeCAD has its own set of Qt widgets to provide special features like adding a unit to input fields and to set preferences properties.

Installation

To make Qt Designer aware of the FreeCAD widgets, you must

  1. Download this ZIP file. (Compiled using Qt 5.12, see below.)
  2. Extract the DLL file in the ZIP and copy it
  • If you use the LibPack: to the folder
    ~\FreeCADLibs_12.1.4_x64_VC15\bin\designer
    Since there will only be a bin folder and you must first create the designer subfolder.
  • If you have a full Qt installation: you can choose between the folder
    C:\Qt\Qt5.12.5\5.12.5\msvc2017_64\plugins\designer
    or
    C:\Qt\Qt5.12.5\5.12.5\msvc2017_64\bin\designer
    (adapt the paths to your installation!).

(Re)Start Qt Designer and check its menu Help → Plugins. If the plugin FreeCAD_widgets.dll is listed as being loaded, you can now design and change FreeCAD's .ui files. If not, you must compile the DLL by yourself.


If you prefer using Qt Creator instead of Qt Designer, the DLL must be placed in this folder:
C:\Qt\Qt5.12.5\Tools\QtCreator\bin\plugins\designer
(Re)Start Qt Creator, switch to the mode Design and then check the menu Tools → Form Editor → About Qt Designer Plugins. If the plugin FreeCAD_widgets.dll is listed as being loaded, you can now design and change FreeCAD's .ui files. If not, you must compile the DLL by yourself.

Compilation

The DLL cannot be loaded as plugin if it was compiled using another Qt version than the one your Qt Designer/Qt Creator is based on. In this case you must compile the DLL by yourself. This is done the following way:

  1. Change to the FreeCAD source folder
    ~\src\Tools\plugins\widget
  2. Open a MSVC x64 command prompt using the Windows Start menu and change within it to the above folder. It is important that it is the x64 version of the MSVC command prompt!
  3. Execute this command
    qmake -t vclib plugin.pro
    
    If qmake could not be found, use the full path to it, e.g. for the LibPack it should be this one (adapt it to your installation):
    D:\FreeCAD-build\FreeCADLibs_12.1.4_x64_VC15\bin\qmake -t vclib plugin.pro
    for a full Qt installation it is
    C:\Qt\Qt5.12.5\5.12.5\msvc2017_64\bin\qmake -t vclib plugin.pro
    (adapt the paths to your installation!)
  4. The call of qmake created the file FreeCAD_widgets.vcxproj in the folder ~\src\Tools\plugins\widget. Double-click on it and the MSVC IDE will open.
  5. In the toolbar of the MSVC IDE assure that you use the compilation target Release.
  6. There is a window called Solution Explorer. Right-click there on FreeCAD_widgets and then choose Build.
  7. As result you should now have a FreeCAD_widgets.dll in the folder ~\src\Tools\plugins\widget\release that you can install as plugin as described above.

Thumbnail Provider

FreeCAD has the feature to provide preview thumbnails for *.FCStd files. That means that in the Windows file explorer *.FCStd files are shown with a screenshot of the model it contains. To provide this feature, FreeCAD needs to have the file FCStdThumbnail.dll installed to Windows.

Installation

The DLL is installed this way:

  1. Download this ZIP file and extract it.
  2. Open a Windows command prompt with administrator privileges (these privileges are a requirement).
  3. Change to the folder where the DLL is.
  4. Execute this command
    regsvr32 FCStdThumbnail.dll
    

So check if it works, assure that in FreeCAD the preferences option Save thumbnail into project file when saving document is enabled and save a model. Then view in Windows Explorer the folder of the saved model using a symbol view. You should now see a screenshot of the model in the folder view.

Compilation

To compile the FCStdThumbnail.dll

  1. Change to the FreeCAD source folder
    ~\src\Tools\thumbs\ThumbnailProvider
  2. Open the CMake GUI
  3. Specify there as source folder the one you are currently in.
  4. Use the same folder as build folder.
  5. Click Configure
  6. In the appearing dialog, specify the generator according to the one you want to use. For the standard MS Visual Studio use Visual Studio xx 2yyy where xx is the compiler version and 2yyy the year of its release. It is recommended to use the default option Use default native compilers.
    Note: It is important to specify the correct bit variant. If you have the 64bit variant of LibPack you must also use the x64 compiler.
  7. Click on Generate.
  8. You should now have the file ALL_BUILD.vcxproj in the folder ~\src\Tools\thumbs\ThumbnailProvider. Double-click on it and the MSVC IDE will open.
  9. In the toolbar of the MSVC IDE assure that you use the compilation target Release.
  10. There is a window called Solution Explorer. Right-click there on ALL_BUILD and then choose Build.
  11. As result you should now have a FCStdThumbnail.dll in the folder ~\src\Tools\thumbs\ThumbnailProvider\release that you can install as described above.

Riferimenti

Vedere anche

Arrow-left.svg Smistamento dei bug Pagina precedente:
Pagina successiva: Compilazione in Linux Arrow-right.svg