Flugzeug

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Aeroplane and the translation is 76% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎čeština • ‎русский • ‎中文(台灣)‎

Base ExampleCommandModel.png Tutorial

Thema
Part Arbeitsbereich
Niveau
Anfänger
Zeit zum Abschluss
10 Minuten
Autor
Hughthecat
FreeCAD version
Beispieldatei(en)


Erste Schritte

Wir arbeiten in diesem Tutorial mit dem Arbeitsbereich Workbench Part.svg Part Arbeitsbereich - wähle es aus den Menüs über Ansicht → Arbeitsbereich → Part oder über den Arbeitsbereich Auswahl.

  • Erstelle ein neues leeres Dokument.
  • Wechsle in die axonometrische Ansicht.
  • Schalte das Achsenkreuz ein ON (über Ansichtsmenü).
  • Stelle sicher, dass die combo Ansicht angezeigt wird (über Ansicht → Ansichten).
  • Erstelle einen Zylinder, durch Klicken auf die Part Cylinder.svg Zylinder Taste.
  • Wähle es aus, durch Klicken auf Zylinder in der Projektansicht.
  • Klicke auf den Datenreiter in der Projektansicht.

Ändere die Höhe auf 20 mm und den Radius auf 2 mm.

Klicke auf Platzierung (beachte das kleine [+]) und eine Schaltfläche mit drei Punkten erscheint .... Klicke darauf. (Du kannst auch wählen: Menü → Bearbeiten → Platzierung) Die Aufgabenanzeige erscheint.

HTCaeroplane01.png

Wenn du mit den XYZ Achsen nicht vertraut bist, dann spiele mit den Zahlen im Übersetzungsfeld. Wenn die Wiedergabe beendet ist, klicke auf die Reset Schaltfläche.

Weitere Schritte

HTCaeroplane02.png

Wir werden den Zylinder nun so drehen, dass er auf der X Achse liegt. Dazu muss er um die Y Achse gedreht werden. Im Feld Drehung sollte "Drehachse mit Winkel" stehen. Ändere also die Achse auf Y und erhöhe den Winkel, bis er 90 erreicht. Klicke auf OK.

Ich spiele an dieser Stelle gerne (und oft!) mit dem Drehen der Ansicht, also tue das unbedingt. Du solltest die 'Naht' des Zylinders auf der Unterseite finden.


HTCaeroplane03.png

Wir werden nun einen Quader hinzufügen und verändern, also klicke auf die Schaltfläche Part Box.pngQuader. Wähle ihn durch anklicken des Quaders in der Projektansicht aus. Ändere die Höhe auf 1 mm, die Länge auf 5 mm und die Breite auf 20 mm.

Klicke auf Platzierung → ..., um die Aufgabenansicht zu erhalten. Gib in das Übersetzungsfeld Y: -10 und Z: -1 ein. Klicke auf OK

Wir werden nun beide Objekte miteinander verschmelzen, indem wie eine Bool'sche Operation anwenden. Klicken Sie dazu auf die Schaltfläche Boolesche Operation Part Booleans.png. Es sollte anschließend eine neue Ansicht zu sehen sein.

Stellen Sie sicher, dass oben die Vereinigung aktiviert ist und dass der Zylinder und die Box in jeweils einer der beiden Listen aktiviert sind. Klicken Sie auf Anwenden und auf Schließen. Das Ergebnis sollte ein einziges Objekt namens "Fusion" im Modellbaum sein.


Lass uns noch einen weiteren Quader einfügen, um das Modell zu vervollständigen. Erstellen Sie wie zuvor einen Würfel, wählen Sie ihn im Modellbaum aus und ändern Sie die Höhe in 5 mm, die Länge in 3 mm und die Weite in 1 mm. Zusätzlich muss der neue Quader um -0.5 mm in Y-Richtung verschoben werden.

Wiederum wollen wir das neue Objekt mit den alten verschmelzen. Wählen Sie dazu beide Objekte ("Fusion" und "Würfel001") im Modellbaum bei gedrückter Strg-Taste aus und klicken Sie auf die Schaltfläche Vereinigung Part Union.png. Das Resultat sollte eine neues Objekt namens "Fusion001" sein.

Sie haben nun ein einfaches Modell eines Flugzeugs. Mit einem Rechtsklick auf "Fusion001" können Sie es in "Flugzeug" umbenennen.

HTCaeroplane04.png

Meiner Ansicht nach müssen die Flügel noch etwas weiter nach vorne verschoben werden. Beim Auswählen des Flugzeugs und ändern der X-Koordinate verschiebt sich jedoch das ganze Objekt.

Öffnen Sie die Hierarchie des Objekts "Flugzeug" mit einem Klick auf den grauen Pfeil links neben dem Objekt im Modellbaum und dasselbe wiederholen Sie für das Objekt "Fusion".

Klicken Sie auf "Würfel" und wechseln Sie anschließend in die Placement-Ansicht zum Verschieben und Drehen des Objektes. Beachten Sie, dass Y:-10 und Z:-1 bei der Verschiebung eingetragen sind. Der Wert für X muss noch in X:3 mm geändert werden und mit einem Klick auf Anwenden wird die Ansicht aktualisiert. Das Ergebnis sieht schon viel besser aus. Klicken Sie auf OK.


Drehungen

Klicken Sie auf das Objekt "Flugzeug" und wechsel Sie wieder in die Ansicht Placement. In der Box "Rotation" muss nun die Option Euler Winkel ausgewählt werden, denn diese vereinfachen die nachfolgenden Schritte.

Tache Placement Lacet fr Mini.gif
Gierung ist die Drehung um die Z-Achse, also eine Drehung von links nach rechts (der Gierungswinkel ist der Winkel Psi ψ).
Tache Placement Tangage fr Mini.gif
Steigung ist die Drehung um die Y-Achse, also nach oben und nach unten (der Steigungswinkel ist der Winkel Phi φ).
Tache Placement Roulis fr Mini.gif
Roll ist die Drehung um die X-Achse, also das Absenken eines Flügels und gleichzeitiges Erhöhen des anderen Flügels (der Rollwinkel ist der Winkel Thêta θ).


Es gibt jedoch auch hier einige wichtige Sachen, die man in Erinnerung behalten sollte:

  • Positive Drehungen sind im Uhrzeigersinn, wenn man vom Koordinatenursprung in Richtung einer positiven Achse blickt. Oder anders ausgedrückt: Positive Drehungen sind gegen den Uhrzeigersinn, wenn man von der positiven Achse auf den Koordinatenursprung blickt.
  • Obwohl die drei Bezeichnungen Gierung, Nicken und Rollen sind, stimmt das nicht wirklich. Gierung, Nicken und Rollen sind Referenzen zu den "Rumpfkoordinaten" eines Objekts im 3D-Raum. Die Bezeichnungen sollten Kurs, Höhe und Kurvenlage sein oder sogar Drehwinkel, Neigung und Querneigung, weil sie sich tatsächlich auf die "Raumkoordinaten" des 3D-System beziehen. Dies sind die "Tait-Bryan-Winkel". Mehr Informationen finden Sie unter [1] bzw. [2].
  • Bei dem Flugzeug in seiner gegenwärtigen Position gelten einfache Regeln. Gierung ist die Rotation um die Z-Achse, also links und rechts. Nicken ist Rotation um die Y-Achse, also Nase hoch und runter. Rollen ist Rotation um die X-Achse, also Flügel auf und ab. Das stimmt für den Anfang, aber später ist das nicht mehr zutreffend!

Spielen Sie ein wenig mit den YPR-Zahlen. Sie brauchen die Werte nur um ein paar Grad zu ändern, um ein Gefühl dafür zu bekommen. Setzen Sie sie zurück, wenn Sie fertig sind.

Jetzt werden wir sehen, warum die Gieren-Nicken-Rollen-Bezeichnungen nicht wirklich zutreffen. Ändern Sie den Rollen-Wert auf 90°. Gieren sollte die Nase des Flugzeugs hoch und runter bewegen und Nicken sollte es hin und her bewegen "von außerhalb des Flugzeugs gesehen", was uns Position betrifft. Stimmt das? Nein! Nicken ändert das Gieren und Gieren ändert das Nicken. Ok, zurücksetzen.

Eine bessere Beschreibung von Rotationen ist, dass Gieren Ihre geografische Länge (longitude) verändert, Nicken Ihre geografische Breite (latitude) und Rollen die Richtung (Nord, Süd, Ost, West), in die Sie fliegen. Oder Sie lesen Axes conventions (en) für weitere Beschreibungen.

Ok, zurück zum Thema. Ändern Sie Gieren auf 45° und Nicken auf -30°. Klicken Sie auf OK zur Ausführung der Operation. Gehen Sie zurück zur Placement Task und schauen Sie auf die Rotationsbox. Sie ist zurückgekehrt zu 'Rotation axis with angle' und zeigt einige merkwürdige Achsen- und Winkelwerte. Meine hatte Achsenwerte: (0.219493,-0.529904,0.819161) und Winkel: 53.65°. Die drei Werte in Klammern sind die XYZ-Komponenten eines Einheitenvektors im 3D-Raum. Das ist die Achse, um die unser ursprüngliches Flugzeug zu unserem endgültigen Flugzeug gedreht wurde. Der Winkel gibt an, wie sehr es gedreht wurde. Clever, oder, aber nicht sehr freundlich! Es war Euler, der zeigte, dass Sie eine Reihe von XYZ-Rotationen zusammenfassen können in eine Rotation über eine Achse.

Hier gibt es weitere Vorschläge für das Spielen mit dem Flugzeug:

  • Ändern Sie die Z-Lokation (und bestätigen Sie), ändern Sie dann die YPR-Werte und schauen Sie sich die Auswirkung an. Dann versuchen Sie, die X- und Y-Lokation und die Rotation zu ändern.
  • Ändern Sie das X-Zentru (und bestätigen Sie), ändern Sie dann die YPR-Werte und schauen Sie sich die Auswirkung an. Dann versuchen Sie, die Y- und Z-Zentren und die Rotation zu ändern.

Ich hoffe, dass dieses kleine Tutorial Ihnen geholfen hat, ein Gefühl für Rotationen zu bekommen.


Template:Tutorials navi/de